Preseed differences between USB boot en PXE

Help with issues regarding installation of Debian

Preseed differences between USB boot en PXE

Postby Faust » 2018-05-20 22:54

I have a bit of a strange issue with booting with a preseed file using PXE. Hopefully someone can help me figure out what's going on, since I'm out of ideas.

Background
I'm building a setup for a fully automated install of several laptops, that all need the same configuration, and will need to be reinstalled regularly. To do this, I have chosen to use PXE boot over a network, with a TFTP server hosting all necessary files, one of which is a preseed. The whole thing is set up in such a way that you only need to plug the machine in and boot it, and it'll go through the install fully automatically (no user interaction needed at all) and shut itself down when finished. The install uses one large encrypted partition on an SSD.

Issue 1
As these laptops use SSDs, I don't want the installer to overwrite the old partition with random data, as this would negatively impact the health of the SSD. This is why I included the following in the preseed:
Code: Select all
d-i partman-auto-crypto/erase_disks boolean false
Now, this works fine when I boot the system off a USB drive, and point it to the preseed manually (no overwriting happens). However, when I switch the system to PXE boot over the network, with the same preseed file, all of a sudden the partition gets overwritten with random data before new partitioning every time. So it seems the code isn't working for some reason when using PXE, but I can't figure out why.

Issue 2
I want the system to be installed with XFCE desktop. It does this by using the preseed as well:
Code: Select all
tasksel tasksel/first multiselect xfce-desktop
Again, when I boot from USB and point to the preseed manually, this works just fine, installing XFCE fully. However, over PXE some elements of XFCE seem to be missing, such as the whisker menu. Again, I have no clue why this is suddenly different.

If anyone has any ideas as to what I'm doing wrong (or why there are differences between USB and PXE boot), I'd love to hear it. Any solutions and suggestions are welcome. Please let me know if you need any more information. My preseed can be found HERE.

Thanks in advance!
Faust
 
Posts: 3
Joined: 2018-05-20 22:17

Return to Installation

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable