PXE Install: Failed to load ldlinux.c32

Help with issues regarding installation of Debian

PXE Install: Failed to load ldlinux.c32

Postby Faust » 2018-06-06 14:26

I've been trying to get a working PXE install for Debian going, fully automated with preseed file. I'm using the netboot.tar.gz from the US Debian FTP. Since I've been working on this for quite a while, I've been doing some things at home. Here I managed to get the PXE boot to work, but on my work network, I just can't get it to boot.

At home I have an ASUS router (for DHCP) and a NAS (for TFTP). I configured my ASUS router with the following line:
Code: Select all
dhcp-boot=pxelinux.0,,192.168.1.10

192.168.1.10 is the address of the NAS, functioning as a TFTP server. With this configuration, everything works perfectly. I connect the machine turn it on, and it runs through the install.

Porting this configuration to our network at work, we had to change things a little, since we use ICS DHCP server, which also functions as a TFTP server. Here, our config is as follows:
Code: Select all
next-server 10.1.1.12;
option bootfile-name "pxelinux.0";

10.1.1.12 is the address of the DHCP/TFTP server. When I do this and try to boot, I keep getting and error saying "Failed to load ldlinux.c32", followed by a boot failure. See screenshot below (click for larger image):
Image

I can't find and y useful resources out there as to what might be going wrong. Hopefully someone here can help me out. Let me know if you need any more information.
Faust
 
Posts: 2
Joined: 2018-05-20 22:17

Re: PXE Install: Failed to load ldlinux.c32

Postby jmgibson1981 » 2018-06-07 13:58

Code: Select all
filename "/pxelinux.0";


Is what I have on my pxe boot server at home. Works for me.

Also I don't think ISC-DHCP-Server works as a TFTP server. For me I had to install tftpd-hpa.
jmgibson1981
 
Posts: 48
Joined: 2015-06-07 14:38


Return to Installation

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable