Stretch doesn't detected RAID virtual drive

Help with issues regarding installation of Debian

Stretch doesn't detected RAID virtual drive

Postby orsomannaro » 2018-09-08 06:16

I'm running Proxmox VE 3.4 (based on Debian Wheezy) on a server with RS2WC040 Intel RAID controller.

Code: Select all
# lspci -v | grep -i raid


Code: Select all
01:00.0 RAID bus controller: LSI Logic / Symbios Logic MegaRAID SAS 2008 [Falcon] (rev 03)
   Subsystem: Intel Corporation RAID Controller RS2WC040
   Kernel driver in use: megaraid_sas
   Kernel modules: megaraid_sas


Trying to install Proxmox VE 5.2 (based on Debian Stretch), installation process shows "The installer could not find a supported hard disk".

So I tried to directly install Debian Stretch, using this iso:
  • debian-9.5.0-amd64-netinst.iso (official netinst)
  • firmware-9.5.0-amd64-netinst.iso (unofficial/non-free/cd-including-firmware netinst)

In both cases installation process show "no disk drive was detected" message (obviously I select megaraid_sas - and some others - when asked to try a specific driver).

Can someone help me with this problem?

Intel release a Suse driver for RS2WC040 (https://downloadcenter.intel.com/product/43165/Intel-RAID-Controller-RS2WC040): have I to install this (alien conveted) driver during installation?


Thanks!
orsomannaro
 
Posts: 4
Joined: 2018-09-08 05:30

Re: Stretch doesn't detected RAID virtual drive

Postby L_V » 2018-09-08 06:39

If BIOS is correctly configured for RAID, looks very likely that a module/firmware is not found during Netinstall.
You should first check if what you need is really embedded in "unofficial/non-free/cd-including-firmware Netinst."
L_V
 
Posts: 771
Joined: 2007-03-19 09:04

Re: Stretch doesn't detected RAID virtual drive

Postby orsomannaro » 2018-09-08 06:56

L_V wrote:If BIOS is correctly configured for RAID


Yes, in fact current Proxmox installation works fine.

L_V wrote:You should first check if what you need is really embedded


And if it is not? Is there another Debian iso image to try?
orsomannaro
 
Posts: 4
Joined: 2018-09-08 05:30

Re: Stretch doesn't detected RAID virtual drive

Postby L_V » 2018-09-08 07:10

Don't think you can directly find an iso for your configuration.
Firmwares should be correctly added on a USB key, and Netinstall should ask if you need specific firmwares.

2.2. Devices Requiring Firmware
https://www.debian.org/releases/stable/ ... 02.html.en
https://wiki.debian.org/DebianInstaller/NetbootFirmware
https://wiki.debian.org/DebianInstaller/NetbootFirmware
http://cdimage.debian.org/cdimage/unoff ... e/current/

+ I wonder if you should not launch Netinstall in so called "expert mode" which offers more options.
→ add "priority=low" as kernel option
L_V
 
Posts: 771
Joined: 2007-03-19 09:04

Re: Stretch doesn't detected RAID virtual drive

Postby orsomannaro » 2018-09-10 07:37

I'm using DVD non-free iso (firmware-9.5.0-amd64-DVD-1.iso) and a USB (fat32) with non-free firmware (even if iso has megaraid_sas driver ...).

Expert mode installer doesn't recognize the RAID virtual disk and it say that the USB doesn't have module compatible with used kernel, I try both current and stretch archives). (see attachments)

Any suggestions?
orsomannaro
 
Posts: 4
Joined: 2018-09-08 05:30

Re: Stretch doesn't detected RAID virtual drive

Postby orsomannaro » 2018-09-10 10:51

I ask to Intel and the answer is: "there is no driver to use with this Linux version". Indeed Wheezy uses LSI megaraid_sas driver.

Is it possible that megaraid_sas driver works with Wheezy and doesn't works with Stretch?
orsomannaro
 
Posts: 4
Joined: 2018-09-08 05:30


Return to Installation

Who is online

Users browsing this forum: Bloom and 3 guests

fashionable