Error while installing NVIDIA GT 530 driver (v. 390.87)

Help with issues regarding installation of Debian

Error while installing NVIDIA GT 530 driver (v. 390.87)

Postby upzb » 2018-09-11 19:08

I am currently trying to install a driver (version 390.87) for a NVIDIA Geforce 530, but at the end of the installation (after running sudo sh NVIDIA-Linux-x86_64-390.87.run) I keep getting the following ERROR message on a blue window over a black:

ERROR: Unable to find the development tool "make" in your path; please make sure that you have the package "make" installed. If make is installed in your system, then please check that "make" is in your PATH.


I have deleted the driver instalation program and download it again from the NVIDIA official website, but I keep having the same problem.
How can I install "make" or see if I already have it? Have any of you had any similar problem?

Thank you very much.
upzb
 
Posts: 1
Joined: 2018-09-11 17:48

Re: Error while installing NVIDIA GT 530 driver (v. 390.87)

Postby Dai_trying » 2018-09-11 19:41

Version 390.77-1~bpo9+1 is available from Stretch-backports (non-free) which is usually an easier route, I use the 384.130-1 version from the stable repo for my GTS 450 card and it works just fine.

A quick check on the Debian Wiki tells me your card is supported with the stable driver.
Dai_trying
 
Posts: 557
Joined: 2016-01-07 12:25

Re: Error while installing NVIDIA GT 530 driver (v. 390.87)

Postby stevepusser » 2018-09-11 21:02

You need basic compiling tools and kernel headers before you can compile the driver for your kernel. I would suggest you follow the Debian's wiki directions on how to install the drivers from the non-free repo section, except you can install the build-dependences easier:

install module-assistant.

As root or with sudo, run
Code: Select all
m-a prepare
.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Quod Libet 4.2.0, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Liquorix kernel 4.18-22, Midori 6.0
User avatar
stevepusser
 
Posts: 10126
Joined: 2009-10-06 05:53


Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable