Debian install fails with UEFI only support

Help with issues regarding installation of Debian

Debian install fails with UEFI only support

Postby ticapix » 2018-09-12 09:25

Hello,

I'm having difficult time to start the installation process of Debian 9.5 (I tried 8.11 too) on a beelink X55 (www.bee-link.com/Beelink-MiniPC-TV-BOX-114-1.html) and VBook A1 celeron (http://en.myvoyo.com/xiazai/Win%20Pad/VBOOK_A1/), two recent mini-pc.
I'm using the debian-9.5.0-amd64-netinst.iso. I tried rufus, unetbootin, etcher, dd, cp, 2 different usb dongles but the results are the same on both PC.
In the BIOS, Secure boot and fast boot are disabled. There is no CSM option.

I can select the USB dongle in the UEFI boot menu (after the hardware manufacturer splash screen) https://imgur.com/PKqsCet and as soon as I press enter, I get a black screen with a non-blinking white cursor on the top left corner. https://imgur.com/gwfpH8K

I can't access grub menu.

It's also not working for system based on debian, like proxmox (https://www.proxmox.com/en/).

On the other hand, I managed to install Ubuntu server 18.04 and Centos 7, on both pc.

After I burnt the debian iso on my USB, what is the partition scheme I'm supposed to have ?
Any other idea ?

Thank you,
ticapix
 
Posts: 3
Joined: 2018-09-10 18:40

Re: Debian install fails with UEFI only support

Postby Segfault » 2018-09-12 11:56

Did you run isohybrid with -u option?
Segfault
 
Posts: 759
Joined: 2005-09-24 12:24

Re: Debian install fails with UEFI only support

Postby ticapix » 2018-09-12 21:19

Not before today.
I did try now but same effect.
ticapix
 
Posts: 3
Joined: 2018-09-10 18:40


Return to Installation

Who is online

Users browsing this forum: jwsarge2 and 8 guests

fashionable