No Bootable Device Found / Error While Mounting

Help with issues regarding installation of Debian

Re: No Bootable Device Found / Error While Mounting

Postby Olympiq » 2018-10-15 05:26

For EFI Part
Code: Select all
# mount -r /dev/mmcblk0p1 /mnt
# mount -o remount,rw /cdrom
# ls /mnt >/cdrom/efipart.txt
# sync (this was suggested earlier in the thread with fdisk.txt)
# umount /mnt
# exit


Attaching the device to a Windows PC, I received a notification that the drive may contain errors. Upon attempting to open efipart.txt, the only text it contains is 'EFI'. I was unsure of what commands to use to view the output that would be in efipart.txt, but in the terminal instead.


For EFI Boot Manager
I think I made my boot order a little unusual in the BIOS for the sake of experimenting, but I made sure the installation media was placed first
Code: Select all
# efibootmgr
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 2001, 2002, 2003
Boot0000* USB HDD: KingstonDT 101 II
Boot0001* Unknown Device:
Boot0002* debian
Boot0003* Unknown Device:
Boot0004* Windows Boot Manager
Boot0005* Windows Boot Manager
Boot0006* Windows Boot Manager
Boot0007* EFI USB Device
Boot0008* EFI Network
Boot000A* Windows Boot Manager
Boot000B* EFI USB Device
Boot000C* EFI Network
Boot000D* Windows Boot Manager
Boot000E* Windows Boot Manager
Boot000F* EFI USB Device
Boot0016* Windows Boot Manager
Boot2001* EFI USB Device
Boot2003* EFI Network


efibootmgr is available only in the installed system environment.

Sorry about the contradiction on that - since efibootmgr was accepted and gave an output, I can only assume this was in the installed system environment.
User avatar
Olympiq
 
Posts: 9
Joined: 2018-10-12 09:17

Re: No Bootable Device Found / Error While Mounting

Postby p.H » 2018-10-20 09:54

Olympiq wrote:Attaching the device to a Windows PC, I received a notification that the drive may contain errors

Maybe remounting /cdrom read-only after the sync would have avoided it.

Olympiq wrote: Upon attempting to open efipart.txt, the only text it contains is 'EFI'.

This is expected when running ls without the -r (recursive) option. If -r is not supported by the available ls version, you must first identify all subdirectories and append their contents to the file.
For example, if
Code: Select all
ls -l /mnt

shows directory "EFI", then run
Code: Select all
ls -l /mnt/EFI

If it shows "BOOT" and "debian", then run
Code: Select all
ls -l /mnt/EFI/BOOT /mnt/EFI/debian

and so on until you found all subdirectories. Then run
Code: Select all
ls -l /mnt /mnt/EFI /mnt/EFI/BOOT /mnt/EFI/debian (other subdir...) > /cdrom/efipart.txt


Olympiq wrote:BootOrder: 2001, 2002, 2003
Boot0000* USB HDD: KingstonDT 101 II
Boot0001* Unknown Device:
Boot0002* debian

Debian has an EFI boot entry but its number 0002 is not in the BootOrder so it won't boot automatically. You could try to change the boot order with
Code: Select all
efibootmgr -o 0002,2001,2002,2003

Boot entry number 2002 does not seem to exist, so the command may reject it. If so, try again and remove it from the list.
p.H
 
Posts: 651
Joined: 2017-09-17 07:12

Re: No Bootable Device Found / Error While Mounting

Postby kevin91 » 2018-12-05 05:29

p.H wrote:
Olympiq wrote:guess I should specify I'm running a shell in the installation environment without using a root file system, because when I try to run it through /dev/mmcblk0p1, it won't accept '-R' as valid

I am surprised that the "ls" command in the installer environment does not support -R (for recursive). Then use ls and use it again on any subdirectory (should be EFI, EFI/BOOT, EFI/debian).

Olympiq wrote:Am I assuming correctly that 'ro' refers to read only here?

Yes. It is not surprising that the FAT partition on the installation media is mounted read only by the installer, as the installer does not need to write on it (and originally it was intended to be on a read-only CD-ROM). The EFI partition on the internal eMMC drive is read-only because of the -r option given to "mount", as we only need to read it and don't want to write accidentally to it.

You should be able to remount the installation media read-write with the following command :
Code: Select all
mount -o remount,rw /cdrom


So to write a the output of a command to a file on the installation media, you should run :
Code: Select all
some_command some_arguments > /media/some_file.txt


IIRC, the df command in the installer environment (from busybox) does not support the -T option. Only the df command in the installed system environment does.

Olympiq wrote:After mounting to the EFI partition and launching the shell on the installer environment (using root partition /dev/mmcblk0p2):

I don't understand. Either you launch a shell in the installer environment and don't select a root partition, or you launch a shell in the installed system environmement and select a root partition. What exactly did you do ?
If you don't know, run "df". If it shows that /dev/mmcblk0p2 is mounted as /, then it means that you are in the installed system environment. Otherwise you are still in the installer environment.

efibootmgr is available only in the installed system environment.

Note that when you are in the installed system environment, you cannot access the installer media through /cdrom. If you want to access it from the installed system environment, you must mount it again on some mount point, say /mnt.



Thanks, I was also facing same problem and this solution worked for me <3
kevin91
 
Posts: 1
Joined: 2018-12-05 05:18

Previous

Return to Installation

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable