[SOLVED]Debian netinst installer didn't use UEFI

Help with issues regarding installation of Debian

[SOLVED]Debian netinst installer didn't use UEFI

Postby NorthEast » 2018-12-01 22:49

The problem I have is that the Debian installer on the Debian-9.5.0-amd64-netinst.iso installed Debian with an MBR and msdos partitioning system instead of a UEFI and GPT format on this machine which is a UEFI one. I couldn't see a way of forcing a UEFI installation, even after choosing the 'expert' installation option. It seems that after partitioning, the installer writes to disk without offering MBR or UEFI, but makes its own choice. Making the /boot/efi partition made no difference.

From the Debian stretch installation guide, I expected that the installer would install as UEFI. It states:
"3.6.3. Systems with UEFI firmware
<snip>
when booting debian-installer on a UEFI system with CSM because debian-installer checks whether it was started on a BIOS- or on a native UEFI system and installs the corresponding bootloader. Normally this simply works but there can be a problem in multi-boot environments."


My system is a single boot environment with a single 1TB disk and has a Gigabyte H110M-S2H-CF motherboard with American Megatrends Inc. firmware which clearly states that "UEFI is supported", which is confirmed by the dmidecode output. The previous installation on this disk was fedora which installed as UEFI.

I don't know whether there is a problem with the Debian installer, or a problem with the UEFI firmware or the user. I have read that not all UEFI technology is free of bugs. Despite the fact that the machine works without evident problems at present, my queries are: did I miss something in the installer to control installing as UEFI? And, does it matter at all on this single 1TB hard disk system, whether the MBR or UEFI is used?
Last edited by NorthEast on 2018-12-03 05:15, edited 1 time in total.
NorthEast
 
Posts: 7
Joined: 2018-11-18 04:35

Re: Debian netinst installer didn't use UEFI

Postby Head_on_a_Stick » 2018-12-01 23:00

The machine needs to be booted in UEFI mode (with Secure Boot disabled), you can verify this by switching to a console screen (<Ctrl>+<Alt>+F2 for the GTK installer or just <Alt>+F2 for the curses version) and checking if /sys/firmware/efi exists.
dbruce wrote:Ubuntu forums try to be like a coffee shop in Seattle. Debian forums strive for the charm and ambience of a skinhead bar in Bacau. We intend to keep it that way.
User avatar
Head_on_a_Stick
 
Posts: 8322
Joined: 2014-06-01 17:46
Location: /dev/chair

[Solved] Re: Debian netinst installer didn't use UEFI

Postby NorthEast » 2018-12-02 03:29

Head_on_a_Stick wrote:The machine needs to be booted in UEFI mode (with Secure Boot disabled), you can verify this by switching to a console screen (<Ctrl>+<Alt>+F2 for the GTK installer or just <Alt>+F2 for the curses version) and checking if /sys/firmware/efi exists.

Thank you Head_on_a_Stick. I was able to find the option in the BIOS and change 'legacy' to 'uefi' which enabled the uefi boot. I believe I missed it before because the option was named "boot storage ..." in the BIOS of this machine which misled me. All good now.
NorthEast
 
Posts: 7
Joined: 2018-11-18 04:35


Return to Installation

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable
cron