[SOLVED] Users with UID < 1000 missing from login screen

Help with issues regarding installation of Debian

[SOLVED] Users with UID < 1000 missing from login screen

Postby fgillis_2 » 2018-12-02 17:12

Upgraded from Debian 8/KDE to Debian 9/KDE with a clean install on a new SSD. Everything works fine except it now seems impossible to have users with UID of < 1000 show-up on the login screen.

Besides editing the /etc/login.defs file with UID_MIN=501, and trying many other variations of MIN/MAX settings in login.defs and useradd.conf these users still don't appear on the login screen.

Seems like the UID_MIN value in login.defs is being ignored or is of lower priority than a setting somewhere else.

Need users with UID's of 501, 502, etc. for compatibility with OSX machines on the network.

Any help appreciated.
Last edited by fgillis_2 on 2018-12-03 23:16, edited 1 time in total.
fgillis_2
 
Posts: 2
Joined: 2018-12-02 16:37

Re: Users with UID < 1000 missing from login screen

Postby bw123 » 2018-12-02 20:50

I don't know where this kcm module went. When I installed plasma-desktop on stretch, I noticed that some documentation said that accountsservices pkg is now used for this. You are probably using sddm now? I use lightdm instead and this is minimum-uid=500 in /etc/lightdm/users.conf

Try one of these to find the sddm module, if it is not in systemsettings somewhere, or in /etc/sddm/something.conf
Code: Select all
kcmshell4 --list
kcmshell5 --list


try man sddm.conf?
User avatar
bw123
 
Posts: 3585
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Users with UID < 1000 missing from login screen

Postby piper » 2018-12-02 23:43

You can find it at

Code: Select all
/etc/sddm.conf


Default will look like

Code: Select all
[Autologin]
Relogin=false
Session=
User=

[General]
HaltCommand=
RebootCommand=

[Theme]
Current=debian-breeze
CursorTheme=Adwaita

[Users]
MaximumUid=65000
MinimumUid=1000
User avatar
piper
 
Posts: 89
Joined: 2005-07-03 08:29

Re: Users with UID < 1000 missing from login screen

Postby fgillis_2 » 2018-12-03 03:00

Hello bw123. Thank you for your suggestions.

It doesn’t look like I’m using lightdm or sddm.
There is no “lightdm” directory under /etc.
There is a “sddm” directory, but it only contains “Xsession”.

Running “kcmshell4 —list” gives 13 lines of error messages starting with…
“kcmshell(2390)/kdeui (kdelibs): Session bus not found”
and ending with…
“Not forwarding the crash to Apport.”

Running “kcmshell5 —list” outputs “The following modules are available:”, followed by a long list of “modules”. sddm is not included in the list.


Hello piper. Thank you for your suggestions.

As mentioned above, there is no sddm.conf file under /etc, so I created one based on your default example, changing MinimumUid to 501.

Damn! It works! :D

Will now continue with the rest of my installation to see if everything else works as expected, (as in Debian_8).

Thank you bw123 & piper!


FYI: Installation to this point was mostly default…

- Used a debian-9.6.0-amd64-netinst.iso CD.
- Partitioning scheme was with separate /home, /var, and /tmp partitions.
- Installed Debian Desktop Environment, KDE, SSH server, Standard system utilities.
- Also installed autofs, nfs-kernel-server, nfs-common, ntpdate, csh, tcsh.
- Updated UID_MIN & GID_MIN values in /etc/login.defs to 501
- Updated FIRST_UID & FIRST_GID values in /etc/adduser.conf to 501
fgillis_2
 
Posts: 2
Joined: 2018-12-02 16:37


Return to Installation

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable