Drivers problem after a fresh install

Help with issues regarding installation of Debian

Drivers problem after a fresh install

Postby caillonantoine » 2018-12-10 11:12

Hi,

I just installed Debian 9 - XFCE on my laptop. Everything seems to work fine, except for some hardware related problems.
I managed to install NVIDIA's drivers, alongside the CUDA toolkit, but i still don't have neither wifi nor soundcard.

Here's the output of lspci -nn :

Code: Select all
00:00.0 Host bridge [0600]: Intel Corporation Device [8086:3e34] (rev 0b)
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3ea0]
00:04.0 Signal processing controller [1180]: Intel Corporation Skylake Processor Thermal Subsystem [8086:1903] (rev 0b)
00:08.0 System peripheral [0880]: Intel Corporation Skylake Gaussian Mixture Model [8086:1911]
00:12.0 Signal processing controller [1180]: Intel Corporation Device [8086:9df9] (rev 30)
00:13.0 Serial controller [0700]: Intel Corporation Device [8086:9dfc] (rev 30)
00:14.0 USB controller [0c03]: Intel Corporation Device [8086:9ded] (rev 30)
00:14.2 RAM memory [0500]: Intel Corporation Device [8086:9def] (rev 30)
00:14.3 Network controller [0280]: Intel Corporation Device [8086:9df0] (rev 30)
00:15.0 Serial bus controller [0c80]: Intel Corporation Device [8086:9de8] (rev 30)
00:15.1 Serial bus controller [0c80]: Intel Corporation Device [8086:9de9] (rev 30)
00:16.0 Communication controller [0780]: Intel Corporation Device [8086:9de0] (rev 30)
00:17.0 SATA controller [0106]: Intel Corporation Device [8086:9dd3] (rev 30)
00:1c.0 PCI bridge [0604]: Intel Corporation Device [8086:9db8] (rev f0)
00:1c.4 PCI bridge [0604]: Intel Corporation Device [8086:9dbc] (rev f0)
00:1d.0 PCI bridge [0604]: Intel Corporation Device [8086:9db0] (rev f0)
00:1d.4 PCI bridge [0604]: Intel Corporation Device [8086:9db4] (rev f0)
00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:9d84] (rev 30)
00:1f.3 Audio device [0403]: Intel Corporation Device [8086:9dc8] (rev 30)
00:1f.4 SMBus [0c05]: Intel Corporation Device [8086:9da3] (rev 30)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device [8086:9da4] (rev 30)
02:00.0 3D controller [0302]: NVIDIA Corporation Device [10de:174d] (rev a2)
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
04:00.0 Non-Volatile memory controller [0108]: Toshiba America Info Systems Device [1179:0113] (rev 01)


And the output of lsmod :

Code: Select all
Module                  Size  Used by
iwlwifi               151552  0
cfg80211              589824  1 iwlwifi
btusb                  45056  0
btrtl                  16384  1 btusb
btbcm                  16384  1 btusb
btintel                16384  1 btusb
bluetooth             552960  4 btrtl,btintel,btbcm,btusb
rndis_host             16384  0
cdc_ether              16384  1 rndis_host
usbnet                 45056  2 rndis_host,cdc_ether
rfkill                 24576  3 bluetooth,cfg80211
binfmt_misc            20480  1
uvcvideo               90112  0
videobuf2_vmalloc      16384  1 uvcvideo
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_v4l2         24576  1 uvcvideo
nls_ascii              16384  1
videobuf2_core         40960  2 uvcvideo,videobuf2_v4l2
nls_cp437              20480  1
videodev              176128  3 uvcvideo,videobuf2_core,videobuf2_v4l2
vfat                   20480  1
media                  40960  2 uvcvideo,videodev
joydev                 20480  0
fat                    69632  1 vfat
dell_wmi               16384  0
dell_smbios            16384  1 dell_wmi
mxm_wmi                16384  0
efi_pstore             16384  0
intel_rapl             20480  0
x86_pkg_temp_thermal    16384  0
intel_powerclamp       16384  0
coretemp               16384  0
kvm_intel             200704  0
dcdbas                 16384  1 dell_smbios
dell_smm_hwmon         16384  0
kvm                   598016  1 kvm_intel
irqbypass              16384  1 kvm
crct10dif_pclmul       16384  0
crc32_pclmul           16384  0
evdev                  24576  14
ghash_clmulni_intel    16384  0
serio_raw              16384  0
efivars                20480  1 efi_pstore
pcspkr                 16384  0
processor_thermal_device    16384  0
shpchp                 36864  0
intel_soc_dts_iosf     16384  1 processor_thermal_device
ucsi                   16384  0
battery                20480  0
soc_button_array       16384  0
int3403_thermal        16384  0
wmi                    16384  2 dell_wmi,mxm_wmi
video                  40960  1 dell_wmi
int3402_thermal        16384  0
int340x_thermal_zone    16384  3 int3402_thermal,int3403_thermal,processor_thermal_device
tpm_crb                16384  0
intel_hid              16384  0
int3400_thermal        16384  0
acpi_thermal_rel       16384  1 int3400_thermal
sparse_keymap          16384  2 dell_wmi,intel_hid
ac                     16384  0
acpi_pad               24576  0
button                 16384  0
nvidia_drm             45056  1
drm_kms_helper        155648  1 nvidia_drm
drm                   360448  4 nvidia_drm,drm_kms_helper
nvidia_modeset        860160  1 nvidia_drm
nvidia              13160448  1 nvidia_modeset
parport_pc             28672  0
ppdev                  20480  0
lp                     20480  0
parport                49152  3 lp,parport_pc,ppdev
efivarfs               16384  1
ip_tables              24576  0
x_tables               36864  1 ip_tables
autofs4                40960  2
ext4                  585728  1
crc16                  16384  2 bluetooth,ext4
jbd2                  106496  1 ext4
crc32c_generic         16384  0
fscrypto               28672  1 ext4
ecb                    16384  0
mbcache                16384  2 ext4
crc32c_intel           24576  2
aesni_intel           167936  0
aes_x86_64             20480  1 aesni_intel
glue_helper            16384  1 aesni_intel
lrw                    16384  1 aesni_intel
gf128mul               16384  1 lrw
ablk_helper            16384  1 aesni_intel
cryptd                 24576  3 ablk_helper,ghash_clmulni_intel,aesni_intel
psmouse               135168  0
ahci                   40960  0
nvme                   28672  3
libahci                32768  1 ahci
nvme_core              40960  5 nvme
r8169                  86016  0
mii                    16384  2 r8169,usbnet
libata                249856  2 ahci,libahci
xhci_pci               16384  0
xhci_hcd              188416  1 xhci_pci
scsi_mod              225280  1 libata
usbcore               253952  7 rndis_host,usbnet,uvcvideo,cdc_ether,xhci_pci,btusb,xhci_hcd
usb_common             16384  1 usbcore
thermal                20480  0
i2c_hid                20480  0
hid                   122880  1 i2c_hid

Thank you very much for your time!
caillonantoine
 
Posts: 4
Joined: 2018-12-10 11:05

Re: Drivers problem after a fresh install

Postby 4D696B65 » 2018-12-10 11:24

User avatar
4D696B65
 
Posts: 2231
Joined: 2009-06-28 06:09

Re: Drivers problem after a fresh install

Postby caillonantoine » 2018-12-10 11:30

Already tried, but doesn't work! No network interfaces are found:

output of ip a:

Code: Select all
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 6c:2b:59:37:19:20 brd ff:ff:ff:ff:ff:ff
caillonantoine
 
Posts: 4
Joined: 2018-12-10 11:05

Re: Drivers problem after a fresh install

Postby arochester » 2018-12-10 11:37

1) Have you enabled contrib and non-free in your sources list?
2) Have you installed iwlwifi?
3) Have you rebooted?
4) Have you also tried this? https://wiki.debian.org/SoundFAQ
arochester
 
Posts: 1367
Joined: 2010-12-07 19:55

Re: Drivers problem after a fresh install

Postby caillonantoine » 2018-12-10 11:43

Yes to all... I've enabled contrib, non free and backports, tried to install firmware-iwlwifi from apt, with success, but still with no wifi. I've rebooted multiple times to see weither anything changed or not. I also tried the SoundFAQ just now, and there is no soundcard found by alsa -l , neither as a regular user nor as root. alsactl init gives me:

Code: Select all
alsactl: init:1757: No soundcards found...


thank you very much for your answers!!
caillonantoine
 
Posts: 4
Joined: 2018-12-10 11:05

Re: Drivers problem after a fresh install

Postby 4D696B65 » 2018-12-10 11:55

Your computer might be too new for Stretch. You may need backports or move to Buster.
User avatar
4D696B65
 
Posts: 2231
Joined: 2009-06-28 06:09

Re: Drivers problem after a fresh install

Postby caillonantoine » 2018-12-10 12:27

Really? That's weird... Before switching to debian, i've been using Xubuntu on it, everything was working fine (wifi, soundcard), but the computer was freezing off way too often.
caillonantoine
 
Posts: 4
Joined: 2018-12-10 11:05

Re: Drivers problem after a fresh install

Postby 4D696B65 » 2018-12-10 12:45

Stretch was released June 2017. Your wifi card was released Q2 2017.
User avatar
4D696B65
 
Posts: 2231
Joined: 2009-06-28 06:09

Re: Drivers problem after a fresh install

Postby llivv » 2018-12-10 12:55

Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411
firmware-realtek
for the wired nic

than maybe, add stretch-backports and upgrade
firmware-iwlwifi
see if that works.

thanks 4D696B65 for catching the release date, and arochester :wink:
In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.
User avatar
llivv
 
Posts: 5856
Joined: 2007-02-14 18:10
Location: cold storage

Re: Drivers problem after a fresh install

Postby arochester » 2018-12-10 13:02

If it is the age of your computer you might try Buster instead of Stretch.

Ubuntu 18.04 is based on a mixture of Testing and Unstable - Buster and Sid.
arochester
 
Posts: 1367
Joined: 2010-12-07 19:55

Re: Drivers problem after a fresh install

Postby stevepusser » 2018-12-11 22:31

Yes, the GPU was released 31 August 2018:

https://pci-ids.ucw.cz/read/PC/8086/3ea0

You need a newer Mesa, kernel, firmware packages, etc. to support this new hardware.

Choices are: update all these from Stretch-backports and hope they are new enough.

Install Buster instead and hope nothing breaks as it moves toward release.

I'm part of the MX Linux development team, and have packaged a 4.19.5 Debian kernel, Mesa 18.2.6, and updated firmware for our upcoming Stretch+backports-based MX 18 release in the hopes of supporting your type of new hardware out of the box. If you want to try that instead of Ubuntu or a development Debian release, we'll have a release candidate of MX 18 out in a day or so--it's a Live ISO, so you don't have to install to test it. Testers of the beta have given us really good reports, and there's even a few reviews of the beta on Youtube now. :D
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.13 kernel, wine-staging 4.0~rc4, Stellarium 0.18.3, VLC 3.0.5, Midori 7.0
User avatar
stevepusser
 
Posts: 10433
Joined: 2009-10-06 05:53


Return to Installation

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable