[Solved] Can't talk to DHCP post netinst install

Help with issues regarding installation of Debian

[Solved] Can't talk to DHCP post netinst install

Postby Pontiac » 2018-12-26 16:05

I'm building a new OpenVPN server on my ProxMox VM server (5.2-11) using the netinst ISO of Deb 9.6. Nothing of importance on this VM instance since it's brand new. I'm building this as a VM, not a container.

I've been able to get the OS installed, but having trouble figuring out why the VM doesn't get an address. It appears that the NIC is there showing as ens18 using [ ip a ] but when I try the ifdown then ifup on that address, DHCP requests just time out. I have exactly zero intention of using IPv6, so maybe this install is asking for a v6 IP via DHCP?

The rest of my network is running just fine (Two kids machines, I can't count the number of tablets, logs are spewing on my Ubuntu based DHCP server about requests, etc) and I was on the network to download from the repos, but, post install, I'm not finding how to get this new machine an IP address.

I've tried changing the VMs NIC to different devices (with appropriate reboots) and still no-go. I've tried the paravirtual, Realtek and the E1000 card.

So I know that the NIC is setup properly as the pre-installer received an IP from my DHCP server, but, post install, she's not getting anything.

When I installed, the only option I went with was the SSH server and the standard tools. Everything else was disabled. There is no wireless, this will be a headless machine so no graphical UI, extremely minimal install (512meg of memory of which 406meg is free at this point, 32gig of drive space)

Checking /etc/network/ the interfaces file has [ iface ens18 inet dhcp ] which I suspect is correct, there is nothing in the ./interfaces.d directory.


I don't mind going back a release or two and going with an LTS release.
Last edited by Pontiac on 2018-12-26 17:15, edited 1 time in total.
Posts: 2
Joined: 2018-12-26 15:23

Re: Can't talk to DHCP post netinst install

Postby Pontiac » 2018-12-26 16:48

Disregard. It appears that I ran out of leases on my DHCP server, so the service wasn't providing or ack'n any new requests. I expanded the number of leases permitted, and immediately got a response.
Posts: 2
Joined: 2018-12-26 15:23

Return to Installation

Who is online

Users browsing this forum: No registered users and 7 guests