nvidia driver installation hangs on a fresh stretch install

Help with issues regarding installation of Debian

Re: nvidia driver installation hangs on a fresh stretch inst

Postby toquinho » 2019-01-11 17:55

I had a look at the arch forums (and most of the other suggestions from google). The problems are mainly related to TLP and not being able to use optimus after switching from battery to AC. I do not have TLP installed. So I had no luck here.

However, I noticed that there are no traces of the nvidia drivers in journalctl, dmesg or /proc/modules. lspci shows both the intel and the nvidia video controllers.

I reinstalled the drivers using ddm-mx, But there is no change. This is the output:

Code: Select all
root@CARTMAN:/etc/modprobe.d# ddm-mx -i nvidia
creating lock ...
===================================
Install drivers for: nvidia
Start at (m/d/y): 01/11/2019 16:33:34
===================================
Refreshing Sources with apt-get update

Continue?
  1) yes (default)
  2) no
Press <Enter> for the default entry
Use 'q' to quit

Ign:1 http://ftp.br.debian.org/debian stretch InRelease
Get:2 http://ftp.br.debian.org/debian stretch-updates InRelease [91.0 kB]
Hit:3 http://ftp.br.debian.org/debian stretch Release
Get:4 http://security.debian.org/debian-security stretch/updates InRelease [94.3 kB]
Get:6 http://security.debian.org/debian-security stretch/updates/main Sources [188 kB]
Get:7 http://security.debian.org/debian-security stretch/updates/main i386 Packages [465 kB]
Get:8 http://security.debian.org/debian-security stretch/updates/main amd64 Packages [464 kB]
Get:9 http://security.debian.org/debian-security stretch/updates/main Translation-en [203 kB]
Ign:10 http://download.opensuse.org/repositories/home:/stevenpusser:/new-hardware-support/Debian_9.0  InRelease
Get:11 http://download.opensuse.org/repositories/home:/stevenpusser:/new-hardware-support/Debian_9.0  Release [1,112 B]
Get:12 http://download.opensuse.org/repositories/home:/stevenpusser:/new-hardware-support/Debian_9.0  Release.gpg [481 B]
Get:13 http://download.opensuse.org/repositories/home:/stevenpusser:/new-hardware-support/Debian_9.0  Packages [194 kB]
Fetched 1,702 kB in 3s (535 kB/s)
Reading package lists...

nvidia-optimus detected

Candidate is:  3.2.1-17~obs1
Installed is:  3.2.1-17~obs1

Would you like to check debian-backports for a later version?

Yes or No?

1: Yes
2: No

Enter Number of selection
1
Ok...
Enabling backports repo
Running apt-get update...
Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://ftp.br.debian.org/debian stretch InRelease
Hit:3 http://ftp.br.debian.org/debian stretch-updates InRelease
Hit:4 http://ftp.br.debian.org/debian stretch Release
Ign:6 http://download.opensuse.org/repositories/home:/stevenpusser:/new-hardware-support/Debian_9.0  InRelease
Get:7 http://ftp.debian.org/debian stretch-backports InRelease [91.8 kB]
Hit:8 http://download.opensuse.org/repositories/home:/stevenpusser:/new-hardware-support/Debian_9.0  Release
Get:10 http://ftp.debian.org/debian stretch-backports/main amd64 Packages [555 kB]
Get:11 http://ftp.debian.org/debian stretch-backports/main i386 Packages [542 kB]
Get:12 http://ftp.debian.org/debian stretch-backports/main Translation-en [430 kB]
Get:13 http://ftp.debian.org/debian stretch-backports/contrib i386 Packages [9,496 B]
Get:14 http://ftp.debian.org/debian stretch-backports/contrib amd64 Packages [9,868 B]
Get:15 http://ftp.debian.org/debian stretch-backports/contrib Translation-en [6,693 B]
Get:16 http://ftp.debian.org/debian stretch-backports/non-free amd64 Packages [33.2 kB]
Get:17 http://ftp.debian.org/debian stretch-backports/non-free i386 Packages [23.5 kB]
Get:18 http://ftp.debian.org/debian stretch-backports/non-free Translation-en [36.5 kB]
Fetched 1,738 kB in 3s (518 kB/s)
Reading package lists...

Installing latest nvidia-detect package

Reading package lists...
Building dependency tree...
Reading state information...
nvidia-detect is already the newest version (390.87-4~bpo9+1).
The following packages were automatically installed and are no longer required:
  libllvm3.9 libtxc-dxtn-s2tc
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 224 not upgraded.

Candidate is:  3.2.1-17~obs1
Debian backports candidate is:   3.2.1-17~obs1
Installed is:  3.2.1-17~obs1

nvidia driver already installed

Reinstall or quit?

1: Reinstall
2: quit

Enter Number of selection
1
reinstalling...


Need driver: bumblebee-nvidia (3.2.1-17~obs1)
 packages to install are  bumblebee-nvidia nvidia-driver nvidia-kernel-dkms primus primus-libs-ia32:i386 nvidia-settings virtualgl virtualgl-libs:i386

Continue?
  1) yes (default)
  2) no
Press <Enter> for the default entry
Use 'q' to quit
1
Frontend:
Nvidia command  = apt-get install --reinstall -y --force-yes   bumblebee-nvidia nvidia-driver nvidia-kernel-dkms primus primus-libs-ia32:i386 nvidia-settings virtualgl virtualgl-libs:i386
Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  libllvm3.9 libtxc-dxtn-s2tc
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 3 reinstalled, 0 to remove and 31 not upgraded.
                                                                              Need to get 0 B/709 kB of archives.
                                                                                                                 After this operation, 0 B of additional disk space will be used.
(Reading database ... 210263 files and directories currently installed.)                                                                                                         (Reading database ...
Preparing to unpack .../build-essential_12.3_amd64.deb ...
Unpacking build-essential (12.3) over (12.3) ...
Preparing to unpack .../firmware-linux-nonfree_20180825.dfsg-1~obs_all.deb ...
Unpacking firmware-linux-nonfree (20180825.dfsg-1~obs) over (20180825.dfsg-1~obs) ...
Preparing to unpack .../linux-headers-4.19.0-1-amd64_4.19.13-1~obs_amd64.deb ...
Unpacking linux-headers-4.19.0-1-amd64 (4.19.13-1~obs) over (4.19.13-1~obs) ...
Setting up build-essential (12.3) ...
Setting up linux-headers-4.19.0-1-amd64 (4.19.13-1~obs) ...
Setting up firmware-linux-nonfree (20180825.dfsg-1~obs) ...
Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  libllvm3.9 libtxc-dxtn-s2tc
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 9 reinstalled, 0 to remove and 31 not upgraded.
                                                                              Need to get 0 B/11.1 MB of archives.
                                                                                                                  After this operation, 0 B of additional disk space will be used.
(Reading database ... 210263 files and directories currently installed.)                                                                                                          (Reading database ...
Preparing to unpack .../0-nvidia-driver_390.87-4~bpo9+1_amd64.deb ...
Unpacking nvidia-driver (390.87-4~bpo9+1) over (390.87-4~bpo9+1) ...
Preparing to unpack .../1-nvidia-kernel-dkms_390.87-4~bpo9+1_amd64.deb ...

-------- Uninstall Beginning --------
Module:  nvidia-current
Version: 390.87
Kernel:  4.19.0-1-amd64 (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia-current.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-1-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-modeset.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-1-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-drm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-1-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-uvm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-1-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod...

DKMS: uninstall completed.

------------------------------
Deleting module version: 390.87
completely from the DKMS tree.
------------------------------
Done.
Unpacking nvidia-kernel-dkms (390.87-4~bpo9+1) over (390.87-4~bpo9+1) ...
Preparing to unpack .../2-nvidia-settings_390.67-1~obs1_amd64.deb ...
Unpacking nvidia-settings (390.67-1~obs1) over (390.67-1~obs1) ...
Preparing to unpack .../3-bumblebee-nvidia_3.2.1-17~obs1_amd64.deb ...
Unpacking bumblebee-nvidia (3.2.1-17~obs1) over (3.2.1-17~obs1) ...
Preparing to unpack .../4-primus_0~20150328-4_amd64.deb ...
Unpacking primus (0~20150328-4) over (0~20150328-4) ...
Preparing to unpack .../5-primus-libs-ia32_0~20150328-4_i386.deb ...
Unpacking primus-libs-ia32:i386 (0~20150328-4) over (0~20150328-4) ...
Preparing to unpack .../6-virtualgl_2.5.2-1~obs_amd64.deb ...
Unpacking virtualgl (2.5.2-1~obs) over (2.5.2-1~obs) ...
Preparing to unpack .../7-virtualgl-libs_2.5.2-1~obs_amd64.deb ...
Unpacking virtualgl-libs:amd64 (2.5.2-1~obs) over (2.5.2-1~obs) ...
Preparing to unpack .../8-virtualgl-libs_2.5.2-1~obs_i386.deb ...
Unpacking virtualgl-libs:i386 (2.5.2-1~obs) over (2.5.2-1~obs) ...
Setting up primus-libs-ia32:i386 (0~20150328-4) ...
Processing triggers for nvidia-alternative (390.87-4~bpo9+1) ...
Setting up primus (0~20150328-4) ...
Setting up nvidia-settings (390.67-1~obs1) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Setting up nvidia-kernel-dkms (390.87-4~bpo9+1) ...
Loading new nvidia-current-390.87 DKMS files...
Building for 4.19.0-1-amd64
Building initial module for 4.19.0-1-amd64
Done.

nvidia-current:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

nvidia-current-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

nvidia-current-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

nvidia-current-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/dkms/

depmod...

DKMS: install completed.
Setting up virtualgl-libs:amd64 (2.5.2-1~obs) ...
Setting up virtualgl-libs:i386 (2.5.2-1~obs) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up virtualgl (2.5.2-1~obs) ...
Setting up bumblebee-nvidia (3.2.1-17~obs1) ...
Setting up nvidia-driver (390.87-4~bpo9+1) ...
Processing triggers for glx-alternative-nvidia (0.8.8~obs) ...
Processing triggers for glx-alternative-mesa (0.8.8~obs) ...
Processing triggers for update-glx (0.8.8~obs) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Processing triggers for glx-alternative-nvidia (0.8.8~obs) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Processing triggers for initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-1-amd64
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
Processing triggers for bumblebee (3.2.1-17~obs1) ...
groupadd: group 'bumblebee' already exists
groupadd: group 'video' already exists
Reading package lists...
Building dependency tree...
Reading state information...
Package 'nvidia-xconfig' is not installed, so not removed
The following packages were automatically installed and are no longer required:
  libllvm3.9 libtxc-dxtn-s2tc
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 31 not upgraded.
mv: cannot stat '/etc/X11/xorg.conf': No such file or directory
Finished


Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://ftp.br.debian.org/debian stretch InRelease                                                       
Hit:3 http://ftp.br.debian.org/debian stretch-updates InRelease                                               
Hit:4 http://ftp.br.debian.org/debian stretch Release                                   
Ign:6 http://download.opensuse.org/repositories/home:/stevenpusser:/new-hardware-support/Debian_9.0  InRelease
Hit:7 http://download.opensuse.org/repositories/home:/stevenpusser:/new-hardware-support/Debian_9.0  Release
Reading package lists... Done

Press <Enter> to exit
root@CARTMAN:/etc/modprobe.d#
toquinho
 
Posts: 35
Joined: 2014-06-24 16:50

Re: nvidia driver installation hangs on a fresh stretch inst

Postby stevepusser » 2019-01-11 18:41

The installer works like it's supposed to, at least, though you didn't need to enable the backports repo. But that's not causing the hangup with Bumblebee.

Dell only has info for Ubuntu and their nvidia-prime solution: https://www.dell.com/support/article/bg ... em?lang=en

I get a lot of hits when I Google those error messages--maybe the difference between Debian is systemd and you need to run

Code: Select all
systemctl disable nvidia-fallback.service


Other hits suggest editing some Bumblebee conf files. Still others say it might be a problem with the glvnd Nvidia drivers and suggest you switch to the non-glvnd ones: nvidia-driver-libs-nonglvnd. I also wonder if the same error would occur in MX Linux after running the installer, since I help develop that, and would like to find a solution for both distros with your hardware.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.13 kernel, wine-staging 4.0~rc4, Stellarium 0.18.3, VLC 3.0.5, Midori 7.0
User avatar
stevepusser
 
Posts: 10443
Joined: 2009-10-06 05:53

Re: nvidia driver installation hangs on a fresh stretch inst

Postby toquinho » 2019-01-11 19:35

Thanks a lot, I really appreciate your support. I tried to follow your suggestions, but it did not help:

systemctl disable nvidia-fallback.service returned an error (No such file or directory, checked for spelling errors), disabled nouveau in grub and installed nvidia-driver-libs-nonglvnd.

What I suggest is that I install MX and report back. Currently, I am on the road and have limited internet access. So it may take a few days until I manage to install it. I will post here what I found. In any case, I have already realized that I cannot use my new machine for my work as soon as I had expected :(. So I will happily provide it for testing MX etc. if this is of use for you.
toquinho
 
Posts: 35
Joined: 2014-06-24 16:50

Re: nvidia driver installation hangs on a fresh stretch inst

Postby stevepusser » 2019-01-11 22:34

OK, though questions abut getting it working there should be on the MX Linux forum instead.

I almost got a G series Dell for compiling packages for MX, but it wasn't quite out yet, so got a similarly-specced MSI gp63 instead. It took me a while to figure out how to get Bumblebee working on it, but with MX 18, pretty much everything just works out of the box.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.13 kernel, wine-staging 4.0~rc4, Stellarium 0.18.3, VLC 3.0.5, Midori 7.0
User avatar
stevepusser
 
Posts: 10443
Joined: 2009-10-06 05:53

Re: nvidia driver installation hangs on a fresh stretch inst

Postby toquinho » 2019-01-21 17:57

Sorry for the delay. I am finally back and have installed MX. Unfortunately, the problems remain. Please see here:

https://forum.mxlinux.org/viewtopic.php?f=107&p=480654#p480654
toquinho
 
Posts: 35
Joined: 2014-06-24 16:50

Previous

Return to Installation

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable