Re: Install debian 9 on Hp Stream Laptop 14-ax010nl [SOLVED]

Help with issues regarding installation of Debian

Re: Install debian 9 on Hp Stream Laptop 14-ax010nl [SOLVED]

Postby Scorpion » 2019-01-29 08:49

Using the dvd as a source is gnome easy to install?

I cannot find the wifi card model, and the wifi usb stick is a based on the chipset MediaTek MT7601U.
With the firmware seems fine. I was able to scan.
So now to connect via cli:
Now edit /etc/network/interfaces. The required configuration is much dependent on your particular setup. See the following example to get an idea of how it works:
Code: Select all
# my wifi device
auto wlan0
iface wlan0 inet dhcp
        wireless-essid [ESSID]
        wireless-mode [MODE] mode????
 

What is mode? Is the password?
Last edited by Scorpion on 2019-01-29 19:26, edited 1 time in total.
Scorpion
 
Posts: 96
Joined: 2018-10-17 11:38

Re: Install debian 9 on Hp Stream Laptop 14-ax010nl

Postby pylkko » 2019-01-29 10:10

Scorpion wrote:I did not find it, If you can...
Where should I mount the dvd (usb stick) to install the packages after editing sources.list?


I was thinking of this, but this is not the same model I guess, but older (although I didn't have time to check if any of the differences in specs are relevant)

viewtopic.php?f=17&t=120536
User avatar
pylkko
 
Posts: 1392
Joined: 2014-11-06 19:02

Re: Install debian 9 on Hp Stream Laptop 14-ax010nl

Postby Scorpion » 2019-01-29 13:00

Using the a phone and usb tethering I reinstalled the OS with the net installer.
But when it ask for the firmware i was not able to provide it. Do I need the .deb file? I use the .bin (for the wireless adapter).

Doesn debian support the wireless card? http://h10032.www1.hp.com/ctg/Manual/c05227771
WLAN module: Intel Dual Band Wireless-AC 7265 802.11 AC 2x2 WiFi + BT 4.2 Combo Adapter non-vPro

Missing firmware:
iwlwifi-7265D-26.ucode
iwlwifi-7265D-25.ucode
24,23,22

https://www.intel.com/content/dam/www/p ... -brief.pdf
I can see: Linux* (most features not available on Linux)
Scorpion
 
Posts: 96
Joined: 2018-10-17 11:38

Re: Install debian 9 on Hp Stream Laptop 14-ax010nl

Postby Head_on_a_Stick » 2019-01-29 15:15

Scorpion wrote:But when it ask for the firmware i was not able to provide it. Do I need the .deb file? I use the .bin (for the wireless adapter).

Instructions here: https://www.debian.org/releases/stretch ... 04.html.en

Scorpion wrote:Missing firmware:
iwlwifi-7265D-26.ucode
iwlwifi-7265D-25.ucode
24,23,22

viewtopic.php?p=690656#p690656
"The trouble with the world is that the stupid are cocksure and the intelligent full of doubt." — Bertrand Russell
User avatar
Head_on_a_Stick
 
Posts: 8839
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Install debian 9 on Hp Stream Laptop 14-ax010nl

Postby Scorpion » 2019-01-29 19:25

I did what the guide states about the missing firmware. Maybe there is some problem with this pc,
Still some questions with no answer, but the important is that:
Everything is fine: wireless card, microphone, bluetooth, speakers and touchpad.
I did not try the camera.

In that package there are not that firmware but it works.

Thanks.
Scorpion
 
Posts: 96
Joined: 2018-10-17 11:38

Re: Install debian 9 on Hp Stream Laptop 14-ax010nl [SOLVED]

Postby stevepusser » 2019-01-29 22:00

Intel wi-fi devices often issue warnings as they go down the list of possible firmware files they can use until they find one they can load. Most of those versions were only used internally at Intel and never released. You can safely ignore the warnings if the device works.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4..20.6 kernel, wine-staging 4.0 final, Sayonara 1.1.1, Calibre 3.39.1, Pale Moon 28.3.1
User avatar
stevepusser
 
Posts: 10510
Joined: 2009-10-06 05:53

Re: Install debian 9 on Hp Stream Laptop 14-ax010nl [SOLVED]

Postby Scorpion » 2019-01-30 09:26

There are no warnings but when I installed the OS it asked for some firmware that are not in the package.
There is only the iwlwifi-7265D-22.ucode. And some other numbers.
But no errors/warnings and it works fine.
Scorpion
 
Posts: 96
Joined: 2018-10-17 11:38

Re: Install debian 9 on Hp Stream Laptop 14-ax010nl [SOLVED]

Postby Scorpion » 2019-02-03 09:56

stevepusser wrote:Intel wi-fi devices often issue warnings as they go down the list of possible firmware files they can use until they find one they can load. Most of those versions were only used internally at Intel and never released. You can safely ignore the warnings if the device works.

Sorry, as first boot messages it asks for those firmware (error -2 failed to load), but the network card is fine.
Also the camera works fine.
I found this errors in dmesg:
Code: Select all
dmesg
[...]
[   66.924739] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-29.ucode (-2)
[   66.924819] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[   66.924896] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-29.ucode failed with error -2
[   66.924924] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-28.ucode (-2)
[   66.924989] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-28.ucode failed with error -2
[   66.925007] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-27.ucode (-2)
[   66.925072] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-27.ucode failed with error -2
[   66.925089] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-26.ucode (-2)
[   66.925154] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-26.ucode failed with error -2
[   66.925172] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-25.ucode (-2)
[   66.925237] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-25.ucode failed with error -2
[   66.925255] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-24.ucode (-2)
[   66.925320] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-24.ucode failed with error -2
[   66.925337] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-23.ucode (-2)
[   66.925402] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-23.ucode failed with error -2
[   66.937240] iwlwifi 0000:02:00.0: firmware: direct-loading firmware iwlwifi-7265D-22.ucode
[   66.938974] iwlwifi 0000:02:00.0: loaded firmware version 22.361476.0 op_mode iwlmvm
[...]
[   67.132555] uvcvideo: Failed to query (GET_INFO) UVC control 2 on unit 1: -32 (exp. 1).
[   67.136016] uvcvideo: Failed to query (GET_INFO) UVC control 4 on unit 1: -32 (exp. 1).
[   67.159791] uvcvideo: Failed to query (GET_INFO) UVC control 4 on unit 2: -32 (exp. 1).
[...]
[   67.208365] kvm: disabled by bios
[   67.263863] kvm: disabled by bios
[...]
[  160.199789] uvcvideo: Failed to query (GET_DEF) UVC control 4 on unit 2: -32 (exp. 2).
[  160.514300] uvcvideo: Failed to query (GET_DEF) UVC control 4 on unit 2: -32 (exp. 2).
[  160.753056] uvcvideo: Failed to query (GET_DEF) UVC control 4 on unit 2: -32 (exp. 2).
[...]
[    0.543497] ACPI: Power Resource [ID3C] (off)
[    0.550146] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-ff])
[    0.550158] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
[    0.550248] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
[    0.550272] acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge
[...]
Scorpion
 
Posts: 96
Joined: 2018-10-17 11:38

Re: Install debian 9 on Hp Stream Laptop 14-ax010nl [SOLVED]

Postby stevepusser » 2019-02-03 21:37

Scorpion wrote:
stevepusser wrote:Intel wi-fi devices often issue warnings as they go down the list of possible firmware files they can use until they find one they can load. Most of those versions were only used internally at Intel and never released. You can safely ignore the warnings if the device works.

Sorry, as first boot messages it asks for those firmware (error -2 failed to load), but the network card is fine.
Also the camera works fine.
I found this errors in dmesg:
Code: Select all
dmesg
[...]
[   66.924739] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-29.ucode (-2)
[   66.924819] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[   66.924896] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-29.ucode failed with error -2
[   66.924924] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-28.ucode (-2)
[   66.924989] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-28.ucode failed with error -2
[   66.925007] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-27.ucode (-2)
[   66.925072] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-27.ucode failed with error -2
[   66.925089] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-26.ucode (-2)
[   66.925154] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-26.ucode failed with error -2
[   66.925172] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-25.ucode (-2)
[   66.925237] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-25.ucode failed with error -2
[   66.925255] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-24.ucode (-2)
[   66.925320] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-24.ucode failed with error -2
[   66.925337] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-23.ucode (-2)
[   66.925402] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-23.ucode failed with error -2
[   66.937240] iwlwifi 0000:02:00.0: firmware: direct-loading firmware iwlwifi-7265D-22.ucode
[   66.938974] iwlwifi 0000:02:00.0: loaded firmware version 22.361476.0 op_mode iwlmvm
[...]
[   67.132555] uvcvideo: Failed to query (GET_INFO) UVC control 2 on unit 1: -32 (exp. 1).
[   67.136016] uvcvideo: Failed to query (GET_INFO) UVC control 4 on unit 1: -32 (exp. 1).
[   67.159791] uvcvideo: Failed to query (GET_INFO) UVC control 4 on unit 2: -32 (exp. 1).
[...]
[   67.208365] kvm: disabled by bios
[   67.263863] kvm: disabled by bios
[...]
[  160.199789] uvcvideo: Failed to query (GET_DEF) UVC control 4 on unit 2: -32 (exp. 2).
[  160.514300] uvcvideo: Failed to query (GET_DEF) UVC control 4 on unit 2: -32 (exp. 2).
[  160.753056] uvcvideo: Failed to query (GET_DEF) UVC control 4 on unit 2: -32 (exp. 2).
[...]
[    0.543497] ACPI: Power Resource [ID3C] (off)
[    0.550146] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-ff])
[    0.550158] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
[    0.550248] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
[    0.550272] acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge
[...]


Exactly what I said in the first quote.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4..20.6 kernel, wine-staging 4.0 final, Sayonara 1.1.1, Calibre 3.39.1, Pale Moon 28.3.1
User avatar
stevepusser
 
Posts: 10510
Joined: 2009-10-06 05:53

Previous

Return to Installation

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable