Dist-upgrade from Stretch to Buster

Help with issues regarding installation of Debian

Re: Dist-upgrade from Stretch to Buster

Postby Head_on_a_Stick » 2019-07-20 10:08

fred44nl wrote:this is what apt-forktracer tells me:

Code: Select all
fred44nl@Debian:~$ sudo apt-forktracer
python-sabyenc (3.3.6-0ubuntu1~jcfp1~16.04) [LP-PPA-jcfp-sab-addons: 3.3.6-0ubuntu1~jcfp1~16.04] [Debian: 3.3.5-1]
sabnzbdplus (2.3.9-0ubuntu1~jcfp1~16.04) [Debian: 2.3.6+dfsg-1] [LP-PPA-jcfp-nobetas: 2.3.9-0ubuntu1~jcfp1~16.04]
par2-tbb (0.4+20150503-0ubuntu1~jcfp1~xenial) [LP-PPA-jcfp-sab-addons: 0.4+20150503-0ubuntu1~jcfp1~xenial]
plexmediaserver (1.16.1.1291-158e5b199) [Artifactory: 1.16.1.1291-158e5b199 1.16.0.1226-7eb2c8f6f 1.15.8.1198-eadbcbb45]

Have you read the first link in my signature?
User avatar
Head_on_a_Stick
 
Posts: 10346
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Dist-upgrade from Stretch to Buster

Postby fred44nl » 2019-07-20 10:29

Head_on_a_Stick wrote:Have you read the first link in my signature?


yes, I did and I know what it means.
however sabnzbd is an application completely written in phyton
and plexmediaserver can only be kept up-to-date from plex.tv
Debian 9.9 on Compulab Fitlet2
User avatar
fred44nl
 
Posts: 162
Joined: 2018-07-14 08:54

Re: Dist-upgrade from Stretch to Buster

Postby fred44nl » 2019-07-27 20:42

Deb-fan wrote:If absolutely minimizing number of packages and install size is a major concern for you, cool. You're trimming it down there. :)


trimming down, as you call it, is not only fun, it is also educational.
keeps me of the street :)
Debian 9.9 on Compulab Fitlet2
User avatar
fred44nl
 
Posts: 162
Joined: 2018-07-14 08:54

Re: Dist-upgrade from Stretch to Buster

Postby Soapm » 2019-07-29 02:17

Head_on_a_Stick wrote:Have you read the first link in my signature?


I find this to be very true advice however most forum respondents say google is your friend. Google is how we find this outdated bad advice so how is that friendly??? :wink:

Code: Select all
Unfortunately there's a lot of bad advice on the Internet. Tutorials found on blogs, forums and other sites often include instructions that will break your system in subtle ways. Don't simply follow the first advice you find, or the tutorial that seems the easiest. Spend some time reading the documentation and compare the difference between tutorials.
User avatar
Soapm
 
Posts: 561
Joined: 2012-05-22 04:23

Re: Dist-upgrade from Stretch to Buster

Postby L_V » 2019-07-29 09:25

May be to summarize a bit......
Code: Select all
grep -rh ^d /etc/apt/sources*

dpkg -l | grep ^ii | wc -l

dpkg -l | grep ^rc | wc -l

aptitude versions '~i' --group-by source-package | grep ^i | grep -v stable
L_V
 
Posts: 1036
Joined: 2007-03-19 09:04

Re: Dist-upgrade from Stretch to Buster

Postby fred44nl » 2019-07-29 13:54

Soapm wrote:I find this to be very true advice


true, very true.
but where do I find recent versions and updates of Sabnzbdplus in Debian repo's ??
the same goes for PlexMediaServer.

recently, I came across Pi-Hole.
any suggestions, as for how to install this ??

fred44nl@Debian:~$ grep -rh ^d /etc/apt/sources*
deb http://ftp.nl.debian.org/debian/ buster main contrib non-free
deb http://security.debian.org/debian-security/ buster/updates main contrib non-free
deb http://ftp.nl.debian.org/debian/ buster-updates main contrib non-free
deb http://ftp.nl.debian.org/debian/ buster-backports main contrib non-free
deb http://ftp.nl.debian.org/debian/ buster-proposed-updates non-free contrib main
deb http://ppa.launchpad.net/jcfp/nobetas/ubuntu/ xenial main
deb http://ppa.launchpad.net/jcfp/sab-addons/ubuntu/ xenial main
deb http://ftp.nl.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb http://ftp.nl.debian.org/debian/ stretch-updates main contrib non-free
deb http://ftp.nl.debian.org/debian stretch-backports main
deb https://downloads.plex.tv/repo/deb/ public main


fred44nl@Debian:~$ dpkg -l | grep ^ii | wc -l
922


fred44nl@Debian:~$ dpkg -l | grep ^rc | wc -l
0


fred44nl@Debian:~$ aptitude versions '~i' --group-by source-package | grep ^i | grep -v stable
i bzip2 1.0.6-9.2~deb10u1 proposed-updates 500
i libbz2-1.0 1.0.6-9.2~deb10u1 proposed-updates 500
i A libblockdev-crypto2 2.20-7+deb10u1 proposed-updates 500
i A libblockdev-fs2 2.20-7+deb10u1 proposed-updates 500
i A libblockdev-loop2 2.20-7+deb10u1 proposed-updates 500
i A libblockdev-part-err2 2.20-7+deb10u1 proposed-updates 500
i A libblockdev-part2 2.20-7+deb10u1 proposed-updates 500
i A libblockdev-swap2 2.20-7+deb10u1 proposed-updates 500
i A libblockdev-utils2 2.20-7+deb10u1 proposed-updates 500
i A libblockdev2 2.20-7+deb10u1 proposed-updates 500
i par2-tbb 0.4+20150503-0ubuntu1~jcfp1~xenial xenial 500
i plexmediaserver 1.16.3.1402-22929c8a2 public 500
i A python-sabyenc 3.3.6-0ubuntu1~jcfp1~16.04 xenial 500
i sabnzbdplus 2.3.9-0ubuntu1~jcfp1~16.04 xenial 500
Debian 9.9 on Compulab Fitlet2
User avatar
fred44nl
 
Posts: 162
Joined: 2018-07-14 08:54

Re: Dist-upgrade from Stretch to Buster

Postby L_V » 2019-07-29 14:11

Then globally not so bad no ? Could be worse !

ppa.launchpad.net/jcfp// : You know what you do, which is the most important.
L_V
 
Posts: 1036
Joined: 2007-03-19 09:04

Previous

Return to Installation

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable