RPI4 OMV4 WiFi issue- Direct firmware load brcm* failed -2

Help with issues regarding installation of Debian

RPI4 OMV4 WiFi issue- Direct firmware load brcm* failed -2

Postby electrosam » 2019-07-21 23:42

Debian v9.4 (stretch)
OpenMediaVault 4
Hardware- RaspberryPi 4

1. Tried to boot from a clean SD card (new etcher install, etcher reported success)
2. Added a user as sudo
3. ssh with this user, and did dmesg | grep brcm. It shows-

$ dmesg | grep brcm
[ 0.217768] brcm-pcie fd500000.pcie: could not get clock
[ 0.217824] brcm-pcie fd500000.pcie: host bridge /scb/pcie@7d500000 ranges:
[ 0.217860] brcm-pcie fd500000.pcie: MEM 0x600000000..0x603ffffff -> 0xf8000000
[ 0.281578] brcm-pcie fd500000.pcie: link up, 5.0 Gbps x1 (!SSC)
[ 0.281824] brcm-pcie fd500000.pcie: PCI host bridge to bus 0000:00
[ 0.845561] brcmstb_thermal fd5d2200.thermal: registered AVS TMON of-sensor driver
[ 4.913222] brcmfmac: F1 signature read @0x18000000=0x15264345
[ 4.923550] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 4.923887] usbcore: registered new interface driver brcmfmac
[ 4.938906] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.txt failed with error -2
[ 5.941662] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50

Please help!

Thanks,
Sam
electrosam
 
Posts: 2
Joined: 2019-07-21 23:38

Re: RPI4 OMV4 WiFi issue- Direct firmware load brcm* failed

Postby sunrat » 2019-07-21 23:54

RPi4 is pretty new hardware. It probably requires drivers not available in Stretch.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2758
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: RPI4 OMV4 WiFi issue- Direct firmware load brcm* failed

Postby electrosam » 2019-07-22 00:28

Another update-
I followed steps in this thread and the driver/firmware seems to work-
https://www.linuxquestions.org/question ... 175627137/

Now the output of dmesg is-
root@raspberrypi:/usr/src# dmesg | grep brcm
[ 0.217743] brcm-pcie fd500000.pcie: could not get clock
[ 0.217799] brcm-pcie fd500000.pcie: host bridge /scb/pcie@7d500000 ranges:
[ 0.217834] brcm-pcie fd500000.pcie: MEM 0x600000000..0x603ffffff -> 0xf8000000
[ 0.271557] brcm-pcie fd500000.pcie: link up, 5.0 Gbps x1 (!SSC)
[ 0.271802] brcm-pcie fd500000.pcie: PCI host bridge to bus 0000:00
[ 0.825373] brcmstb_thermal fd5d2200.thermal: registered AVS TMON of-sensor driver
[ 3.190740] brcmfmac: F1 signature read @0x18000000=0x15264345
[ 3.199930] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 3.200543] usbcore: registered new interface driver brcmfmac
[ 4.331921] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50
[ 5.341649] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50


However even with this, cannot use WiFi-

iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

nmtui does not show wireless yet.

I also tried connecting external USB3.0 rtl8812au WiFi Dongle, it gets detected and drivers are installed. But iwconfig / nmtui does not show WiFI.

Something seems wrong in OMV 4 for RPI?
Why is this happening?
Please help!
electrosam
 
Posts: 2
Joined: 2019-07-21 23:38

Re: RPI4 OMV4 WiFi issue- Direct firmware load brcm* failed

Postby sunrat » 2019-07-22 00:54

You may need firmware-realtek for the USB wifi.

I don't have a RPi yet but thinking about getting one and I would certainly use Raspbian as it's set up to support the hardware. There is an installer available which includes Raspian Buster -
https://www.raspberrypi.org/forums/view ... p?t=142574
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2758
Joined: 2006-08-29 09:12
Location: Melbourne, Australia


Return to Installation

Who is online

Users browsing this forum: eveil and 9 guests

fashionable