debian 10 curl pb

Help with issues regarding installation of Debian

debian 10 curl pb

Postby oitsuki » 2019-08-08 16:58

Hello,

I have this error appear when I want to call an url with guzzlehttp
Code: Select all
[08-Aug-2019 03:38:25 UTC] PHP Notice:  {
    "method": "get",
    "url": "https:\/\/demo.xxxxx.com\/demo\/index.php?Products&Description&products_id=12",
    "options": {
        "verify": "\/var\/www\/clients\/client1\/web8\/web\/demo\/includes\/xxxxxxxxxxx\/External\/cacert.pem"
    }
} in /var/www/clients/client1/web8/web/demo/includes/xxxxxxxxxxx/OM/HTTP.php on line 147
[08-Aug-2019 03:38:25 UTC] PHP Notice:  Error creating resource: [message] fopen(): SSL operation failed with code 1. OpenSSL Error messages:
error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed
[file] /var/www/clients/client1/web8/web/demo/includes/xxxxxxxxxxx/External/vendor/guzzlehttp/guzzle/src/Handler/StreamHandler.php
[line] 323
[message] fopen(): Failed to enable crypto
[file] /var/www/clients/client1/web8/web/demo/includes/xxxxxxxxxxx/External/vendor/guzzlehttp/guzzle/src/Handler/StreamHandler.php
[line] 323
[message] fopen(https://demo.xxxxx.com/demo/index.php?Products&Description&products_id=12): failed to open stream: operation failed
[file] /var/www/clients/client1/web8/web/demo/includes/xxxxxxxxxxx/External/vendor/guzzlehttp/guzzle/src/Handler/StreamHandler.php
[line] 323 in /var/www/clients/client1/web8/web/demo/includes/xxxxxxxxxxx/OM/HTTP.php on line 150
[08-Aug-2019 03:38:25 UTC] PHP Warning:  DOMDocument::loadHTML(): Empty string supplied as input in /var/www/clients/client1/web8/web/demo/includes/xxxxxxxxxxx/Apps/Marketing/SEO/Classes/xxxxxxxxxxxAdmin/SeoReport.php on line 261
 


I think there is a relation with curl

The following packages contain unsatisfied dependencies:
php7.3-curl: Depends: libcurl3 (up 7.44.0) but it is not installable
E: Unable to fix problems, defective packages are in "keep it as they are" mode.

The following packages contain unsatisfied dependencies:
php7.3-curl: Depends: libcurl3 (up 7.44.0) but it is not installable
E: Unable to fix problems, defective packages are in "keep it as they are" mode.

I tryied this :

Voici le résultat

Code: Select all
aptitude show php7.3-curl
Paquet : php7.3-curl                                   
Version : 7.3.8-1+0~20190807.43+debian9~1.gbp7731bf
État: non installé (il reste les fichiers de configuration)
Priorité : optionnel
Section : php
Responsable : Debian PHP Maintainers <team+pkg-php@tracker.debian.org>
Architecture : amd64
Taille décompressée : 123 k
Dépend: php-common (>= 1:35), ucf, php7.3-common (=
        7.3.8-1+0~20190807.43+debian9~1.gbp7731bf), libc6 (>= 2.14), libcurl3
        (>= 7.44.0)
Casse: php7.0-curl (< 7.0.33-1~)
Fournit: php-curl
Description : module CURL pour PHP
 Ce paquet fournit le module CURL pour PHP.


How to resolve that ?

Thank you
oitsuki
 
Posts: 3
Joined: 2019-08-08 16:53

Re: debian 10 curl pb

Postby kedaha » 2019-08-08 18:07

You can try removing your current stable version of the package, but make a note of any packages that also get removed so as to reinstall them when you have finished, and then download and install the old libcurl3 package which will also need libssl1.0.0 from Debian jessie (oldoldstable).
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 2909
Joined: 2008-05-24 12:26

Re: debian 10 curl pb

Postby oitsuki » 2019-08-08 18:44

Could you tell me the process ?
note I m on Debian 10
tk
oitsuki
 
Posts: 3
Joined: 2019-08-08 16:53

Re: debian 10 curl pb

Postby kedaha » 2019-08-08 18:55

On second thoughts I think my previous reply is not the way.
I got the wrong idea. I think using aptitude you may be able to resolve the dependency problem
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 2909
Joined: 2008-05-24 12:26

Re: debian 10 curl pb

Postby oitsuki » 2019-08-08 19:20

Ok but I am not familiar with aptitude.
Code: Select all
Aptitude install curl
oitsuki
 
Posts: 3
Joined: 2019-08-08 16:53


Return to Installation

Who is online

Users browsing this forum: eveil and 10 guests

fashionable