Net install with Broadcom wireless

Help with issues regarding installation of Debian

Net install with Broadcom wireless

Postby rickseiden » 2019-09-08 13:52

Hello,

I have a weird machine--an ASUS X205TA. It's got a 64 bit architecture, but can only boot using a 32 bit environment. So that means that I can't install the 64 bit version of buster on it.

I have installed the 32 bit version of buster on this machine, and it works like a charm. There was the issue of the Broadcom wireless driver, but I got past that. There are two files that have to be in /lib/firmware/brcm. They are brcmfmac43340-sdio.txt and brcmfmac43340-sdio.bin.

But there are things you can't do on a 32 bit environment, that I really want/need to do. So I need a way to install the 64 bit version of buster.

I did some searching and found that the net install can do what I need, but there's a problem with the net install and the Broadcom driver. When it searches for the wireless card, it tells me I'm missing a file. Specifically the .txt file above. So I throw it on a usb drive, switch to a console (ALT-F2), mount the drive and copy the .txt file into /lib/firmware/brcm, then switch back to the installer (ALT-F5). When I was installing the 32 bit version of buster, I did this, and the install proceeded without an issue, and I was able to configure my wireless card during the installation.

But the net install comes back saying that I'm missing a file called brcmfmac43340-sdio.clm_blob.

I've search for this file everywhere and can't find it. It's odd that the 32 bit installer doesn't require it, but the net installer does.

Does anyone know what's going on with this?

Thanks!

PS: I've even downloaded the 64 bit non free iso, added a file called bootia32.efi to the USB drive so I can boot the 64 bit USB drive into 32 bit, and followed the same steps when it comes to networking. I had no problems there, either. Where I did have problems was after the install when it tried to install the boot system. It goes for a 64 bit boot system, and crashes.
rickseiden
 
Posts: 2
Joined: 2019-09-07 12:54

Re: Net install with Broadcom wireless

Postby rickseiden » 2019-09-08 16:19

I ended up figuring something out. I ran the expert install instead of the regular install, and then when it asked for the clm_blob file, I just said no, I didn't want to look for it, and it looked for the Ethernet port, which doesn't exist, and then it took me back to the installation menu. I selected configure network, and was able to configure my wireless network and proceed from there. The rest of the installer worked no problem.
rickseiden
 
Posts: 2
Joined: 2019-09-07 12:54


Return to Installation

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable