Problems to upgrade dist

Help with issues regarding installation of Debian

Problems to upgrade dist

Postby Maxxx » 2019-09-11 15:09

Hi everyone,
I expose my problem ... it's been a few months since I updated my Debian 8 because it gave me errors on packages (related to python in particular) corrupt or somehow damaged, and I avoided facing these problems due to lack of time
Then, a few days ago, I finally decided to find the time to update the system, trying directly to switch from Debian 8 to 9.
After modifying the sources.list file and running "update" command, the packet problems remained and after several attempts I made the situation worse by creating other errors on other packages and other dependency errors.
At this point, not finding a way out, the solution was either to reinstall everything from scratch or to try to go directly to Debian 10 ... so I decided to do this last thing... I have changed the file sources.list again and I gave back the update and in the end I solved the problems I had before about packages and dependencies (googling a lot) ... I'm not going to list exactly the steps I performed because I don't remember them exactly but what helped me most to solve the problems was to delete the files related to the corrupted packages at /var/lib/dpkg/info/.
At this point the system has been updated (update, upgrade and dist-upgrade) and the Debian version is 10.
But even if as a graphic environment I had gnome before, when I reboot, the system runs Xfce even after reinstalling Gnome (task-gnome-desktop) ... I solved this problem by modifying the xinitrc file inserting "exec / usr/bin/gnome-session" and starting gdm3.
When reboot system, it starts gdm3 regularly, but with many problems because the mouse does not run smoothly, and it freezes very often (as if the system was slowed down) and when I can put the user password the system seems to enter to gnome but then it comes out and it asks me again to select the user and relative password on gdm3.
Probably I missing some fundamental package, even if I gave the "--reinstall" on gnome several times.
I also tried the nouveau drivers and the nvidia drivers (I have nvidia 1070) but nothing.

Posting the results of some commands is very difficult because I can't work in a graphical environment, not even under Xfce since the terminal doesn't work there.

What could I do to solve this problem?

I thank anyone who can give me some advice.
Maxxx
 
Posts: 5
Joined: 2019-09-11 14:57

Re: Problems to upgrade dist

Postby ruwolf » 2019-09-14 18:50

User avatar
ruwolf
 
Posts: 392
Joined: 2008-02-18 05:04
Location: Slovakia, Banovce nad Bebravou, Matice slovenskej 1260/4-7

Re: Problems to upgrade dist

Postby Maxxx » 2019-09-15 19:51

Hi, thanks for your response.
Now i'm trying to install nvidia drivers... i recompiled kernel without any framebuffers and blacklisted nouveau, but i got many error, like "nvidia adapter not probed".
Nvidia-detect says me to install "nvidia-driver" and i did it, but command "lshw -c display" says that i have nouveau driver even if i blacklisted it...
I also tried installing nvidia driver downloaded from nvidia site, but nothing.
Now startx give me "no screen found".
I think that if i'll be able to install correctly nvidia driver probably it'll run properly.
as soon as I can I will post the startx log
Maxxx
 
Posts: 5
Joined: 2019-09-11 14:57

Re: Problems to upgrade dist

Postby ruwolf » 2019-09-15 20:08

And what about to write nvidia driver to Xorg configuration?
User avatar
ruwolf
 
Posts: 392
Joined: 2008-02-18 05:04
Location: Slovakia, Banovce nad Bebravou, Matice slovenskej 1260/4-7

Re: Problems to upgrade dist

Postby Maxxx » 2019-09-15 20:10

Already done... write nvidia in xorg.conf but nothing
Maxxx
 
Posts: 5
Joined: 2019-09-11 14:57

Re: Problems to upgrade dist

Postby Maxxx » 2019-09-15 20:11

And modprobe nvidia tell me that it doesn't found file.so
Maxxx
 
Posts: 5
Joined: 2019-09-11 14:57

Re: Problems to upgrade dist

Postby ruwolf » 2019-09-15 20:45

Have you restarted system? Black-list will apply after restart, I think...
Have you not seen any errors during installation of nvidia-driver?
It is meta-package, which depends on nvidia-kernel-dkms and it should build and install nvidia kernel module for you...
User avatar
ruwolf
 
Posts: 392
Joined: 2008-02-18 05:04
Location: Slovakia, Banovce nad Bebravou, Matice slovenskej 1260/4-7

Re: Problems to upgrade dist

Postby Maxxx » 2019-09-15 22:28

Yes, but maybe i wrong something
Maxxx
 
Posts: 5
Joined: 2019-09-11 14:57


Return to Installation

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable