XFCE 10.1 new install - CUPS not installed and sudo oddity

Help with issues regarding installation of Debian

XFCE 10.1 new install - CUPS not installed and sudo oddity

Postby marcusadamski » 2019-09-14 16:28

Hello,

Just installed Debian XFCE 10.1. Copied all restored all my files from backup ... and the next job is setting up my printer.

Coming from Mint / Ubuntu - I was surprised to see CUPS was not installed

Code: Select all
dpkg -l cups
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
un  cups           <none>       <none>       (no description available)


And when I tried to use 'service' to restart or re-install, discovered that's not installed. Before I go any further, can you please please confirm this is expected? If so, what's my next move, to install 'service' ... or explore another option first?

Secondly, another oddity I noticed. Although, when prompted via a dialogue, I can successfully log on as root (e.g. for synaptic) - but on the command line if I try:

Code: Select all
sudo ls
[sudo] password for marcus:
marcus is not in the sudoers file.  This incident will be reported.


Any help would be greatly appreciated,
Marc
marcusadamski
 
Posts: 1
Joined: 2019-09-14 16:14

Re: XFCE 10.1 new install - CUPS not installed and sudo oddi

Postby Bloom » 2019-09-14 16:56

If you're the only user and you're not in the sudoers file, you most likely entered a root password during install.
You need to do
Code: Select all
su root

and enter the root password, then you can install software. You can then also add yourself to the sudo system if you want.
User avatar
Bloom
 
Posts: 331
Joined: 2017-11-11 12:23


Return to Installation

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable