SOLVED - Problems with Samba after upgrade from 9 to 10

Help with issues regarding installation of Debian

SOLVED - Problems with Samba after upgrade from 9 to 10

Postby bookie » 2019-09-19 07:52

Have upgraded from Debian 9 to Debian 10 but not able to connect to home network....connection fails?
What are the best ways to troubleshoot samba problems?

bookie
Last edited by bookie on 2019-09-25 04:14, edited 1 time in total.
bookie
 
Posts: 300
Joined: 2007-12-07 11:49

Re: Problems with Samba after upgrade from 9 to 10

Postby andre@home » 2019-09-19 14:47

Can you post the logs here?

https://www.debian.org/releases/stable/ ... s-new.html
Different Samba versions 4.5 & 4.9....
What is the difference?
andre@home
 
Posts: 347
Joined: 2011-10-02 08:00

Re: Problems with Samba after upgrade from 9 to 10

Postby bookie » 2019-09-19 14:59

Hi andre@home!
I have since done a fresh install of debian and am having same problem....
I have installed samba and gvs-bin...
I can click on "Browse the Network" and see a Windows network icon...I can also see other computers that are liunx based but can't access any of them... for the linux machines I am getting "Failed to get share list from server"?
If I click on the Windows Network Icon it just goes to smb:/// and it is empty...?
I will look at attaching a log file....

bookie
bookie
 
Posts: 300
Joined: 2007-12-07 11:49

Re: Problems with Samba after upgrade from 9 to 10

Postby bookie » 2019-09-19 15:05

Couldn't find anything in log file....
bookie
 
Posts: 300
Joined: 2007-12-07 11:49

Re: Problems with Samba after upgrade from 9 to 10

Postby NFT5 » 2019-09-19 16:23

In the [global] section of smb.conf, add:

Code: Select all
client max protocol = NT1


This will allow network browsing from the file manager. It misbehaves occasionally, but is usable.
User avatar
NFT5
 
Posts: 331
Joined: 2014-10-10 11:38
Location: Canberra, Australia

Re: Problems with Samba after upgrade from 9 to 10

Postby bookie » 2019-09-19 16:50

Hi NFT5 :D
That worked and I could get access....after reboot nada...?

bookie
bookie
 
Posts: 300
Joined: 2007-12-07 11:49

Re: Problems with Samba after upgrade from 9 to 10

Postby andre@home » 2019-09-19 18:56

Tnx too... in case I need it.

I use Webdav to do a similar thing, approaching a folder or a drive on another system.
Webdav is more secure certainly when used via https on port 443.

Succes further.
andre@home
 
Posts: 347
Joined: 2011-10-02 08:00

Re: Problems with Samba after upgrade from 9 to 10

Postby bookie » 2019-09-19 22:03

Well, as far as I can see it is only samba that isn't working properly...
bookie
bookie
 
Posts: 300
Joined: 2007-12-07 11:49

Re: Problems with Samba after upgrade from 9 to 10

Postby andre@home » 2019-09-20 04:35

Well, you're lucky, considering the questions on this theme on the forum.

Personally: After several years of a certain Debian LTE version for my 2 servers, I prefer a clean install and make images (in case of a failure, whatever it is). It's a choice.

Enjoy your updated system :mrgreen:
andre@home
 
Posts: 347
Joined: 2011-10-02 08:00

Re: Problems with Samba after upgrade from 9 to 10

Postby bookie » 2019-09-21 22:24

Hi again!
Well, did a clean install and still can't browse the network....
There are a lot of workarounds but nothing works on my machine...
bookie
bookie
 
Posts: 300
Joined: 2007-12-07 11:49

Re: Problems with Samba after upgrade from 9 to 10

Postby andre@home » 2019-09-22 11:34

You need to describe your system/ config file in details.
And what kind of computer , Operating Systems, users, shares/rights , etc are you trying to approach.
Are there firewalls or virus scanners with firewalls active?
Are you approaching this Debian system from the other ones?
The same fro this Debian pc: is there a firewall or virus scanner with firewall active?

There are now to many details unknown.
andre@home
 
Posts: 347
Joined: 2011-10-02 08:00

Re: Problems with Samba after upgrade from 9 to 10

Postby CwF » 2019-09-22 13:19

On a debian machine wanting to browse connected window computers, install gigolo and gvfs-fuse and gvfs-backends. This does not require samba be installed, but will honor smb.conf setiings. There is no automagic neighborhood browsing, use gigolo to define and mount/dismount shares.

///smb: will still be flakey, most FM's and file choosers can then access /run/user/100*/gvfs
bookmark gvfs
CwF
 
Posts: 502
Joined: 2018-06-20 15:16

Re: Problems with Samba after upgrade from 9 to 10

Postby bookie » 2019-09-23 07:34

Hi guys!
andre@home:
I have shared folders on Windows 7 computers and never had a problem seeing them before this latest upgrade....
I have password protected and usually add them when I click on the link in samba...but smb:// (is unpopulated and can's see my home network at all....

cwf:
I installed gigolo and setup the Windows 7 computer I am writing from...it popped up a connection for password etc and I then had access to my shared folders from this computer...
gigolo is doing easily what samba is making a pigs ear of....;)
I have now added this computer on Debian-Server as a bookmark for ease of access

Now working like it did before

Thank you guys for your valid input!

Also had a problem with VMworkstation on the new updated Debian machine...but thanks to https://www.youtube.com/watch?v=0unvuAJ70TI I could use the info and fix that problem as well....

I will always use Debian as my main Linux distro because it is so damn good....always a few tweaks to do but that is part of Linux...

bookie
bookie
 
Posts: 300
Joined: 2007-12-07 11:49


Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable