Installed Debian 10 but fan doesn't work

Help with issues regarding installation of Debian

Installed Debian 10 but fan doesn't work

Postby luiznetto » 2019-10-05 22:29

Acer 5315-2122. Installed Debian 10 (Buster) 4 days ago. Fan sometimes works, sometimes it doesn't. Worked all day yesterday, but today it doesn't want to work. When I run Knoppix 8.1 on the same machine, like I'm doing now, it works perfectly, and Knoppix is based on Debian - same kernel. I installed fancontrol and lm-sensors two days ago, and the fan worked, but make too much noise, so I uninstalled lm-sensors. It worked fine all day, excellent temperature management. But today I booted, and noted the fan doesn't work. I re-installed lm-sensors back, but regardless the fan refuses to work when I boot into Debian 10. The old script that I used for my old Debian doesn't seem to work any more. Maybe it can be changed in a way that it will work with the new system?

Anybody can help me please? I deeply appreciate it.
Best regards.
Last edited by luiznetto on 2019-10-06 00:10, edited 1 time in total.
luiznetto
 
Posts: 46
Joined: 2013-11-26 18:40

Re: Installed Debian 10 but fan doesn't work

Postby stevepusser » 2019-10-05 22:35

Maybe the fan isn't running when the system is cool enough not to need it. We don't know, since you didn't tell us the temperatures.

You can also try adding a newer kernel from debian-backports to see if the problem is just restricted to the stock kernel.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Chromium 78.0.3904.87, Hedgewars 1.0.0, PulseEffects 4.6.8, Telegram-desktop 1.8.15, Pale Moon 28.7.2, KeepassXC 2.5.0
User avatar
stevepusser
 
Posts: 11231
Joined: 2009-10-06 05:53

Re: Installed Debian 10 but fan doesn't work

Postby luiznetto » 2019-10-06 00:13

The temperature that shows is 40 degrees Celsius. Since it keeps showing the same value for a long time, I suspect it is wrong, but I don't know for sure.

When I install fancontrol, should I install it after or before I install lm-sensors?
luiznetto
 
Posts: 46
Joined: 2013-11-26 18:40


Return to Installation

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable