nvidia on GTX 1050

Help with issues regarding installation of Debian

nvidia on GTX 1050

Postby bird12358 » 2019-10-21 18:42

Hello,

I have a Debian 9 and I want to install my Nvidia driver for my Nvidia GTX 1050. I use the recommended driver 430.50 for my card.
When I try to launch any nvidia command to get information on my conf I get error:

Code: Select all
sudo optirun nvidia-settings
[ 1622.912431] [ERROR]Cannot access secondary GPU - error: [XORG] (EE)

[ 1622.912488] [ERROR]Aborting because fallback start is disabled.


In log I get that errors:

Code: Select all
 cat /var/log/Xorg.8.log
[   968.455]
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[   968.455] Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
[   968.455] Current Operating System: Linux debian 4.19.0-5-amd64 #1 SMP Debian 4.19.37-5 (2019-06-19) x86_64
[   968.455] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.19.0-5-amd64 root=UUID=34edfe6d-b4b0-4eaf-abe1-431064c337b2 ro quiet
[   968.455] Build Date: 05 March 2019  08:11:12PM
[   968.455] xorg-server 2:1.20.4-1 (https://www.debian.org/support)
[   968.455] Current version of pixman: 0.36.0
[   968.455]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   968.455] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   968.455] (==) Log file: "/var/log/Xorg.8.log", Time: Mon Oct 21 21:19:44 2019
[   968.455] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
[   968.455] (++) Using config directory: "/etc/bumblebee/xorg.conf.d"
[   968.455] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   968.455] (==) ServerLayout "Layout0"
[   968.455] (==) No screen section available. Using defaults.
[   968.455] (**) |-->Screen "Default Screen Section" (0)
[   968.455] (**) |   |-->Monitor "<default monitor>"
[   968.455] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[   968.455] (**) |   |-->Device "DiscreteNvidia"
[   968.455] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[   968.455] (**) Option "AutoAddDevices" "true"
[   968.455] (**) Option "AutoAddGPU" "false"
[   968.455] (**) Automatically adding devices
[   968.455] (==) Automatically enabling devices
[   968.455] (**) Not automatically adding GPU devices
[   968.455] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   968.455] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   968.455]    Entry deleted from font path.
[   968.455] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins
[   968.455] (++) ModulePath set to "/usr/lib/nvidia/nvidia,/usr/lib/xorg/modules"
[   968.455] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[   968.455] (II) Loader magic: 0x55c5aec26e20
[   968.455] (II) Module ABI versions:
[   968.455]    X.Org ANSI C Emulation: 0.4
[   968.455]    X.Org Video Driver: 24.0
[   968.455]    X.Org XInput driver : 24.1
[   968.455]    X.Org Server Extension : 10.0
[   968.456] (--) using VT number 2

[   968.456] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   968.456] (II) xfree86: Adding drm device (/dev/dri/card0)
[   968.456] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[   968.458] (--) PCI:*(1@0:0:0) 10de:1c8d:103c:8259 rev 161, Mem @ 0xb3000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
[   968.458] (II) LoadModule: "glx"
[   968.458] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   968.465] (II) Module glx: vendor="X.Org Foundation"
[   968.465]    compiled for 1.20.4, module version = 1.0.0
[   968.465]    ABI class: X.Org Server Extension, version 10.0
[   968.465] (II) LoadModule: "nvidia"
[   968.465] (II) Loading /usr/lib/nvidia/nvidia/nvidia_drv.so
[   968.467] (II) Module nvidia: vendor="NVIDIA Corporation"
[   968.467]    compiled for 1.6.99.901, module version = 1.0.0
[   968.467]    Module class: X.Org Video Driver
[   968.467] (II) NVIDIA dlloader X Driver  430.50  Thu Sep  5 22:43:53 CDT 2019
[   968.467] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   968.467] (II) Loading sub module "fb"
[   968.467] (II) LoadModule: "fb"
[   968.467] (II) Loading /usr/lib/xorg/modules/libfb.so
[   968.467] (II) Module fb: vendor="X.Org Foundation"
[   968.467]    compiled for 1.20.4, module version = 1.0.0
[   968.467]    ABI class: X.Org ANSI C Emulation, version 0.4
[   968.467] (II) Loading sub module "wfb"
[   968.467] (II) LoadModule: "wfb"
[   968.468] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   968.468] (II) Module wfb: vendor="X.Org Foundation"
[   968.468]    compiled for 1.20.4, module version = 1.0.0
[   968.468]    ABI class: X.Org ANSI C Emulation, version 0.4
[   968.468] (II) Loading sub module "ramdac"
[   968.468] (II) LoadModule: "ramdac"
[   968.468] (II) Module "ramdac" already built-in
[   968.468] (II) NVIDIA(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[   968.468] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[   968.468] (==) NVIDIA(0): RGB weight 888
[   968.468] (==) NVIDIA(0): Default visual is TrueColor
[   968.468] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   968.468] (**) NVIDIA(0): Option "ProbeAllGpus" "false"
[   968.468] (**) NVIDIA(0): Option "UseEDID" "false"
[   968.468] (**) NVIDIA(0): Option "UseDisplayDevice" "none"
[   968.468] (**) NVIDIA(0): Enabling 2D acceleration
[   968.468] (**) NVIDIA(0): Ignoring EDIDs
[   968.468] (**) NVIDIA(0): Option "UseDisplayDevice" set to "none"; enabling NoScanout
[   968.468] (**) NVIDIA(0):     mode
[   968.469] (II) Loading sub module "glxserver_nvidia"
[   968.469] (II) LoadModule: "glxserver_nvidia"
[   968.469] (II) Loading /usr/lib/nvidia/nvidia/libglxserver_nvidia.so
[   968.490] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"
[   968.490]    compiled for 1.6.99.901, module version = 1.0.0
[   968.490]    Module class: X.Org Server Extension
[   968.490] (II) NVIDIA GLX Module  430.50  Thu Sep  5 22:41:46 CDT 2019
[   968.948] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 1050 (GP107-A) at PCI:1:0:0 (GPU-0)
[   968.948] (--) NVIDIA(0): Memory: 2097152 kBytes
[   968.948] (--) NVIDIA(0): VideoBIOS: 86.07.3d.00.09
[   968.948] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   968.948] (II) NVIDIA(0): Validated MetaModes:
[   968.948] (II) NVIDIA(0):     "NULL"
[   968.948] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[   968.948] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[   968.948] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[   968.948] (II) NVIDIA: Using 24576.00 MB of virtual memory for indirect memory
[   968.948] (II) NVIDIA:     access.
[   968.952] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[   968.952] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[   968.952] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[   968.952] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[   968.952] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[   968.952] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[   968.952] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[   968.952] (II) NVIDIA(0):     Config Options in the README.
[   968.965] (II) NVIDIA(0): Setting mode "NULL"
[   968.967] (==) NVIDIA(0): Disabling shared memory pixmaps
[   968.967] (==) NVIDIA(0): Backing store enabled
[   968.967] (==) NVIDIA(0): Silken mouse enabled
[   968.967] (==) NVIDIA(0): DPMS enabled
[   968.967] (WW) NVIDIA(0): Option "NoLogo" is not used
[   968.967] (II) Loading sub module "dri2"
[   968.967] (II) LoadModule: "dri2"
[   968.967] (II) Module "dri2" already built-in
[   968.967] (II) NVIDIA(0): [DRI2] Setup complete
[   968.967] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[   968.967] (II) Initializing extension Generic Event Extension
[   968.968] (II) Initializing extension SHAPE
[   968.968] (II) Initializing extension MIT-SHM
[   968.968] (II) Initializing extension XInputExtension
[   968.968] (II) Initializing extension XTEST
[   968.968] (II) Initializing extension BIG-REQUESTS
[   968.968] (II) Initializing extension SYNC
[   968.968] (II) Initializing extension XKEYBOARD
[   968.968] (II) Initializing extension XC-MISC
[   968.968] (II) Initializing extension SECURITY
[   968.968] (II) Initializing extension XFIXES
[   968.968] (II) Initializing extension RENDER
[   968.968] (II) Initializing extension RANDR
[   968.969] (II) Initializing extension COMPOSITE
[   968.969] (II) Initializing extension DAMAGE
[   968.969] (II) Initializing extension MIT-SCREEN-SAVER
[   968.969] (II) Initializing extension DOUBLE-BUFFER
[   968.969] (II) Initializing extension RECORD
[   968.969] (II) Initializing extension DPMS
[   968.969] (II) Initializing extension Present
[   968.969] (II) Initializing extension DRI3
[   968.969] (II) Initializing extension X-Resource
[   968.969] (II) Initializing extension XVideo
[   968.969] (II) Initializing extension XVideo-MotionCompensation
[   968.969] (II) Initializing extension SELinux
[   968.969] (II) SELinux: Disabled on system
[   968.969] (II) Initializing extension GLX
[   968.970] (II) Initializing extension GLX
[   968.970] (II) Indirect GLX disabled.
[   968.970] (II) GLX: Another vendor is already registered for screen 0
[   968.970] (II) Initializing extension XFree86-VidModeExtension
[   968.970] (II) Initializing extension XFree86-DGA
[   968.970] (II) Initializing extension XFree86-DRI
[   968.970] (II) Initializing extension DRI2
[   968.970] (II) Initializing extension NV-GLX
[   968.970] (II) Initializing extension NV-CONTROL
[   968.975] (EE)
[   968.975] (EE) Backtrace:
[   968.977] (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x139) [0x55c5aeb992c9]
[   968.978] (EE) 1: /lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x50) [0x7f2815fd655f]
[   968.978] (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (memcpy+0x1f) [0x7f2815ea4c9f]
[   968.978] (EE) 3: /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.430.50 (_nv043glcore+0x27ff09) [0x7f2814ad0809]
[   968.978] (EE) 4: /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.430.50 (_nv043glcore+0x28006d) [0x7f2814ad0b2d]
[   968.978] (EE) 5: /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.430.50 (_nv015glcore+0x49ab8) [0x7f2814582fd8]
[   968.978] (EE) unw_get_proc_name failed: no unwind info found [-10]
[   968.978] (EE) 6: /usr/lib/nvidia/nvidia/libglxserver_nvidia.so (?+0x0) [0x7f28124f6d32]
[   968.978] (EE)
[   968.978] (EE) Segmentation fault at address 0x7f28125f0000
[   968.978] (EE)
Fatal server error:
[   968.978] (EE) Caught signal 11 (Segmentation fault). Server aborting
[   968.978] (EE)
[   968.978] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   968.978] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
[   968.978] (EE)
[   968.980] (EE) Server terminated with error (1). Closing log file.


I try different solutions but there are still errors when I try to execute programs.

Can someone give me advice ?

Best regard.
bird12358
 
Posts: 2
Joined: 2019-10-21 18:37

Re: nvidia on GTX 1050

Postby stevepusser » 2019-10-21 22:03

You have a hardware related issue. We need hardware and system information to provide good answers.

Please install inxi and provide the output of "inxi -Fxxz" in the terminal to provide that information.

Furthermore, Nvidia-driver 430.50 is not available for Stretch or in stretch-backports, so you left out important information as to how you tried to install that.

Newer Nvidia drivers are possible on a Stretch base...I offer the laptop I'm using right now:
Code: Select all
$ optirun inxi -G
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia v: 435.21
           Display: x11 server: X.Org 1.19.2 driver: intel resolution: 1920x1080~60Hz
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21


But this is on MX-18, where I and other developers have put in a lot of work to make the install as easy as possible. You should also be aware, as far as I know, that Bumblebee does not support Vulkan if you want to use that for gaming.

BTW, Buster-based MX 19 is due to be released in a matter of hours...
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Clipgrab 3.8.6, Hedgewars 1.0.0, PulseEffects 4.6.8, Telegram-desktop 1.8.15, Pale Moon 28.7.2, KeepassXC 2.5.1
User avatar
stevepusser
 
Posts: 11258
Joined: 2009-10-06 05:53

Re: nvidia on GTX 1050

Postby bird12358 » 2019-10-22 04:40

Than you for the answer. Here is the command result I have.

Code: Select all
optirun inxi -G
Graphics:
  Device-1: Intel HD Graphics 630 driver: i915 v: kernel
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nouveau
  v: kernel
  Display: x11 server: X.Org 1.20.4 driver: modesetting,nouveau,nvidia
  unloaded: fbdev,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: llvmpipe (LLVM 9.0 256 bits) v: 3.3 Mesa 19.2.1


Code: Select all
optirun inxi -Fxxz
System:
  Host: debian Kernel: 4.19.0-5-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0
  Desktop: Gnome 3.30.2 wm: gnome-shell dm: GDM3
  Distro: Debian GNU/Linux bullseye/sid
Machine:
  Type: Laptop System: HP product: OMEN by HP Laptop v: Type1ProductConfigId
  serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: HP model: 8259 v: 83.46 serial: <filter> UEFI: Insyde v: F.37
  date: 04/20/2017
Battery:
  ID-1: BAT0 charge: 56.7 Wh condition: 56.7/56.7 Wh (100%) volts: 15.8/15.4
  model: Hewlett-Packard Primary serial: <filter> status: Discharging
CPU:
  Topology: Quad Core model: Intel Core i5-7300HQ bits: 64 type: MCP
  arch: Kaby Lake rev: 9 L2 cache: 6144 KiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 19968
  Speed: 900 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 867 2: 865
  3: 879 4: 890
Graphics:
  Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915
  v: kernel bus ID: 00:02.0 chip ID: 8086:591b
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1c8d
  Display: x11 server: X.Org 1.20.4 driver: modesetting,nouveau,nvidia
  unloaded: fbdev,vesa alternate: nv compositor: gnome-shell
  resolution: 1920x1080~60Hz
  OpenGL: renderer: llvmpipe (LLVM 9.0 256 bits) v: 3.3 Mesa 19.2.1
  compat-v: 3.1 direct render: Yes
Audio:
  Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a171
  Sound Server: ALSA v: k4.19.0-5-amd64
Network:
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: 4000
  bus ID: 04:00.0 chip ID: 8086:095a
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 05:00.0
  chip ID: 10ec:8168
  IF: eno1 state: down mac: <filter>
Drives:
  Local Storage: total: 1.03 TiB used: 145.61 GiB (13.9%)
  ID-1: /dev/sda vendor: SanDisk model: SD8SN8U-128G-1006 size: 119.24 GiB
  speed: 6.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: HGST (Hitachi) model: HTS721010A9E630
  size: 931.51 GiB speed: 6.0 Gb/s serial: <filter>
Partition:
  ID-1: / size: 404.27 GiB used: 145.51 GiB (36.0%) fs: ext4 dev: /dev/sdb5
  ID-2: swap-1 size: 14.90 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb3
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A gpu: nouveau temp: 27 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 230 Uptime: 9h 15m Memory: 7.68 GiB used: 1.89 GiB (24.6%)
  Init: systemd v: 242 runlevel: 5 Compilers: gcc: 9.2.1 alt: 6/7/8/9
  Shell: optirun running in: terminator inxi: 3.0.36


I purge all package on my computer and remove all nvidia package then I properly install nvidia-driver package.
After a reboot instead of getting the logging page, I get a white page, with message : "Oops something wrong append."
And I can't log on my session.
bird12358
 
Posts: 2
Joined: 2019-10-21 18:37


Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable