Why are these Debian v8 (Jessie)'s packages not needed?

Help with issues regarding installation of Debian

Why are these Debian v8 (Jessie)'s packages not needed?

Postby ant » 2019-12-07 17:25

Hello.

$ sudo apt-get update ; sudo apt-get dist-upgrade
Ign http://dl.google.com stable InRelease
Ign http://deb.debian.org jessie InRelease
Hit http://archive.debian.org jessie-backports InRelease
Hit http://dl.google.com stable Release.gpg
Hit http://security.debian.org jessie/updates InRelease
Hit http://deb.debian.org jessie Release.gpg
Hit http://dl.google.com stable Release
Hit http://deb.debian.org jessie Release
Ign http://archive.debian.org jessie-backports/main Sources/DiffIndex
Hit http://dl.google.com stable/main amd64 Packages
Ign http://archive.debian.org jessie-backports/contrib Sources/DiffIndex
Hit http://deb.debian.org jessie/main Sources
Hit http://security.debian.org jessie/updates/main Sources
Hit http://deb.debian.org jessie/contrib Sources
Hit http://deb.debian.org jessie/non-free Sources
Hit http://deb.debian.org jessie/main amd64 Packages
Hit http://security.debian.org jessie/updates/contrib Sources
Ign http://archive.debian.org jessie-backports/non-free Sources/DiffIndex
Hit http://deb.debian.org jessie/contrib amd64 Packages
Hit http://deb.debian.org jessie/non-free amd64 Packages
Hit http://security.debian.org jessie/updates/non-free Sources
Ign http://archive.debian.org jessie-backports/main amd64 Packages/DiffIndex
Hit http://security.debian.org jessie/updates/main amd64 Packages
Hit http://deb.debian.org jessie/main i386 Packages
Hit http://security.debian.org jessie/updates/contrib amd64 Packages
Ign http://archive.debian.org jessie-backports/contrib amd64 Packages/DiffIndex
Hit http://security.debian.org jessie/updates/non-free amd64 Packages
Hit http://deb.debian.org jessie/contrib i386 Packages
Hit http://security.debian.org jessie/updates/main i386 Packages
Ign http://archive.debian.org jessie-backports/non-free amd64 Packages/DiffIndex
Hit http://deb.debian.org jessie/non-free i386 Packages
Hit http://deb.debian.org jessie/contrib Translation-en
Hit http://deb.debian.org jessie/main Translation-en
Ign http://archive.debian.org jessie-backports/main i386 Packages/DiffIndex
Hit http://deb.debian.org jessie/non-free Translation-en
Ign http://dl.google.com stable/main Translation-en_US
Ign http://archive.debian.org jessie-backports/contrib i386 Packages/DiffIndex
Hit http://security.debian.org jessie/updates/contrib i386 Packages
Ign http://dl.google.com stable/main Translation-en
Ign http://archive.debian.org jessie-backports/non-free i386 Packages/DiffIndex
Ign http://archive.debian.org jessie-backports/contrib Translation-en/DiffIndex
Hit http://security.debian.org jessie/updates/non-free i386 Packages
Hit http://security.debian.org jessie/updates/contrib Translation-en
Hit http://security.debian.org jessie/updates/main Translation-en
Hit http://security.debian.org jessie/updates/non-free Translation-en
Ign http://archive.debian.org jessie-backports/main Translation-en/DiffIndex
Ign http://archive.debian.org jessie-backports/non-free Translation-en/DiffIndex
Hit http://archive.debian.org jessie-backports/contrib Translation-en
Hit http://archive.debian.org jessie-backports/main Translation-en
Hit http://archive.debian.org jessie-backports/non-free Translation-en
Hit http://archive.debian.org jessie-backports/main Sources
Hit http://archive.debian.org jessie-backports/contrib Sources
Hit http://archive.debian.org jessie-backports/non-free Sources
Hit http://archive.debian.org jessie-backports/main amd64 Packages
Hit http://archive.debian.org jessie-backports/contrib amd64 Packages
Hit http://archive.debian.org jessie-backports/non-free amd64 Packages
Hit http://archive.debian.org jessie-backports/main i386 Packages
Hit http://archive.debian.org jessie-backports/contrib i386 Packages
Hit http://archive.debian.org jessie-backports/non-free i386 Packages
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
i965-va-driver:i386 libgsm1:i386 libmp3lame0:i386 libopenjpeg5:i386 libschroedinger-1.0-0:i386
libspeex1:i386 libspeexdsp1:i386 libtheora0:i386 libva1:i386 libvdpau1:i386 libx264-142:i386
libxvidcore4:i386 va-driver-all:i386 vdpau-va-driver:i386
Use 'apt-get autoremove' to remove them.
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Why are these Debian v8 (Jessie)'s packages not needed anymore since yesterday? :/

Thank you for reading and hopefully answering soon. :)
Last edited by ant on 2019-12-07 20:32, edited 2 times in total.
ant
 
Posts: 313
Joined: 2011-11-09 00:15

Re: Why are these Debian v8 (Jessie)'s packages not needed?

Postby arzgi » 2019-12-07 17:48

Most likely you have removed some package, which dependencies they were.
arzgi
 
Posts: 667
Joined: 2008-02-21 17:03
Location: Finland

Re: Why are these Debian v8 (Jessie)'s packages not needed?

Postby arid » 2019-12-07 19:51

What do you care?

Is your system working?

You don't have to remove packages if you're going to get all paranoid.

Considering how old your system is, maybe you should hang on to them anyway.
There's no drama in my sid......
arid
 
Posts: 96
Joined: 2014-05-08 18:40
Location: Aridzona

Re: Why are these Debian v8 (Jessie)'s packages not needed?

Postby ant » 2019-12-07 20:29

arzgi wrote:Most likely you have removed some package, which dependencies they were.
Hmm, it must be related to this according to history command with grepped apt-get variable:
05/12/19 10:18:42 sudo apt-get install libavcodec56 libavresample2 libavutil54


$ cat /var/log/apt/history.log

Start-Date: 2019-12-01 09:36:53
Commandline: apt-get dist-upgrade
Upgrade: file:amd64 (5.22+15-2+deb8u6, 5.22+15-2+deb8u7), libmagic1:amd64 (5.22+15-2+deb8u 6, 5.22+15-2+deb8u7)
End-Date: 2019-12-01 09:36:59

Start-Date: 2019-12-01 17:58:04
Commandline: apt-get install bsdiff
Install: bsdiff:amd64 (4.3-15+deb8u1)
End-Date: 2019-12-01 17:58:10

Start-Date: 2019-12-03 09:23:00
Commandline: apt-get dist-upgrade
Upgrade: libexiv2-13:amd64 (0.24-4.1+deb8u4, 0.24-4.1+deb8u5), exiv2:amd64 (0.24-4.1+deb8u 4, 0.24-4.1+deb8u5)
End-Date: 2019-12-03 09:23:06

Start-Date: 2019-12-05 10:18:26
Commandline: apt-get dist-upgrade
Upgrade: libavformat56:amd64 (11.12-1~deb8u8, 11.12-1~deb8u9), libswscale3:amd64 (11.12-1~ deb8u8, 11.12-1~deb8u9)
End-Date: 2019-12-05 10:18:31

Start-Date: 2019-12-05 10:18:59
Commandline: apt-get install libavcodec56 libavresample2 libavutil54
Upgrade: libavresample2:amd64 (11.12-1~deb8u8, 11.12-1~deb8u9), libavcodec56:amd64 (11.12- 1~deb8u8, 11.12-1~deb8u9), libavutil54:amd64 (11.12-1~deb8u8, 11.12-1~deb8u9)
Remove: libavresample2:i386 (11.12-1~deb8u8), libasound2-plugins:i386 (1.0.28-1+b1), libav codec56:i386 (11.12-1~deb8u8), libavutil54:i386 (11.12-1~deb8u8)
End-Date: 2019-12-05 10:19:06
(SopelPython3)ant@ANTian:~/Downloads$ cat /var/log/apt/history.log

Start-Date: 2019-12-01 09:36:53
Commandline: apt-get dist-upgrade
Upgrade: file:amd64 (5.22+15-2+deb8u6, 5.22+15-2+deb8u7), libmagic1:amd64 (5.22+15-2+deb8u6, 5.22+15-2+deb8u7)
End-Date: 2019-12-01 09:36:59

Start-Date: 2019-12-01 17:58:04
Commandline: apt-get install bsdiff
Install: bsdiff:amd64 (4.3-15+deb8u1)
End-Date: 2019-12-01 17:58:10

Start-Date: 2019-12-03 09:23:00
Commandline: apt-get dist-upgrade
Upgrade: libexiv2-13:amd64 (0.24-4.1+deb8u4, 0.24-4.1+deb8u5), exiv2:amd64 (0.24-4.1+deb8u4, 0.24-4.1+deb8u5)
End-Date: 2019-12-03 09:23:06

Start-Date: 2019-12-05 10:18:26
Commandline: apt-get dist-upgrade
Upgrade: libavformat56:amd64 (11.12-1~deb8u8, 11.12-1~deb8u9), libswscale3:amd64 (11.12-1~deb8u8, 11.12-1~deb8u9)
End-Date: 2019-12-05 10:18:31

Start-Date: 2019-12-05 10:18:59
Commandline: apt-get install libavcodec56 libavresample2 libavutil54
Upgrade: libavresample2:amd64 (11.12-1~deb8u8, 11.12-1~deb8u9), libavcodec56:amd64 (11.12-1~deb8u8, 11.12-1~deb8u9), libavutil54:amd64 (11.12-1~deb8u8, 11.12-1~deb8u9)
Remove: libavresample2:i386 (11.12-1~deb8u8), libasound2-plugins:i386 (1.0.28-1+b1), libavcodec56:i386 (11.12-1~deb8u8), libavutil54:i386 (11.12-1~deb8u8)
End-Date: 2019-12-05 10:19:06
ant
 
Posts: 313
Joined: 2011-11-09 00:15

Re: Why are these Debian v8 (Jessie)'s packages not needed?

Postby arzgi » 2019-12-08 08:51

I always upgrade to stable soon after it is released. apt changed, was it after jessie, so it knows which packages are not any more needed, and lists them when you update.

So this is normal now, before you had to use aptitude to tell you unneeded packages.

P.S. Please use code boxes.
arzgi
 
Posts: 667
Joined: 2008-02-21 17:03
Location: Finland


Return to Installation

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable