[SOLVED] Dependecy problem upgrading from Stretch to Buster

Help with issues regarding installation of Debian

[SOLVED] Dependecy problem upgrading from Stretch to Buster

Postby DeadTOm76 » 2019-12-09 19:07

I got this error while performing the upgrade today:

Code: Select all
#apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 gstreamer1.0-plugins-base : Breaks: gstreamer1.0-plugins-base:i386 (!= 1.10.4-1+deb9u1) but 1.14.4-2 is installed
 gstreamer1.0-plugins-base:i386 : Breaks: gstreamer1.0-plugins-base (!= 1.14.4-2) but 1.10.4-1+deb9u1 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies


I've tried running the following commands:

Code: Select all
#dpkg --configure -a


Code: Select all
#apt install -f


I've gone through my sources and found an Ubuntu entry in there, which is probably what initiated this. I have since removed it and ran 'apt update', but this problem isn't going away.

Does anyone know how I can resolve this?

Thanks.
Last edited by DeadTOm76 on 2019-12-10 15:20, edited 1 time in total.
User avatar
DeadTOm76
 
Posts: 44
Joined: 2017-09-22 15:36
Location: Missoula, MT USA

Re: Dependecy problem upgrading from Stretch to Buster

Postby Head_on_a_Stick » 2019-12-09 19:19

DeadTOm76 wrote:I've gone through my sources and found an Ubuntu entry in there, which is probably what initiated this. I have since removed it and ran 'apt update', but this problem isn't going away.

You need to remove the packages installed from the Ubuntu source:
Code: Select all
# aptitude purge $(aptitude search '?narrow(?installed, !?origin(debian))')

Check the output carefully before accepting, aptitude may offer several options. Post them all here if you're not sure.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Dependecy problem upgrading from Stretch to Buster

Postby cuckooflew » 2019-12-09 19:24

Please Read What we expect you have already Done
Search Engines know a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
and
Just say NO to help vampires!
cuckooflew
 
Posts: 683
Joined: 2018-05-10 19:34
Location: Some where out west

Re: Dependecy problem upgrading from Stretch to Buster

Postby Head_on_a_Stick » 2019-12-09 19:26

Nice link, I forgot about that thread :)
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Dependecy problem upgrading from Stretch to Buster

Postby DeadTOm76 » 2019-12-09 19:35

Head_on_a_Stick wrote:You need to remove the packages installed from the Ubuntu source:
Code: Select all
# aptitude purge $(aptitude search '?narrow(?installed, !?origin(debian))')

Check the output carefully before accepting, aptitude may offer several options. Post them all here if you're not sure.


Unfortunately, since this happened in the middle of an upgrade, aptitude is not installed, and I'm unable to install or remove anything with apt or apt-get, because of this error.
User avatar
DeadTOm76
 
Posts: 44
Joined: 2017-09-22 15:36
Location: Missoula, MT USA

Re: Dependecy problem upgrading from Stretch to Buster

Postby Head_on_a_Stick » 2019-12-09 19:40

https://www.hooktube.com/watch?v=LukyMYp2noo

Ah well, it's probably safer to reinstall anyway...
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Dependecy problem upgrading from Stretch to Buster

Postby DeadTOm76 » 2019-12-10 15:19

After playing around with dpkg, I finally figured out how to resolve this. I ran these two commands:

Code: Select all
sudo dpkg --remove --force-remove-reinstreq gstreamer1.0-plugins-base:amd64
sudo dpkg --remove --force-remove-reinstreq gstreamer1.0-plugins-bad:i386


This worked, and the problematic software was removed. After this, I ran dpkg --configure -a, then apt update, apt dist-upgrade, and the install finished without issue.

Everything is working fine now.
User avatar
DeadTOm76
 
Posts: 44
Joined: 2017-09-22 15:36
Location: Missoula, MT USA

Re: [SOLVED] Dependecy problem upgrading from Stretch to Bus

Postby Head_on_a_Stick » 2019-12-11 16:51

Have you checked for any other Ubuntu packages? The problem might re-occur unless you cleanse your system.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: [SOLVED] Dependecy problem upgrading from Stretch to Bus

Postby DeadTOm76 » 2019-12-11 16:54

Head_on_a_Stick wrote:Have you checked for any other Ubuntu packages? The problem might re-occur unless you cleanse your system.


Yeah, I removed everything supplied by Ubuntu.
User avatar
DeadTOm76
 
Posts: 44
Joined: 2017-09-22 15:36
Location: Missoula, MT USA


Return to Installation

Who is online

Users browsing this forum: No registered users and 19 guests

fashionable