[solved] Install error

Help with issues regarding installation of Debian

[solved] Install error

Postby oldboy » 2019-12-29 22:05

Just upgraded to Buster and got these errors. How do I get them corrected? TIA

Errors were encountered while processing:
/tmp/apt-dpkg-install-9Leyup/246-libel-api-java_3.0.0-2_all.deb
/tmp/apt-dpkg-install-9Leyup/256-libjsp-api-java_2.3.4-2_all.deb
/tmp/apt-dpkg-install-9Leyup/266-libwebsocket-api-java_1.1-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Last edited by oldboy on 2019-12-30 04:26, edited 1 time in total.
This oldboy has a lot of time in his hands
Linux slows down my Alzheimer and dementia
oldboy
 
Posts: 716
Joined: 2007-08-09 12:45

Re: Install error

Postby oldboy » 2019-12-29 22:32

OK, I managed to correct the error going into advanced mode. Now I have this problem:
root@debian:/home/shum# uname -r
4.9.0-8-amd64


This is the old header. How do I change to use the new header which should be 4.19.0..
Also I do not have the Linux image 4.19.0.
Should I just install these two packages?

Looking further, I found that Linux-header 4.19.67-4.19.67-2+deb10u2 is install
But the Linux-image 4.19.67-2+deb10u2 is not installed but 4.9.0.... version is installed

During the upgrade process, the /root drive has a warning that drive is low in storage. I have now used auto remove to gain more space. Is this the reason why the new image is not installed? Should I go ahead an install it an remove the old 4.9.0....?


Please advice Tia
This oldboy has a lot of time in his hands
Linux slows down my Alzheimer and dementia
oldboy
 
Posts: 716
Joined: 2007-08-09 12:45

Re: Install error

Postby oldboy » 2019-12-30 04:26

OK. Just installed the new image. Thanks for reading
This oldboy has a lot of time in his hands
Linux slows down my Alzheimer and dementia
oldboy
 
Posts: 716
Joined: 2007-08-09 12:45

Re: [solved] Install error

Postby p.H » 2019-12-30 07:51

Did you follow the buster release notes when upgrading ? They address most of your issues (and many more).
p.H
 
Posts: 1260
Joined: 2017-09-17 07:12

Re: [solved] Install error

Postby oldboy » 2019-12-30 13:33

No I did not read the release notes. My bad.
This oldboy has a lot of time in his hands
Linux slows down my Alzheimer and dementia
oldboy
 
Posts: 716
Joined: 2007-08-09 12:45


Return to Installation

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable