terminal login after install

Help with issues regarding installation of Debian

terminal login after install

Postby techwinder » 2019-12-30 11:56

Hi everyone,
Tried to install Debian for the first time. I used the graphic installer and everything went well. I Selected the KDE desktop.
However GRUB directs directly to the terminal and does not launch the desktop. I'm just a casual linux user who has been working with another distro up to now, so I've no idea what to do next.
BtW, I tried this on two distinct computers with exactly the same result.
Attached is the screenshot of the point I've reached.
Thanks in advance for any help.

Posts: 2
Joined: 2019-12-30 11:40

Re: terminal login after install

Postby techwinder » 2019-12-30 14:57

Thanks, but the thread is of no help at all.
Still stuck.
Posts: 2
Joined: 2019-12-30 11:40

Re: terminal login after install

Postby Hallvor » 2020-01-07 15:39

This happened to me 14 days ago when installing Debian 10 KDE on one of my dad's old laptops. It needed non-free video drivers to boot to the desktop.

Without knowing your hardware, there is not much anyone can do to help.

Log in with your username and password, then type lspci. Post the output here.
Lenovo Thinkpad T440S, Intel Core i7-4600U CPU @ 2.10GHz, 8 GB RAM, 256 GB SSD, Debian Buster (KDE)
Lenovo Thinkpad X240, Intel Core i5-4300U CPU @ 2.90GHz, 8 GB RAM, 120 GB SSD, Debian Buster (KDE)
User avatar
Posts: 994
Joined: 2009-04-16 18:35
Location: Norway

Re: terminal login after install

Postby oswaldkelso » 2020-01-07 19:24

It could be many things. My shuttle machine was notoriously difficult with many desktops.

Strange it happens on 2 machines. Before you go wasting your day. Did you check the iso?

I got this from my notes on plasma.

"plasma really struggled to load the monitor. Very slow to start like over a minute or two. First time I got a black screen and waited.
Eventually an option to select a monitor appeared. I clicked the wrong one and got a permanent black screen. I opened a tty and went in to .local/share/kscreen and deleted the file in there. rebooted and tried again this time I selected the correct monitor and eventually got a desktop."

Basically it thought I had 2 monitors and picked the one I didn't have as the main primary monitor.

Have you tried typing

Ash init durbatulûk, ash init gimbatul,
Ash init thrakatulûk agh burzum-ishi krimpatul.
User avatar
Posts: 1215
Joined: 2005-07-26 23:20
Location: UK

Return to Installation

Who is online

Users browsing this forum: No registered users and 6 guests