Black screen after succesful install

Help with issues regarding installation of Debian

Black screen after succesful install

Postby SivMonkey » 2020-02-24 01:26

Hello, im relatively new to linux, I messed around with it years ago, heard about buster and wanted to try it out.. Never had an issue with installing a Linux OS, but when i installed debian buster 10.3 it reboots and goes straight ito black screen after initial startup sequence. No login screen.. Nothing. straight to black screen with a blinking cursor in the top left. not a mouse cursor.. text, a caret. Pretty sure i didnt have to explain that.. whatever but through my research i have found only fixes for ubuntu black screen issues but i've tried everything to my limited "knowledge" of a linux os. but im pretty positive it is an issue with my nvidia graphics card... but i cant get to anything inside the os itself to install the driver package... and i cant find a distro that offers the software package in the installation media itself. I've consulted the wiki and know i need buster-backports but have no idea have to achieve getting to it without being in the OS. So if someone could please lend a hand to a down on his luck simple windows pal, to have i can achieve installing debian and being able to boot into the OS having the drivers i need.

I have Nvidia RTX 2070..
Thanks.
SivMonkey
 
Posts: 7
Joined: 2020-02-24 01:15


Re: Black screen after succesful install

Postby SivMonkey » 2020-02-25 06:21

Thanks it looks like you are on to something with that link and I was trying to execute it but couldn’t most likely because of the mirror that I chose in installation so I went to reinstall deb and now grub boot loader is opening into bash terminal... something went wrong but did everything the same and even just completely formatted partition and did fresh install... now I’m trying to figure out how to fix this. Any ideas? Thank you though for the link as well the link you posted looks like it’s for amd cards or that’s just all that he mentioned and it’s for any recent graphics cards because as I mentioned I have Nvidia GeForce RTX 2070.

Again thank you for the link!
SivMonkey
 
Posts: 7
Joined: 2020-02-24 01:15

Re: Black screen after succesful install

Postby Chrisdb » 2020-02-25 15:57

You should really get to the point with your posts. They're really bloated with irrelevant info. Tip: use paragraphs.

What are your system specs? Is your system using bios or UEFI? The partitioning probably screwed up your installation.

How did you partition your drive?
Chrisdb
 
Posts: 273
Joined: 2018-04-10 07:16

Re: Black screen after succesful install

Postby Head_on_a_Stick » 2020-02-25 16:02

SivMonkey wrote:the link you posted looks like it’s for amd cards or that’s just all that he mentioned and it’s for any recent graphics cards because as I mentioned I have Nvidia GeForce RTX 2070

My linked guide applies to all AMD cards, any Skylake or newer Intel cards and any NVIDIA cards not using the proprietary drivers (if you didn't install them yourself then you're not using them).

EDIT: and it just so happens that I do identify as male but I still prefer an impersonal pronoun (ie, "they mentioned"). Thanks.
User avatar
Head_on_a_Stick
 
Posts: 11992
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Black screen after succesful install

Postby SivMonkey » 2020-02-26 03:50

it’s fine man. I’ll figure it out. Thanks tho
SivMonkey
 
Posts: 7
Joined: 2020-02-24 01:15


Return to Installation

Who is online

Users browsing this forum: NFT5 and 6 guests

fashionable