KDEnlive playback flickers after Debian 10 upgrade

Help with issues regarding installation of Debian

KDEnlive playback flickers after Debian 10 upgrade

Postby sailor757 » 2020-02-29 05:45

Hi all! I have an Nvidia GS 8400 graphics card using the proprietary Nvidia drivers.
After upgrading my Debian 10, these drivers were upgraded to version 340.108.
After the upgrade, playback within KDEnlive flickers to the point it renders the application useless.
Any clues how to get rid of the flickering?

How the flickering looks: https://www.youtube.com/watch?v=Vur9YI69HWk
sailor757
 
Posts: 6
Joined: 2019-08-01 19:20

Re: KDEnlive playback flickers after Debian 10 upgrade

Postby stevepusser » 2020-03-01 01:37

We are getting reports of the same driver update causing similar issues on MX Linux, too, possibly due to an incorrect symlink to the Nvidia GL shared library.

Can you install inxi and give us the results of "inxi -Gxx" in the terminal?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.6, Strawberry 0.6.11, Muse 3.1.0, Chromium with va-api, Audacity 2.4.1, Kdenlive 20.04
User avatar
stevepusser
 
Posts: 11692
Joined: 2009-10-06 05:53

Re: KDEnlive playback flickers after Debian 10 upgrade

Postby sailor757 » 2020-03-04 11:11

Sure, here is the output from inxi -Gxx. I'm now running Ubuntu Studio and it is the same problem there:

With Nvidia driver

Graphics:
Device-1: NVIDIA GT218 [GeForce 8400 GS Rev. 3] vendor: Micro-Star MSI
driver: nvidia v: 340.107 bus ID: 02:00.0 chip ID: 10de:10c3
Display: x11 server: X.Org 1.20.5 driver: nvidia
resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce 8400GS/PCIe/SSE2 v: 3.3.0 NVIDIA 340.107
direct render: Yes


With Noveau driver

inxi -Gxx
Graphics:
Device-1: NVIDIA GT218 [GeForce 8400 GS Rev. 3] vendor: Micro-Star MSI
driver: nouveau v: kernel bus ID: 02:00.0 chip ID: 10de:10c3
Display: x11 server: X.Org 1.20.5 driver: modesetting unloaded: fbdev,vesa
alternate: nvidia tty: N/A
OpenGL: renderer: NVA8 v: 3.3 Mesa 19.2.8 direct render: Yes
sailor757
 
Posts: 6
Joined: 2019-08-01 19:20

Re: KDEnlive playback flickers after Debian 10 upgrade

Postby stevepusser » 2020-03-05 23:21

Hmmm--so on Ubuntu, it's still at .107, yet has the same issue? Is it only on kdenlive that you see the flicker or tearing?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.6, Strawberry 0.6.11, Muse 3.1.0, Chromium with va-api, Audacity 2.4.1, Kdenlive 20.04
User avatar
stevepusser
 
Posts: 11692
Joined: 2009-10-06 05:53

Re: KDEnlive playback flickers after Debian 10 upgrade

Postby sailor757 » 2020-03-06 17:08

Yes, this flickering problem is only with KDEnlive. Reverting back to the last version 18 of KDEnlive removes the flickering.

stevepusser wrote:Hmmm--so on Ubuntu, it's still at .107, yet has the same issue? Is it only on kdenlive that you see the flicker or tearing?
sailor757
 
Posts: 6
Joined: 2019-08-01 19:20


Return to Installation

Who is online

Users browsing this forum: sodcore and 5 guests

fashionable