Having Problems Installing Debian 10.3.0

Help with issues regarding installation of Debian

Having Problems Installing Debian 10.3.0

Postby CoolDude2 » 2020-03-28 00:04

Hello,
I'm having difficulty installing Debian using the Debian live amd64 versions on both a DVD and USB stick and I believe its a hardware issue.

My current setup is. . .

ASUS M5A99FX PRO R2.0 AM3+ AMD 990FX + SB950 SATA 6Gb/s USB 3.0 ATX AMD Motherboard with UEFI BIOS Version 2501
AMD FX-8350 Black Edition Vishera 8-Core 4.0 GHz (4.2 GHz Turbo) Socket AM3+ 125W FD8350FRHKBOX Desktop Processor
Creative 70SB174000000 Sound BlasterX AE-5 Hi-Resolution PCIe Gaming Sound Card
EVGA GeForce GTX 1060 SC GAMING, ACX 2.0 (Single Fan), 06G-P4-6163-KR, 6GB GDDR5, DX12 OSD Support (PXOC)
G.SKILL Sniper Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900) Desktop Memory Model F3-14900CL9D-8GBSR
EVGA 700 W Bronze Power Supply
Samsung EVO 850 250(GB) with Windows 10 Pro Installed
Samsung EVO 850 500(GB) where I would like to install Debian Buster KDE
Plugged in via ethernet cable to the router for Modem Access.

I followed all the directions for download and creating bootable iso's using the live version on my DVD. It booted and when I initiated the graphical installer I got the error message about nouveau driver not found or such(I don't remember exactly what it said. But, anyway I did some research and found thats a very common issue so what I did was add "nomodeset" after "no splash". I intiated the install and this time it got to the Debian loading symbol before freezing relatively quickly the first time and the second time after about 6 or so rotations.

Now the reason I believe this is a hardware issue is because before trying the live version I tried installing from a bootable dvd iso image. Through MANY different attempts there was always a framebuffer issue so I used the fb=false parameter which fixed it, however, after a while the prompt would tell me the AHCI storage controller wasn't found. Under bios, I verified that all the drives were using it. So I added another parameter AHCI=off. After initiallizing the install again it came up with clocksource errors. So under bios I disabled all of the cpu core speed controls in order to just have a cpu running at a constant speed with no adjustments made via hardware. After doing that, I no longer recieved the clocksource errors and was able to begin installation of Debian through the installer. I tried about 4 or 5 times, freezing at different intervals throughout the installer seemingly random, like while detecting network hardware or partitioning an ssd.

I've messed with it a little more and got some different results. This may be of help.

Here is my bios setup.

https://ibb.co/WW48QmP
https://ibb.co/YDwGgkS
https://ibb.co/xXSp1dk
https://ibb.co/9NQRRK9
https://ibb.co/6HHzxKd
https://ibb.co/kSfZ6W7
https://ibb.co/Dgnr82p
https://ibb.co/mz4XfQx
https://ibb.co/GWxDsYk
https://ibb.co/TvJtMZj

This setup when booted from the dvd live kde iso it does directly to grub instead of the installer menu. From online tutorials I assumed it should've loaded into the installer menu. If anybody has anything to add it would be much appreciated.
Last edited by CoolDude2 on 2020-03-28 20:43, edited 3 times in total.
CoolDude2
 
Posts: 7
Joined: 2020-03-27 23:21

Re: Having Problems Installing Debian 10.3.0

Postby pylkko » 2020-03-28 20:38

can you share the instructions that you followed?

did I get this right? you manage to boot, but the installer freezes?
User avatar
pylkko
 
Posts: 1793
Joined: 2014-11-06 19:02

Re: Having Problems Installing Debian 10.3.0

Postby CoolDude2 » 2020-04-02 00:24

Hello Again, I never figured out what was wrong with it the first time. But I remade some disc images with a different computer, formatted both of my hard drives, then reinstalled. It works now.
CoolDude2
 
Posts: 7
Joined: 2020-03-27 23:21


Return to Installation

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable