[SOLVED]Issue with wifi during installation on debian 10

Help with issues regarding installation of Debian

[SOLVED]Issue with wifi during installation on debian 10

Postby gugus2000 » 2020-04-19 08:28

Hello,
I tried to install debian 10 on an Asus T100TA computer.
I first used a usb stick with the netinst iso, but I couldn't get my wireless card to be recognise during the installation.
So I used the DVD iso with non-free firmware. However, I got the same issue: no ethernet card recognised. I resumed the installation, and all others things worked well.
Now, debian 10 is installed in my computer, but I can't get my card to work.
I know that my card is an on-board SDIO device Broadcom 43241b1, and I saw some thing about my config here: https://wiki.debian.org/InstallingDebianOn/Asus/T100TA (even if I didn't understand all)
Some commands, like
Code: Select all
# cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcmfmac43241b4-sdio.txt

and
Code: Select all
# cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcm/brcmfmac43340-sdio.txt

didn't work:
Code: Select all
cp: can't create the standard file '/lib/firmware/brcm/brcmfmac43241b4-sdio.txt': No file or foolder of this type
(translated from
Code: Select all
cp: Impossible de créer le fichier standard '/lib/firmware/brcm/brcmfmac43241b4-sdio.txt': Aucun fichier ou dossier de ce type
). (I mounted the directory first)
I tried to do
Code: Select all
lspci
, and I didn't find the device.
Code: Select all
lspci | grep Ethernet
give an empty result.
I ran
Code: Select all
dmesg | grep -i wireless
(and
Code: Select all
dmesg | grep -i ETH
, which giving me some results like Asus Wireless Radio Control, and other things that I can't copy (I'm on another computer)).
I finally downloaded the fimware from here: http://cdimage.debian.org/cdimage/unofficial/non-free/firmware/buster/20200209/,
and ran
Code: Select all
dkpg -i /home/myusername/firmware_brcm80211_20190114_2_all.deb
, but this command gives an error:
Code: Select all
dkpg-deb --control subprocess returned error exit status 2

I have no more clues of what I'm missing...
If you have any idea of how I can get an internet connection with this computer, I will be very happy :D

Thanks

[UPDATE]
After redownloading the firmware file, the dkpg command works, but, even after a reboot, nothing change. Others commands still don't display my device...
I can do the dkpg command many times, but it seems that nothing change.
Last edited by gugus2000 on 2020-04-20 11:36, edited 2 times in total.
gugus2000
 
Posts: 3
Joined: 2020-04-19 06:04

Re: Issue with wifi during installation on debian 10

Postby Head_on_a_Stick » 2020-04-19 10:26

You might also need the firmware stored in your motherboard's NVRAM.
gugus2000 wrote:Some commands, like
Code: Select all
# cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcmfmac43241b4-sdio.txt

and
Code: Select all
# cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcm/brcmfmac43340-sdio.txt

didn't work:
Code: Select all
cp: can't create the standard file '/lib/firmware/brcm/brcmfmac43241b4-sdio.txt': No file or foolder of this type

Try
Code: Select all
# mkdir -p /lib/firmware/brcm/brcm/

Then run the cp commands again.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Issue with wifi during installation on debian 10

Postby gugus2000 » 2020-04-19 11:19

Thank you a lot for your answer !
Now,
Code: Select all
# cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcm/brcmfmac43340-sdio.txt
doesn't return any error.
However, even if I redo the dpkg command and reboot, the other commands still not display my card, and I cannot use wifi :/
Am I missing something?
When I ran
Code: Select all
modprobe -r brcmfmac && modprobe brcmfmac
, I have this error:
Code: Select all
firmware: failed to load brmc/brmcfmac43241b4-sdio.txt (-2)
brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50

I found this: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=797779. But I don't understand what I have to do :?

[UPDATE]
I tried to do
Code: Select all
# cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcmfmac43340-sdio.txt
, but the modprobe command give the same error
gugus2000
 
Posts: 3
Joined: 2020-04-19 06:04

Re: Issue with wifi during installation on debian 10 [SOLVED

Postby gugus2000 » 2020-04-20 11:27

I fixed the issue \o/
I'm dumb:
Code: Select all
# cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcm/brcmfmac43241b4-sdio.txt

solved the issue (I didn't see it was brcmfmac43241b4 and not what I write earlier)

I hope it will help other people ^^
gugus2000
 
Posts: 3
Joined: 2020-04-19 06:04


Return to Installation

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable