kept-back packages [solved]

Help with issues regarding installation of Debian

kept-back packages [solved]

Postby runs » 2020-04-24 17:05

I have upgraded from 9.0 to 10.


All OK, but these kept-back packages: build-essential g++ gobjc libatlas3-base libblas3 liblapack3


The problem is that other package depends on them and cannot install it.

I already did:

sudo apt-get autoclean
apt-get update
apt-get dist-upgrade
apt-get autoremove
etc, etc. several times but no luck

any idea?
Last edited by runs on 2020-04-24 18:12, edited 2 times in total.
runs
 
Posts: 16
Joined: 2018-04-24 21:29

Re: kept-back packages

Postby milomak » 2020-04-24 17:18

it would probably be better if you posted what the output is when you encounter the problem
Desktop: iMac Late-2015 27" 5K Retina (17,1 - 3.3GHz) - MacOS and Windows 10 (Bootcamp)/ Sid (External SSD)
Laptop: Lenovo ideapad Y700-15ISK [nVidia Optimus] (64-bit) - Sid, Win10, Solus
Kodi Box: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 2039
Joined: 2009-06-09 22:20

Re: kept-back packages

Postby Ardouos » 2020-04-24 17:27

User avatar
Ardouos
 
Posts: 1061
Joined: 2013-11-03 00:30
Location: Elicoor II

Re: kept-back packages

Postby runs » 2020-04-24 18:01

I have gcc in a superior version :-(

Maybe I did something bad :-(
runs
 
Posts: 16
Joined: 2018-04-24 21:29

Re: kept-back packages

Postby milomak » 2020-04-24 18:07

runs wrote:I have gcc in a superior version :-(

Maybe I did something bad :-(

well again if you don't post the output of what is happening we are not psychics who can read tea leaves and give you a solution
Desktop: iMac Late-2015 27" 5K Retina (17,1 - 3.3GHz) - MacOS and Windows 10 (Bootcamp)/ Sid (External SSD)
Laptop: Lenovo ideapad Y700-15ISK [nVidia Optimus] (64-bit) - Sid, Win10, Solus
Kodi Box: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 2039
Joined: 2009-06-09 22:20

Re: kept-back packages

Postby runs » 2020-04-24 18:12

I have a 9.0 Frankedebian (Monster-Debian)

I've solved removing some packages carefully and reinstalling:

sudo dpkg -r --force-all xxx.deb

Now it works.

Thanx for your help. :-)
runs
 
Posts: 16
Joined: 2018-04-24 21:29


Return to Installation

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable