Pkgs I do not want to install

Help with issues regarding installation of Debian

Pkgs I do not want to install

Postby JeSuisFlaneur » 2020-05-10 18:09

I tried updating. The upgrade fails due to it trying to install LibreOffice. I use OpenOffice. How do I update, without LibreOffice. There is a kernel update being held back due to this. Why would the upgrade care so much as to not update the kernel, because of LibreOffice?

Installing OpenOffice is not easy in Debian/Ubuntu. I had to do a complex series of commands to force LibreOffice off this computer.

Also in Notifications is a Thunderbird update. I do want to install it.

Is it possible to remove the LibreOffice from the repository, so that I don't have any more offers of updates?
JeSuisFlaneur
 
Posts: 38
Joined: 2019-08-28 16:00

Re: Pkgs I do not want to install

Postby Head_on_a_Stick » 2020-05-10 18:39

JeSuisFlaneur wrote:The upgrade fails due to it trying to install LibreOffice

That a bit vague, can we see the full output of
Code: Select all
apt -s upgrade
apt policy


JeSuisFlaneur wrote:I had to do a complex series of commands to force LibreOffice off this computer.

Again, that's far too vague. We need to know *exactly* what you did.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12159
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Pkgs I do not want to install

Postby JeSuisFlaneur » 2020-05-10 19:15

When I try to understand how to respond to the vagueness problem, I must first apologize for not being adept at computers. If I knew enough to be more clear, I would not withhold a jot or tittle.

This morning, on powering up the computer, an on-screen notification appeared about updates. When I looked at the updates available, I saw the entire LibreOffice suite was ready for installation (which would technically be an upgrade from an earlier LO version).

About a year ago, I installed Debian 10 on a bare SSD drive. The Buster installer added, LibreOffice. After some time, I found an article on uninstalling LO and installing Apache OpenOffice. I followed all those instructions. I have a working OpenOffice on this system. There is a directory, that LO and OO fight over, called soffice. I don't know what is in it, that is, I don't know why there is one directory with the same name from both software packagers. LibreOffice cannot be easily removed. If needs be I'll find the posts I followed, but it's over a year ago.

As for the output you request:

Code: Select all
mark@Lexington:/$ apt -s upgrade
NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libreoffice-help-ca : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-common : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-cs : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-da : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-de : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-dz : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-el : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-en-gb : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-en-us : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-es : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-et : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-eu : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-fi : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-fr : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-gl : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-hi : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-hu : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-it : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-ja : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-km : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-ko : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-nl : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-pl : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-pt : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-ru : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-sk : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-sl : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-sv : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-zh-cn : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-help-zh-tw : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-ar : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
                       Recommends: fonts-hosny-amiri but it is not installed
                       Recommends: fonts-hosny-thabit but it is not installed
                       Recommends: fonts-kacst but it is not installed
                       Recommends: fonts-sil-scheherazade but it is not installed
 libreoffice-l10n-ast : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-be : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-bg : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-bn : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
                       Recommends: fonts-beng but it is not installed
 libreoffice-l10n-bs : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-ca : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-cs : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-cy : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-da : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-de : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-dz : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
                       Recommends: fonts-dzongkha but it is not installed
 libreoffice-l10n-el : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-en-gb : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-en-za : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-eo : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-es : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-et : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-eu : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-fa : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
                       Recommends: fonts-farsiweb but it is not installed
 libreoffice-l10n-fi : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-fr : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-ga : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-gl : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-gu : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
                       Recommends: fonts-gujr but it is not installed
 libreoffice-l10n-he : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-hi : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-hr : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-hu : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-id : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-is : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-it : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-ja : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-ka : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-km : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
                       Recommends: fonts-khmeros but it is not installed
 libreoffice-l10n-ko : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-lt : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-lv : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-mk : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-ml : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
                       Recommends: fonts-mlym but it is not installed
 libreoffice-l10n-mr : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
                       Recommends: fonts-deva but it is not installed
 libreoffice-l10n-nb : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-ne : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
                       Recommends: fonts-deva but it is not installed
 libreoffice-l10n-nl : Depends: libreoffice-common (= 1:6.1.5-3+deb10u6) but 1:6.1.5-3+deb10u5 is installed
 libreoffice-l10n-nn : Depends: libreoffice-common (= mark@Lexington:/$ apt -s upgrade

mark@Lexington:/$ apt policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 https://packages.microsoft.com/repos/ms-teams stable/main amd64 Packages
     release o=ms-teams stable,a=stable,n=stable,l=ms-teams stable,c=main,b=amd64
     origin packages.microsoft.com
 500 https://deb.opera.com/opera-stable stable/non-free amd64 Packages
     release o=Opera Software AS,a=stable,n=stable,l=The Opera web browser,c=non-free,b=amd64
     origin deb.opera.com
 500 http://ftp.us.debian.org/debian buster/contrib amd64 Packages
     release v=10.4,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=amd64
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian buster/main amd64 Packages
     release v=10.4,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
     origin ftp.us.debian.org
 500 http://security.debian.org/debian-security buster/updates/non-free amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://deb.debian.org/debian buster-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian buster/main amd64 Packages
     release v=10.4,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian buster/non-free amd64 Packages
     release v=10.4,o=Debian,a=stable,n=buster,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
Pinned packages:
mark@Lexington:/$ 
JeSuisFlaneur
 
Posts: 38
Joined: 2019-08-28 16:00

Re: Pkgs I do not want to install

Postby cuckooflew » 2020-05-10 19:15

Is it possible to remove the LibreOffice from the repository, so that I don't have any more offers of updates?

No we will not remove it from the repositories, there are many others that do want it.
How do I update, without LibreOffice

What you can do is remove the package from your system, there is documentation on how to do this,: https://www.debian.org/doc/manuals/debian-faq/pkgtools.en.html
8.1.2. APT
To remove the foo package from your system, run: -----snip---To remove the foo package and its configuration files from your system, run: ---snip---and so on,

Read it, I can not do that for you. I used the same instructions my self, in fact it was to remove libre office as well, pretty simple if you know how to follow instructions,...
Also:
https://wiki.debian.org/DebianPackageManagement
So, that is all there is to it, just remove the libre office package from you system, before trying to update or upgrade.
and there is even more information, but you did not bother to even try to find any of it , did you ?
Please Read.. What we expect you have already Done.
Please Read.. What we expect you have already Done.
Does any one know about this ?
Users browsing this forum: Google Knows, and
My grand father knows all about everything:
…one flew east, one flew west,
One flew over the cuckoo’s nest.
cuckooflew
 
Posts: 403
Joined: 2018-05-10 19:34
Location: Some where out west

Re: Pkgs I do not want to install

Postby cuckooflew » 2020-05-10 22:00

Additional note, after you have run 'apt remove libreoffice' and 'apt purge libreoffice' There may still be some debri left over, you can follow this guide:
https://dwaves.org/2016/10/06/linux-debian-uninstall-libreoffice/
It tells you about a easy way to find and remove any leftover traces.
# keep copy pasting that into your console until it keeps saying:

E: Unable to locate package
Please Read.. What we expect you have already Done.
Does any one know about this ?
Users browsing this forum: Google Knows, and
My grand father knows all about everything:
…one flew east, one flew west,
One flew over the cuckoo’s nest.
cuckooflew
 
Posts: 403
Joined: 2018-05-10 19:34
Location: Some where out west

Re: Pkgs I do not want to install

Postby arid » 2020-05-11 02:53

It tells you about a easy way to find and remove any leftover traces.

That is beyond absurd!

Or you can install deborphan(orphaner) and list and remove any and all leftovers.

I also use synaptic for any and all package management.

Oh, the horror of it all!

Puzzling to me how in all these years, I've never had any non-functioning systems.

I have also removed libreoffice on dozens of installs without a problem.

Of course if you want to live in the stone-age with that ancient stable stuff...
There's no drama in my sid......
arid
 
Posts: 85
Joined: 2014-05-08 18:40
Location: Aridzona

Re: Pkgs I do not want to install

Postby cuckooflew » 2020-05-11 03:26

In any event, the main point is, there are various ways to install and remove the packages
I also use synaptic for any and all package management.
,
https://packages.debian.org/buster/synaptic
That's nice, I never have used it myself, maybe should try it some time, I did not know it is suitable for doing upgrades though, is it really ? I see the info says it can be used for package upgrades, but what about full upgrades, or dist - upgrade, like from Debian 9 to Debian 10 ?
Or you can install deborphan

Can't say I had heard of it,..but here it is (for the OP and anyone else):
https://packages.debian.org/buster/deborphan
Package: deborphan (1.7.31)
program that can find unused packages, e.g. libraries

deborphan finds "orphaned" packages on your system. It determines which packages have no other packages depending on their installation and shows you a list of these packages. It is most useful when finding libraries, but it can be used on packages in all sections.

This package also includes orphaner, a text menu frontend to deborphan. Please install the recommended packages dialog, gettext-base and apt when you want a working and fully featured orphaner.

Sounds good, another one I will try some time,.
Thanks for sharing.
Please Read.. What we expect you have already Done.
Does any one know about this ?
Users browsing this forum: Google Knows, and
My grand father knows all about everything:
…one flew east, one flew west,
One flew over the cuckoo’s nest.
cuckooflew
 
Posts: 403
Joined: 2018-05-10 19:34
Location: Some where out west

Re: Pkgs I do not want to install

Postby Head_on_a_Stick » 2020-05-11 15:23

JeSuisFlaneur wrote:I must first apologize for not being adept at computers. If I knew enough to be more clear, I would not withhold a jot or tittle.

Don't be silly, no need to apologise, it's fine.

JeSuisFlaneur wrote:LibreOffice cannot be easily removed.

Why not? What happens when you try?

JeSuisFlaneur wrote:
Code: Select all
You might want to run 'apt --fix-broken install' to correct these.

^ Have you tried that?

It looks like you still have the LO help & localisation ("l10n") packages installed, can you remove them?
Code: Select all
apt purge --simulate --autoremove 'libreoffice*'
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12159
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Pkgs I do not want to install

Postby JeSuisFlaneur » 2020-05-11 20:05

The next day . . .

On screen notification wanted to install updates. No LibreOffice, this time it was the OS and Thunderbird.

I OK'd the update. On reboot, the OS fails. Cannot run OS or the rescue. Both run to a blank screen and halt.

I'm reinstalling the OS. That's another post from here.

Thank you Debian/Linux Community.
JeSuisFlaneur
 
Posts: 38
Joined: 2019-08-28 16:00


Return to Installation

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable