Dell 7391 2n1 Graphics not working

Help with issues regarding installation of Debian

Dell 7391 2n1 Graphics not working

Postby themagicm » 2020-06-10 01:26

I've installed Debian 10.4 and cannot get X server to start. I'm sitting at a black screen with a blinking cursor.

lspci shows:

Intel Corporation Device 9b41 (rev 02). I've installed various firmwares, drivers etc..still no go.

X org log says:

Cannot run in framebuffer mode. Please specify BusIDs for all framebuffer devices.

Any clues on what driver to install to get graphics working?
themagicm
 
Posts: 42
Joined: 2011-11-23 06:08

Re: Dell 7391 2n1 Graphics not working

Postby themagicm » 2020-06-10 02:10

lol.. nevermind. Installed the 5.4 kernel and all is well.
themagicm
 
Posts: 42
Joined: 2011-11-23 06:08

Re: Dell 7391 2n1 Graphics not working

Postby stevepusser » 2020-06-10 03:23

Really really new hardware and an aging version of Debian stable are a poor match. You may need to use backports or even firmware packages that aren't in any version of Debian yet.

This will be the answer to many many many questions that will appear here in the future, just as it's been the answer to many recent questions.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.7, Strawberry 0.6.12, Pale Moon 28.10.0, Xscreensaver 5.44, Krita 4.3.0, Foliate 2.4.0
User avatar
stevepusser
 
Posts: 11792
Joined: 2009-10-06 05:53

Re: Dell 7391 2n1 Graphics not working

Postby themagicm » 2020-06-10 13:35

stevepusser wrote:Really really new hardware and an aging version of Debian stable are a poor match. You may need to use backports or even firmware packages that aren't in any version of Debian yet.

This will be the answer to many many many questions that will appear here in the future, just as it's been the answer to many recent questions.


Yea..

The second part was to download linux-firmware and copy it over to /lib/firmware. That fixed my NIC/wifi card issue. Other than that, smooth sailing so far.
themagicm
 
Posts: 42
Joined: 2011-11-23 06:08

Re: Dell 7391 2n1 Graphics not working

Postby stevepusser » 2020-06-11 02:57

Even the newest firmware packages in Debian Sid haven't been updated since last July. :(

This led me to reluctantly port over the much newer and inclusive "linux-firmware" from Ubuntu to MX Linux in order to support newer hardware out of the box, despite the fact that it mixes all the free and non-free files in one huge glob. Installing it from here has also recently been the solution to many questions about newer firmware.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.7, Strawberry 0.6.12, Pale Moon 28.10.0, Xscreensaver 5.44, Krita 4.3.0, Foliate 2.4.0
User avatar
stevepusser
 
Posts: 11792
Joined: 2009-10-06 05:53


Return to Installation

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable