No Video or Network with Buster on HP Pavilion [Solved]

Help with issues regarding installation of Debian

No Video or Network with Buster on HP Pavilion [Solved]

Postby KitchM » 2020-11-05 21:00

Have HP Pavilion G6 with Windows 8.1. Used DVD disk 1, and then network install and then firmware network install.

No matter what I do, there is no Ethernet network or proper video. None of the proper firmware is found or installed or asked for. :roll:

And for the cherry on the top, the computer does not boot to grub. :lol:

Anyone have any experience with this issue before?
Last edited by KitchM on 2020-11-06 17:57, edited 1 time in total.
KitchM
 
Posts: 109
Joined: 2019-06-11 18:11

Re: No Video or Network with Buster on HP Pavilion

Postby arochester » 2020-11-05 22:07

No video
What is the output of: lspci | egrep "3D|Display|VGA"

No Network
What is the output of: lspci | grep Network

What do you mean: Have HP Pavilion G6 with Windows 8.1. Used DVD disk 1, and then network install and then firmware network install.
Dual booting with Windows?
Single booting Debian?
You used DVD#1 AND did Network install AND did "firmware network install"
What firmware did you install?
But you have no ethernet?
arochester
 
Posts: 1770
Joined: 2010-12-07 19:55

Re: No Video or Network with Buster on HP Pavilion

Postby stevepusser » 2020-11-05 22:11

If you try a network install without a network connection, there will naturally be missing components of the OS.

Could you tell us about when this machine was manufactured? Buster often has trouble with machines mid-2019 or newer.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12131
Joined: 2009-10-06 05:53

Re: No Video or Network with Buster on HP Pavilion

Postby KitchM » 2020-11-06 15:52

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7640G]

02:00.0 Network controller: Qualcom Atheros AR9485 Wireless Network Adapter (rev 01)

There is also:
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 05)

I apologize for being unclear. Yes, of course it is to be a dual-boot.

I tried over and over again using three different installation iso setups. The applicable partitions were deleted and recreated each time. All seemed to install, but none came up with a desktop.

None asked for firmware, and it is reasonable to assume that the net install with included non-free firmware would have taken care of that automatically.

The router sees the laptop, so there must be connection. It is just that no matter which install is used, it is never configured with network setup on the laptop.

The manufacture date appears to be 2011.
KitchM
 
Posts: 109
Joined: 2019-06-11 18:11

Re: No Video or Network with Buster on HP Pavilion

Postby KitchM » 2020-11-06 16:10

Well this is bizarre. I was finally able to get to a command prompt and log in. I then did apt update and it worked perfectly. :shock:

I tried startx and it states there is a problem with modesetting isn't supported. I must assume that means the non-free firmware is not installed, even though non-free is in the sources.list.

Maybe I can figure a way to complete the install. Any tips?
KitchM
 
Posts: 109
Joined: 2019-06-11 18:11

Re: No Video or Network with Buster on HP Pavilion

Postby arochester » 2020-11-06 17:41

What does your sources list say?

If you do (as Root) apt update && apt full-upgrade what error message do you get?
arochester
 
Posts: 1770
Joined: 2010-12-07 19:55

Re: No Video or Network with Buster on HP Pavilion

Postby KitchM » 2020-11-06 17:56

"0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded"

I was able to do the following:
    Downloaded appropriate Radeon firmware from wiki.debian.org/Firmware. (One file had them all.)
    Put deb file on USB drive.
    Put USB drive in laptop.
    Ran cd /mnt
    Ran mkdir usbdrive
    Ran lsblk -p | grep “disk”
    Saw drive as sdb
    Ran mount /dev/sdb1 /mnt/usbdrive
    Ran cd /usbdrive
    Ran ls
    Ran apt install ./(name of firmware deb file)
    Ran shutdown -r now
    Booted into Debian and waited to desktop.

I now have good video and a normal desktop.

Thanks all.
KitchM
 
Posts: 109
Joined: 2019-06-11 18:11

Re: No Video or Network with Buster on HP Pavilion [Solved]

Postby arochester » 2020-11-06 18:58

For the record, which firmware did you install?
arochester
 
Posts: 1770
Joined: 2010-12-07 19:55

Re: No Video or Network with Buster on HP Pavilion [Solved]

Postby stevepusser » 2020-11-06 23:03

It has to be firmware-amd-graphics, which 99.9999999% of AMD GPUs need to work correctly.

Your wi-fi seems to be one of the few cards that doesn't need outside firmware (ath9k driver).
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12131
Joined: 2009-10-06 05:53

Re: No Video or Network with Buster on HP Pavilion [Solved]

Postby Head_on_a_Stick » 2020-11-07 16:16

Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12756
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: No Video or Network with Buster on HP Pavilion [Solved]

Postby KitchM » 2020-11-25 19:53

Sorry, but I would have posted sooner if the notifications in the forum were working.

I installed:
amd64-microcode_3.20181128.1_amd64.deb
firmware-linux-nonfree_20190114-2_all.deb
firmware-misc-nonfree_20190114-2_all.deb
firmware-amd-graphics_20190114-2_all.deb

Thank you everyone.
KitchM
 
Posts: 109
Joined: 2019-06-11 18:11


Return to Installation

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable