Buster not detecting external boot USB after installation

Help with issues regarding installation of Debian

Buster not detecting external boot USB after installation

Postby Danathar » 2021-01-10 13:02

Thanks ahead of time for anybody who can assist with this!

I have a Dell Optiplex 3020 small form factor. I attempted to install Debian Buster to an external USB and almost succeeded, but after the installer finished successfully (to an external Samsung T3) and rebooted the USB drive is not detected.

The BIOS is set to legacy and not UEFI. During the installation I actually disconnected the internal Windows SSD drive (which is also an MBR installation and not GPT because I'm paranoid...).

I'm scratching my head on this. If the BIOS is set to legacy mode and the external USB T3 installation is an old style MBR install why is it not being detected but the Buster install media on the USB was? Not sure where to go next with this. Is there something special in the Debian installer that I need to do to make the USB installed drive bootable like the installer USB was?

thanks!
Danathar
 
Posts: 6
Joined: 2021-01-10 12:44

Re: Buster not detecting external boot USB after installatio

Postby Head_on_a_Stick » 2021-01-10 13:28

The firmware ("BIOS") for some machines may require the "boot" flag to be applied to the relevant partition.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13062
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Buster not detecting external boot USB after installatio

Postby p.H » 2021-01-10 14:51

There is no relevant partition. The only relevant thing for BIOS boot should be the MBR boot code. Any partition will do. Even swap.
My Dell Optiplex has this bug.
p.H
 
Posts: 1620
Joined: 2017-09-17 07:12

Re: Buster not detecting external boot USB after installatio

Postby Danathar » 2021-01-10 16:31

p.H wrote:There is no relevant partition. The only relevant thing for BIOS boot should be the MBR boot code. Any partition will do. Even swap.
My Dell Optiplex has this bug.


Is there a workaround? What did you do (or not) with your Optiplex?
Danathar
 
Posts: 6
Joined: 2021-01-10 12:44

Re: Buster not detecting external boot USB after installatio

Postby Danathar » 2021-01-10 16:34

Head_on_a_Stick wrote:The firmware ("BIOS") for some machines may require the "boot" flag to be applied to the relevant partition.


Hmm. I guess I could compare the partitions on the USB install media and the destination installed USB drive to see if there is a boot flag difference. Which utility could tell me that?
Danathar
 
Posts: 6
Joined: 2021-01-10 12:44

Re: Buster not detecting external boot USB after installatio

Postby p.H » 2021-01-10 16:58

Danathar wrote:Is there a workaround? What did you do (or not) with your Optiplex?

The workaround was what Head_on_a_Stick suggested : set the boot flag on any partition in the MBR with fdisk or the like.
p.H
 
Posts: 1620
Joined: 2017-09-17 07:12

Re: Buster not detecting external boot USB after installatio

Postby Danathar » 2021-01-10 17:04

p.H wrote:
Danathar wrote:Is there a workaround? What did you do (or not) with your Optiplex?

The workaround was what Head_on_a_Stick suggested : set the boot flag on any partition in the MBR with fdisk or the like.


Ok. I'll proceed with that. Assuming this is the problem, is this a bug? Or is there some reason why the boot flag was not (and is not) being set on the installed partition?
Danathar
 
Posts: 6
Joined: 2021-01-10 12:44

Re: Buster not detecting external boot USB after installatio

Postby p.H » 2021-01-10 17:11

This is a BIOS bug. The BIOS should not care about partitions, including the boot flag. Only the boot code in the MBR may care (standard DOS-like boot code does, GRUB does not).
p.H
 
Posts: 1620
Joined: 2017-09-17 07:12

Re: Buster not detecting external boot USB after installatio

Postby Bulkley » 2021-01-10 19:15

Danathar, let me propose an alternative. Since you are working with a USB install I suggest you try Antix.
Back in 2009, the antiX devs foresaw that usb flash drives would be the wave of the future for live Linux media. During the ensuing eight years antiX has been refining their live-usb technology striving to improve the live-usb experience and to find new and unique ways for making use of fast read-write live boot media.
Antix Linux

I'm not trying to chase you away. It's just that Antix has spent so much effort into USB installs that they probably have a solution for you. Make sure to follow their instructions.
Bulkley
 
Posts: 6031
Joined: 2006-02-11 18:35

Re: Buster not detecting external boot USB after installatio

Postby Danathar » 2021-01-11 13:18

Bulkley wrote:Danathar, let me propose an alternative. Since you are working with a USB install I suggest you try Antix.
Back in 2009, the antiX devs foresaw that usb flash drives would be the wave of the future for live Linux media. During the ensuing eight years antiX has been refining their live-usb technology striving to improve the live-usb experience and to find new and unique ways for making use of fast read-write live boot media.
Antix Linux

I'm not trying to chase you away. It's just that Antix has spent so much effort into USB installs that they probably have a solution for you. Make sure to follow their instructions.


Yea, I'm familiar with MX and Antix. I've got them both installed on other systems. This system that I'm installing is meant to be a system that will be supported for a while with just security fixes. I was going to go with Ubuntu LTS but for some reason I had the urge to go vanilla Debian and see how far I could get on Buster.

Some updates: Using LVM during the install works. It's just doing a vanilla non-LVM install that is broke. Also, rather strange...The mouse movement on the GDM login manager seems to be in conflict or being disrupted by something. As I move the mouse around it hangs for a moment then releases...then hangs and releases. I don't get that behavior during the graphical install process, and I don't get it once I log in. Odd. I also don't get that with Ubuntu or MX Linux as well. Could this be a bug in the version of GDM that Buster ships with? I've not tried LightDM.
Danathar
 
Posts: 6
Joined: 2021-01-10 12:44

Re: Buster not detecting external boot USB after installatio

Postby p.H » 2021-01-11 18:30

Danathar wrote:Using LVM during the install works. It's just doing a vanilla non-LVM install that is broke

If you used guided partitioning, one difference is that with LVM the installer creates a small /boot partition at the beginning of the drive.
Did you check with fdisk whether this partition has the boot flag set ? If yes, did you test what happens if you clear the boot flag (get a rescue media ready) ?
p.H
 
Posts: 1620
Joined: 2017-09-17 07:12

Re: Buster not detecting external boot USB after installatio

Postby Danathar » 2021-01-11 19:24

p.H wrote:
Danathar wrote:Using LVM during the install works. It's just doing a vanilla non-LVM install that is broke

If you used guided partitioning, one difference is that with LVM the installer creates a small /boot partition at the beginning of the drive.
Did you check with fdisk whether this partition has the boot flag set ? If yes, did you test what happens if you clear the boot flag (get a rescue media ready) ?


No, but I'll give it a try and report back.
Danathar
 
Posts: 6
Joined: 2021-01-10 12:44


Return to Installation

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable