Installation successfully but reboot in black screen

Help with issues regarding installation of Debian

Installation successfully but reboot in black screen

Postby ehehe » 2021-02-02 13:44

Not first time install debian in this compute, but this time encounter problems after installation. A few
months ago I successfully installed Debian 10.2

System: Debian 10.7
CPU: Intel i7-9700kf
GPU: Nvidia RTX2070s
Whole SSD

After installation and reboot, the power on message first line show something like "nouveau unknown pcie...",
and program stop at black screen, only a cursor at top-left.

It can use alt+ctrl+f2~f6 to enter terminal, I did two things but no effect:
    #1
    Add
    Code: Select all
    blacklist nouveau
    options nouveau modeset=0
    to `/etc/modprobe.d/blacklist.conf`


Reboot, and power on message show
Code: Select all
[FAILED] failed to start Load Kernel Modules.
See 'systemctl status systemd-modules-load.service' for details.

Enter tty2 and the details are:
Code: Select all
systemd-modules-load.service - Load Kernek Modules
Loaded: loaded (/lib/systemd/system/systemd-modules-lad.service; static; vendor preset: enabled)
Active: failed (Result: exit-caode) Since Tue 2021-02-02 21:46:09 EST; 12h left
Docs: man:systemd-modules-lad.service(8)
      man:modules-load.d(5)
Process: 535 ExecStart=/lib/systemd/systemd-modules-load(code=exited, status=1/FAILURE)
Main PID: 535 (code=exited, status=1/FAILURE)

I have searched in Internet and tried several methods, all failed. :(
ehehe
 
Posts: 4
Joined: 2018-12-01 02:08

Re: Installation successfully but reboot in black screen

Postby Head_on_a_Stick » 2021-02-02 14:51

Are the kernel headers installed? Did the NVIDIA kernel module build successfully?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13262
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: to Head_on_a_Stick

Postby ehehe » 2021-02-03 01:48

Head_on_a_Stick wrote:Are the kernel headers installed? Did the NVIDIA kernel module build successfully?

How to do?
To install kernel headers, I found a cmd in Cuda Doc https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#verify-kernel-packages
Code: Select all
sudo apt-get install linux-headers-$(uname -r)
is it right?

And how to build nvidia kernel moudle?

Thx!
ehehe
 
Posts: 4
Joined: 2018-12-01 02:08

Re: Installation successfully but reboot in black screen

Postby sunrat » 2021-02-03 02:13

ehehe wrote:It can use alt+ctrl+f2~f6 to enter terminal, I did two things but no effect:
    #1
    Add
    Code: Select all
    blacklist nouveau
    options nouveau modeset=0
    to `/etc/modprobe.d/blacklist.conf`

You don't need to do this, installation of nvidia-driver package does it automatically.


This wiki guide explains how to do everything you are asking, basically:
- install headers
- install nvidia-driver and firmware-misc-nonfree
- reboot

There's one thing that may be missing from the wiki; a module building setup may be required and I can't remember if it is present in a default install. You can do this instead of installing the headers as they are pulled in by this:
Code: Select all
apt install module-assistant
m-a prepare


As H_o_a_S said, watch the messages carefully when you run these commands. If module build fails, it will say so.
And H_o_a_S is not the only person here who can offer assistance btw.

Also I'm not 100% sure GTX2070 is fully supported in Buster. You may need some other packages or you may have more luck with Bullseye although that is still Testing and may have other niggles, although it's in freeze now and consequently less volatile than earlier in its development cycle.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3404
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Installation successfully but reboot in black screen

Postby Head_on_a_Stick » 2021-02-03 14:26

sunrat wrote:
ehehe wrote:It can use alt+ctrl+f2~f6 to enter terminal, I did two things but no effect:
    #1
    Add
    Code: Select all
    blacklist nouveau
    options nouveau modeset=0
    to `/etc/modprobe.d/blacklist.conf`

You don't need to do this, installation of nvidia-driver package does it automatically.

Actually I don't think the nouveau module needs to be blocked any more, X should handle the NVIDIA blob automagically. It might be useful if you could check this on your machine and let us know.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13262
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Installation successfully but reboot in black screen

Postby sunrat » 2021-02-03 20:57

Head_on_a_Stick wrote:
sunrat wrote:
ehehe wrote:It can use alt+ctrl+f2~f6 to enter terminal, I did two things but no effect:
    #1
    Add
    Code: Select all
    blacklist nouveau
    options nouveau modeset=0
    to `/etc/modprobe.d/blacklist.conf`

You don't need to do this, installation of nvidia-driver package does it automatically.

Actually I don't think the nouveau module needs to be blocked any more, X should handle the NVIDIA blob automagically. It might be useful if you could check this on your machine and let us know.


Code: Select all
$ locate blacklist |grep nvidia
/etc/alternatives/glx--nvidia-blacklists-nouveau.conf
/etc/alternatives/nvidia--nvidia-blacklists-nouveau.conf
/etc/modprobe.d/nvidia-blacklists-nouveau.conf
/etc/nvidia/nvidia-blacklists-nouveau.conf
/etc/nvidia/current/nvidia-blacklists-nouveau.conf
/usr/share/initramfs-tools/hooks/zz_nvidia-blacklists-nouveau


The first five have the same content. Last one is a script which presumably runs if initramfs is updated. I did not create these manually.
Code: Select all
$ cat /etc/modprobe.d/nvidia-blacklists-nouveau.conf
# You need to run "update-initramfs -u" after editing this file.

# see #580894
blacklist nouveau
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3404
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Installation successfully but reboot in black screen

Postby ehehe » 2021-02-05 11:31

Thanks two friends!

For some reasons, I could not use computer for several days. Today I follow your suggestions, successfully entered the graphics desktop. Thanks again!

My mistake, skipped the Prerequisites step in that wiki, but when I run the command, return linux-headers-amd64 is already the newest version (5.9.15-1~bpo10+1). Maybe the kernel headers were installed when I installed driver.

After run two commands to build nvidia kernel module, I entered the desktop. One file named nvidia-blacklists-nouveau.conf is in /etc/modprobe.d/ with the same things as sunrat posted, so I remove the blacklist.conf which I created my own.

I also have a question: When this time after installation, system can not enter desktop, before, Debian 10.2 or Debian 9, although the screen resolution is bad ( I think because nouveau not support rtx2070s), at least can enter desktop, why this time can not, is it about Debian 10.7 or I did something wrong with the installation?
ehehe
 
Posts: 4
Joined: 2018-12-01 02:08


Return to Installation

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable