[SOLVED] LXDE session only lasts 10 seconds

Help with issues regarding installation of Debian

[SOLVED] LXDE session only lasts 10 seconds

Postby rephlex » 2010-04-18 17:06

Hi, I have just upgraded to the latest testing packages with aptitude and now when I log in I get 2 error messages.
One is "Your session only lasted less than 10 seconds. If you have not logged out yourself, this could mean that there is some installation problem or that you may be out of diskspace. Try logging in with one of the failsafe sessions to see if you can fix this problem." and then if I click on view details I get "/etc/gdm/Xsession: Beginning session setup..."
As long if I don't click OK the system (LXDE) is completely usable and the only thing that doesn't seem to be working properly is wifi - I think I was using network manager which doesn't seem to be loading.
The other error message is:
"GTK+ icon theme is not properly set
This usually means you don't have an XSETTINGS manager running. Desktop environment like GNOME or XFCE automatically execute their XSETTING managers like gnome-settings-daemon or xfce-mcs-manager.

If you don't use these desktop environments, you have two choices:
1. run an XSETTINGS manager, or
2. simply specify an icon theme in ~/.gtkrc-2.0.
For example to use the Tango icon theme add a line:
gtk-icon-theme-name="Tango" in your ~/.gtkrc-2.0. (create it if no such file)

NOTICE: The icon theme you choose should be compatible with GNOME, or the file icons cannot be displayed correctly. Due to the differences in icon naming of GNOME and KDE, KDE themes cannot be used. Currently there is no standard for this, but it will be solved by freedesktop.org in the future."
clicking OK brings up icons etc. and desktop background.
Does anyone have any ideas? I am using an SSD and when I set up the laptop I think that I made /tmp a folder on a ram disk (and maybe a few other temporary files as well). Could this have anything to do with these error messages?
(one also pops up about battery empty when the battery is still @ 100% but that is less irritating)
Thanks, Nick
Last edited by rephlex on 2010-04-20 09:52, edited 1 time in total.
rephlex
 
Posts: 3
Joined: 2010-04-18 16:53

Re: LXDE session only lasts 10 seconds

Postby aspnair » 2010-04-19 06:38

Even I am finding the same problem.
For the gtk settings error, you could fix the following way
Create/Open a file /home/<username>/.gtkrc-2.0
Include the following line
Code: Select all
gtk-icon-theme-name="Onyx"

Or specify any other lxde theme from /usr/share/themes

For the first one, I searched a lot. There were many suggestions.
* Make sure that you have enough space, for me I am using only around 3GB out of 12GB.
* Make sure that /home/<username> should have ownership of <username> especially /home/<username>/.ICEauthority
But it did fix the problem.

I just wanted only a lite desktop. Then, I installed xfce4 and it is working fine.
Compressed Air Energy Storage, Entropy and Efficiency
http://saurorja.org/2012/06/18/compress ... fficiency/
User avatar
aspnair
 
Posts: 1247
Joined: 2009-06-18 12:27
Location: Twitter: @anand_sivaram

Re: LXDE session only lasts 10 seconds

Postby miks » 2010-04-19 06:50

I had this a couple of weeks ago and got around it by installing lxde from sid.
miks
 
Posts: 51
Joined: 2009-08-21 17:41

Re: LXDE session only lasts 10 seconds

Postby aspnair » 2010-04-19 07:38

I followed miks suggestion. Upgraded from 0.4.2-3(squeeze) to 0.5.0-3(unstable), it is working now.
Compressed Air Energy Storage, Entropy and Efficiency
http://saurorja.org/2012/06/18/compress ... fficiency/
User avatar
aspnair
 
Posts: 1247
Joined: 2009-06-18 12:27
Location: Twitter: @anand_sivaram

Re: LXDE session only lasts 10 seconds

Postby rephlex » 2010-04-20 09:51

Thanks, that fixed it!
rephlex
 
Posts: 3
Joined: 2010-04-18 16:53


Return to Installation

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable