[SOLVED] Upgrading squeeze to sid failure

Help with issues regarding installation of Debian

[SOLVED] Upgrading squeeze to sid failure

Postby p3tris » 2012-05-16 11:47

Hi,

I am trying to upgrade squeeze to sid. I edited /etc/sources.list to point to:
Code: Select all
deb http://ftp.us.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.us.debian.org/debian/ sid main contrib non-free


I ran:
Code: Select all
sudo apt-get update
sudo apt-get dist-upgrade

It starting upgrading some files and then it crashed with:
Code: Select all
Setting up atop (1.23-1.1) ...
Starting atop system monitor: invoke-rc.d: initscript atop, action "start" failed.
dpkg: error processing atop (--configure):
 subprocess installed post-installation script returned error exit status 1
configured to not write apport reports
                                      Errors were encountered while processing:
 atop
E: Sub-process /usr/bin/dpkg returned an error code (1)


Now when I run it again I get:
Code: Select all
Calculating upgrade... Failed
The following packages have unmet dependencies:
 libopencv-core-dev : Breaks: libcv-dev (< 2.3.1-1) but 2.1.0-3+squeeze1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

When I try:
Code: Select all
sudo apt-get install libcv-dev
I get:
Code: Select all
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 initscripts : Breaks: console-setup (< 1.74) but 1.68+squeeze2 is to be installed
               Breaks: nfs-common (< 1:1.2.5-3) but 1:1.2.2-4squeeze2 is to be installed
 libcv-dev : Depends: libopencv-features2d-dev but it is not going to be installed
             Depends: libopencv-calib3d-dev but it is not going to be installed
             Depends: libopencv-objdetect-dev but it is not going to be installed
             Depends: libopencv-legacy-dev but it is not going to be installed
 libglib2.0-0 : Breaks: eog (< 3.2.2-3) but 2.30.2-1 is to be installed
                Breaks: gnome-control-center (< 1:3) but 1:2.30.1-2 is to be installed
 libgnome-keyring0 : Breaks: gnome-keyring (< 3.0) but 2.30.3-5 is to be installed
 network-manager : Recommends: crda but it is not going to be installed
                   Breaks: network-manager-gnome (< 0.9) but 0.8.1-2 is to be installed
E: Broken packages


Any ideas?
Last edited by p3tris on 2012-05-22 11:49, edited 1 time in total.
p3tris
 
Posts: 25
Joined: 2012-03-16 10:16

Re: Upgrading squeeze to sid failure

Postby dilberts_left_nut » 2012-05-16 12:02

Welcome to sid :)

Check your sources.list, it still seems to be trying to install squeeze versions.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4691
Joined: 2009-10-05 07:54
Location: enzed

Re: Upgrading squeeze to sid failure

Postby p3tris » 2012-05-16 13:34

dilberts_left_nut wrote:Welcome to sid :)

Check your sources.list, it still seems to be trying to install squeeze versions.

Code: Select all
p3tris@p3tris-debian:~$ cat /etc/apt/sources.list
deb http://ftp.be.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.be.debian.org/debian/ sid main contrib non-free

#deb http://security.debian.org/ squeeze/updates main contrib
#deb-src http://security.debian.org/ squeeze/updates main contrib


I see that. But I have nowhere squeeze...
p3tris
 
Posts: 25
Joined: 2012-03-16 10:16

Re: Upgrading squeeze to sid failure

Postby cynwulf » 2012-05-16 14:24

You will need to remove the troublesome packages and reinstall them later on. Try to remove lbcv-dev for a start and re run the dist-upgrade.
cynwulf
 
Posts: 2396
Joined: 2008-09-25 08:49

Re: Upgrading squeeze to sid failure

Postby p3tris » 2012-05-16 14:47

cynwulf wrote:You will need to remove the troublesome packages and reinstall them later on. Try to remove lbcv-dev for a start and re run the dist-upgrade.


It worked for a while. Now it crashed at:
Code: Select all
E: Could not perform immediate configuration on 'phonon-backend-vlc'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)


and 'phonon-backend-vlc' is not a package...
p3tris
 
Posts: 25
Joined: 2012-03-16 10:16

Re: Upgrading squeeze to sid failure

Postby cynwulf » 2012-05-16 15:46

cynwulf
 
Posts: 2396
Joined: 2008-09-25 08:49

Re: Upgrading squeeze to sid failure

Postby craigevil » 2012-05-16 17:20

it is a package, a package that is buggy as hell. Remove it and be happy.

$ apt-cache policy phonon-backend-vlc
phonon-backend-vlc:
Installed: (none)
Candidate: 0.5.0-1
Version table:
0.5.0-1 0
500 http://ftp-mirror.internap.com/pub/debian/ unstable/main i386 Packages
Debian Sid KDE Kernel 3.17 Thinkpad R40 Intel M 1.3 CPU 2GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Debian upgrade script smxi | sysinfo script inxi
User avatar
craigevil
 
Posts: 5192
Joined: 2006-09-17 03:17
Location: Oz

Re: Upgrading squeeze to sid failure

Postby p3tris » 2012-05-16 18:42

craigevil wrote:it is a package, a package that is buggy as hell. Remove it and be happy.

$ apt-cache policy phonon-backend-vlc
phonon-backend-vlc:
Installed: (none)
Candidate: 0.5.0-1
Version table:
0.5.0-1 0
500 http://ftp-mirror.internap.com/pub/debian/ unstable/main i386 Packages


I know it exists, but it's not installed! I tried:
Code: Select all
apt-get remove / aptitude remove / dpkg -P
All report that is not installed...
p3tris
 
Posts: 25
Joined: 2012-03-16 10:16

Re: Upgrading squeeze to sid failure

Postby cynwulf » 2012-05-16 18:48

You need to post full outputs rather than snippets and vague comments...
cynwulf
 
Posts: 2396
Joined: 2008-09-25 08:49

Re: Upgrading squeeze to sid failure

Postby p3tris » 2012-05-16 18:52

cynwulf wrote:You need to post full outputs rather than snippets and vague comments...


Sorry for that, I know. I left the office and don't have access now. Tomorrow morning I'll see the exact messages and post them...
p3tris
 
Posts: 25
Joined: 2012-03-16 10:16

Re: Upgrading squeeze to sid failure

Postby p3tris » 2012-05-21 07:47

cynwulf wrote:You need to post full outputs rather than snippets and vague comments...


Sorry for the delay. I had some urgent work and I didn't want to mess with the computer anymore (it's my office computer).

I made
Code: Select all
sudo apt-get update && sudo apt-get dist-upgrade
again this morning (after a reboot). Now it breaks down saying
Code: Select all
E: Couldn't configure pre-depend ure for libreoffice-core, probably a dependency cycle.

libreoffice is not installed. So, I removed openoffice.org and I still get the same problem. When I try to also remove openoffice.org-core, I get:
Code: Select all
p3tris@p3tris-debian:~$ sudo apt-get purge openoffice.org-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libglib2.0-0 : Breaks: eog (< 3.2.2-3) but 2.30.2-1 is to be installed
                Breaks: gnome-control-center (< 1:3) but 1:2.30.1-2 is to be installed
 libgnome-keyring0 : Breaks: gnome-keyring (< 3.0) but 2.30.3-5 is to be installed
 network-manager : Recommends: crda but it is not going to be installed
                   Breaks: network-manager-gnome (< 0.9) but 0.8.1-2 is to be installed
E: Broken packages


Is this too much screwed to be fixed?
p3tris
 
Posts: 25
Joined: 2012-03-16 10:16

Re: Upgrading squeeze to sid failure

Postby dilberts_left_nut » 2012-05-21 07:59

Again, it is still trying to install squeeze versions.
Check also in /etc/apt/sources.list.d/
and /etc/apt/preferences ?

post the full output of 'apt-get update'
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4691
Joined: 2009-10-05 07:54
Location: enzed

Re: Upgrading squeeze to sid failure

Postby p3tris » 2012-05-21 08:06

dilberts_left_nut wrote:Again, it is still trying to install squeeze versions.
Check also in /etc/apt/sources.list.d/
and /etc/apt/preferences ?

post the full output of 'apt-get update'


/etc/apt/preferences does not exist. /etc/apt/sources.list.d/ and /etc/apt/preferences.d are empty.

Code: Select all
p3tris@p3tris-debian:/etc/apt/preferences.d$ sudo apt-get update
Hit http://ftp.de.debian.org sid Release.gpg
Hit http://ftp.de.debian.org/debian/ sid/contrib Translation-en
Ign http://ftp.de.debian.org/debian/ sid/contrib Translation-en_US
Hit http://ftp.de.debian.org/debian/ sid/main Translation-en
Ign http://ftp.de.debian.org/debian/ sid/main Translation-en_US
Hit http://ftp.de.debian.org/debian/ sid/non-free Translation-en
Ign http://ftp.de.debian.org/debian/ sid/non-free Translation-en_US
Hit http://ftp.de.debian.org sid Release
Hit http://ftp.de.debian.org sid/main Sources/DiffIndex
Hit http://ftp.de.debian.org sid/contrib Sources/DiffIndex
Hit http://ftp.de.debian.org sid/non-free Sources/DiffIndex
Hit http://ftp.de.debian.org sid/main amd64 Packages/DiffIndex
Hit http://ftp.de.debian.org sid/contrib amd64 Packages/DiffIndex
Hit http://ftp.de.debian.org sid/non-free amd64 Packages/DiffIndex
Reading package lists... Done
p3tris@p3tris-debian:/etc/apt/preferences.d$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  capplets-data defoma deskbar-applet eclipse-plugin-cvs g++-4.3 gcc-4.3 gcc-4.3-multilib gir1.0-clutter-1.0 gir1.0-freedesktop gir1.0-glib-2.0 gir1.0-gstreamer-0.10
  gir1.0-gtk-2.0 gir1.0-json-glib-1.0 gnome-about gnome-accessibility gnome-desktop-environment gnome-netstatus-applet gnome-orca gnome-utils-common kdebase-bin kdebase-data
  kdebase-runtime kdebase-runtime-data kdelibs5-dev kdepim-runtime kile knm-runtime konsole krusader kwalletmanager libakonadiprivate1 libbrasero-media0 libdrm-nouveau1
  libebook1.2-9 libedata-book1.2-2 libedataserverui1.2-8 libepc-1.0-2 libepc-ui-1.0-2 libept1 libgail-gnome-module libgd2-noxpm libgstfarsight0.10-0 libgtkhtml-editor0
  libhdf5-serial-1.8.4 libmetacity-private0 libmtp8 libnautilus-extension1 libntfs-3g75 libpanel-applet2-0 libpango1.0-common libperl5.10 libpolkit-gtk-1-0 libpulse-browse0
  libqt4-multimedia libquantlib-1.0.0 librpm1 librpmbuild1 libsdl1.2debian-alsa libseed0 libstdc++6-4.3-dev libtelepathy-farsight0 libxmlrpc-c3 linux-headers-2.6.32-5-amd64
  linux-sound-base nautilus-gksu network-manager-kde openoffice.org-base-core openoffice.org-core openoffice.org-gcj phonon-backend-xine php5-suhosin pulseaudio-module-hal
  python-gnomeapplet r-cran-vr remmina-plugin-data seahorse-plugins sun-java6-fonts totem-coherence wine-utils x-ttcidfont-conf xserver-xorg-video-nv
The following NEW packages will be installed:
  abiword abiword-common abiword-plugin-grammar abiword-plugin-mathview accountsservice acl aisleriot akonadi-backend-mysql apg aptdaemon aptdaemon-data at-spi2-core
  audacious-plugins-data brltty brltty-x11 cdbs chktex coinor-libcgl0 coinor-libclp0 coinor-libcoinutils0 coinor-libdylp0 coinor-libosi0 coinor-libsymphony0 coinor-libvol0
  colord cpp-4.6 cpp-4.7 crda cups-filters dconf-gsettings-backend dconf-service dconf-tools docbook-xsl dvidvi eclipse-cdt-jni eclipse-emf eclipse-rse enchant
  epiphany-extensions extlinux finger firmware-linux-free folks-common fonts-cantarell fonts-comfortaa fonts-droid fonts-gfs-artemisia fonts-gfs-baskerville
  fonts-gfs-bodoni-classic fonts-gfs-complutum fonts-gfs-didot fonts-gfs-didot-classic fonts-gfs-gazis fonts-gfs-neohellenic fonts-gfs-olga fonts-gfs-porson fonts-gfs-solomos
  fonts-gfs-theokritos fonts-hosny-amiri fonts-inconsolata fonts-ipaexfont-gothic fonts-ipaexfont-mincho fonts-ipafont-gothic fonts-ipafont-mincho fonts-junicode
  fonts-liberation fonts-linuxlibertine fonts-lyx fonts-oflb-asana-math fonts-opensymbol fonts-sil-gentium fonts-sil-gentium-basic fuse g++-4.7 gcc-4.6 gcc-4.6-base gcc-4.7
  gcc-4.7-multilib gcj-4.7-base gcj-4.7-jre gcj-4.7-jre-headless gcj-4.7-jre-lib gconf-service gcr gdebi gdebi-core geany-common gedit-plugins gfortran-4.7
  gfortran-4.7-multilib gir1.2-accountsservice-1.0 gir1.2-atk-1.0 gir1.2-atspi-2.0 gir1.2-caribou-1.0 gir1.2-clutter-1.0 gir1.2-clutter-gst-1.0 gir1.2-cogl-1.0
  gir1.2-coglpango-1.0 gir1.2-evince-3.0 gir1.2-folks-0.6 gir1.2-freedesktop gir1.2-gconf-2.0 gir1.2-gdata-0.0 gir1.2-gdkpixbuf-2.0 gir1.2-gee-1.0 gir1.2-gkbd-3.0
  gir1.2-glib-2.0 gir1.2-gmenu-3.0 gir1.2-gnomebluetooth-1.0 gir1.2-gnomekeyring-1.0 gir1.2-goa-1.0 gir1.2-gst-plugins-base-0.10 gir1.2-gstreamer-0.10 gir1.2-gtk-3.0
  gir1.2-gtkclutter-1.0 gir1.2-gtksource-3.0 gir1.2-gucharmap-2.90 gir1.2-javascriptcoregtk-3.0 gir1.2-json-1.0 gir1.2-mutter-3.0 gir1.2-networkmanager-1.0 gir1.2-notify-0.7
  gir1.2-panelapplet-4.0 gir1.2-pango-1.0 gir1.2-peas-1.0 gir1.2-polkit-1.0 gir1.2-rb-3.0 gir1.2-soup-2.4 gir1.2-telepathyglib-0.12 gir1.2-telepathylogger-0.2 gir1.2-totem-1.0
  gir1.2-totem-plparser-1.0 gir1.2-tracker-0.14 gir1.2-upowerglib-1.0 gir1.2-vte-2.90 gir1.2-webkit-3.0 gir1.2-wnck-3.0 gir1.2-xkl-1.0 git-el git-man gjs glchess
  glib-networking glib-networking-common glib-networking-services glines glx-alternative-mesa glx-alternative-nvidia glx-diversions gnect gnibbles gnobots2
  gnome-commander-data gnome-contacts gnome-control-center-data gnome-desktop3-data gnome-documents gnome-font-viewer gnome-icon-theme-extras gnome-icon-theme-symbolic
  gnome-online-accounts gnome-packagekit gnome-packagekit-data gnome-session-fallback gnome-shell gnome-shell-common gnome-sudoku gnome-sushi gnome-themes-standard
  gnome-video-effects gnomine gnotravex gnotski grilo-plugins-0.1 growisofs grub-pc-bin grub2-common gsettings-desktop-schemas gstreamer0.10-gconf gtali guile-2.0-libs
  gvfs-common gvfs-daemons gvfs-libs iagno ibus-qt4 icedtea-netx icedtea-netx-common imagemagick-common iputils-tracepath iw javascript-common kate-data katepart
  kde-baseapps-data kde-runtime-data kerneloops-applet kerneloops-daemon ksh latex-fonts-thai-tlwg latexdiff lib32itm1 lib32quadmath0 lib32tinfo5 libaacs0 libabiword-2.9
  libaccountsservice0 libakonadiprotocolinternals1 libapache-pom-java libapt-inst1.5 libapt-pkg4.12 libarchive12 libasprintf0c2 libatk-adaptor-data libatk-wrapper-java
  libatk-wrapper-java-jni libatkmm-1.6-1 libatspi2.0-0 libaudiofile1 libav-tools libavahi-ui-gtk3-0 libavcodec53 libavdevice53 libavfilter2 libavformat53 libavutil51
  libbabl-0.1-0 libbackport-util-concurrent-java libbind9-80 libbluray1 libboost-filesystem1.49.0 libboost-iostreams1.49.0 libboost-program-options1.49.0 libboost-python1.49.0
  libboost-regex1.49.0 libboost-serialization1.49.0 libboost-signals1.49.0 libboost-system1.49.0 libboost-thread1.49.0 libbrasero-media3-1 libcamel-1.2-29 libcanberra-gtk3-0
  libcanberra-gtk3-module libcanberra-pulse libcap2-bin libcapi20-3 libcaribou-common libcaribou0 libchamplain-0.12-0 libchamplain-gtk-0.12-0 libcheese-gtk21 libcheese3
  libclass-isa-perl libclutter-1.0-common libclutter-gst-1.0-0 libclutter-gtk-1.0-0 libclutter-imcontext-0.1-0 libcluttergesture-0.0.2-0 libcmis-0.2-0 libcogl-common
  libcogl-pango0 libcogl9 libcolord1 libcommons-net2-java libcommons-parent-java libcupsfilters1 libcurl3-nss libdb5.1 libdb5.1-java libdb5.1-java-jni libdbus-glib1.0-cil
  libdbus1.0-cil libdbusmenu-qt2 libdconf0 libdlrestrictions1 libdmapsharing-3.0-2 libdnet libdns81 libdom4j-java libdotconf1.0 libdrm-nouveau1a libebackend-1.2-1 libebml3
  libebook-1.2-12 libecal-1.2-10 libedata-book-1.2-11 libedata-cal-1.2-13 libedataserver-1.2-15 libedataserverui-3.0-1 libencode-locale-perl libepc-1.0-3 libepc-ui-1.0-3
  libept1.4.12 libescpr1 libevdocument3-4 libevview3-3 libexiv2-12 libexo-1-0 libexo-helpers libexttextcat-data libexttextcat0 libfarstream-0.1-0 libfile-fcntllock-perl
  libfile-listing-perl libfile-which-perl libfm-data libfm-gtk-bin libfm-gtk1 libfm1 libfolks-eds25 libfolks-telepathy25 libfolks25 libfreerdp1 libgail-3-0 libgarcon-1-0
  libgarcon-common libgcj13 libgcj13-awt libgck-1-0 libgconf-2-4 libgcr-3-1 libgcr-3-common libgd2-xpm libgdata1.9-cil libgdata13 libgdict-common libgdk-pixbuf2.0-0
  libgdk-pixbuf2.0-common libgdk-pixbuf2.0-dev libgdome2-0 libgdome2-cpp-smart0c2a libgee2 libgegl-0.2-0 libgeocode-glib0 libgettextpo0 libgexiv2-1 libgirepository-1.0-1
  libgjs0b libgkeyfile1.0-cil libglapi-mesa libglew1.7 libglib2.0-bin libglpk0 libgmime-2.6-0 libgmime2.6-cil libgmlib0 libgmp10 libgmtk0 libgmtk0-data libgnome-bluetooth8
  libgnome-control-center1 libgnome-desktop-3-2 libgnome-keyring-common libgnome-media-profiles-3.0-0 libgnome-menu-3-0 libgnomekbd7 libgoa-1.0-0 libgoa-1.0-common
  libgphoto2-l10n libgpod-common libgpod4 libgraphite2-2.0.0 libgrilo-0.1-0 libgssdp-1.0-3 libgstreamer-plugins-bad0.10-0 libgtk-3-0 libgtk-3-bin libgtk-3-common
  libgtk-sharp-beans-cil libgtk-vnc-2.0-0 libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0 libgtkmathview0c2a libgtkmm-3.0-1 libgtksourceview-3.0-0
  libgtksourceview-3.0-common libgucharmap-2-90-7 libgudev1.0-cil libguess1 libgupnp-1.0-4 libgupnp-av-1.0-2 libgupnp-igd-1.0-4 libgusb2 libgvnc-1.0-0 libgweather-3-0 libgxps2
  libhawtjni-runtime-java libhdf5-7 libhtml-form-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl libhttp-message-perl libhttp-negotiate-perl libhunspell-1.3-0
  libibus-qt1 libicu48 libicu4j-4.4-java libimlib2 libimobiledevice2 libisc83 libisccc80 libisccfg82 libitm1 libjansi-java libjansi-native-java libjavascriptcoregtk-1.0-0
  libjavascriptcoregtk-3.0-0 libjaxen-java libjaxme-java libjgoodies-common-java libjim0debian2 libjs-jquery libjson0 libjte1 libkarma0 libkatepartinterfaces4 libkcalcore4
  libkcalutils4 libkcmutils4 libkdeclarative5 libkemoticons4 libkidletime4 libkonq5-templates libkpathsea6 libkprintutils4 liblink-grammar4 liblockfile-bin libloudmouth1-0
  liblvm2app2.2 liblwp-mediatypes-perl liblwp-protocol-https-perl liblwres80 liblzma5 libmagick++5 libmagickcore5 libmagickcore5-extra libmagickwand5 libmatroska5
  libmeanwhile1 libmetacity-private0a libmhash2 libminiupnpc5 libmission-control-plugins0 libmono-cairo4.0-cil libmono-compilerservices-symbolwriter4.0-cil
  libmono-corlib4.0-cil libmono-i18n-west4.0-cil libmono-i18n4.0-cil libmono-posix4.0-cil libmono-security4.0-cil libmono-sharpzip4.84-cil libmono-system-configuration4.0-cil
  libmono-system-core4.0-cil libmono-system-drawing4.0-cil libmono-system-security4.0-cil libmono-system-xml4.0-cil libmono-system4.0-cil libmowgli2 libmozjs185-1.0 libmpc2
  libmpg123-0 libmtdev1 libmtp-common libmtp-runtime libmtp9 libmutter0 libmx-1.0-2 libmx-bin libmx-common libnatpmp1 libnautilus-extension1a libnepomukutils4 libnet-http-perl
  libnetfilter-conntrack3 libnettle4 libnice10 libnl-route-3-200 libnl2 libnm-glib4 libnm-gtk-common libnm-gtk0 libnm-util2 libnotify4 libnspr4 libnss3 libntrack-qt4-1
  libntrack0 liboauth0 libobrender27 libobt0 libodbc1 liboobs-1-5 libopal3.10.4 libopenal-data libopenal1 libopenconnect1 libopencv-core2.3 libopencv-imgproc2.3 libots0
  libpackagekit-glib2-14 libpam-cap libpam-modules-bin libpanel-applet-4-0 libpano13-2 libpeas-1.0-0 libpeas-common libperl5.14 libpipeline1 libpolkit-qt-1-1 libpoppler-glib6
  libpoppler13 libpostproc52 libprocps0 libpt2.10.4 libptexenc1 libpurple-bin libpurple0 libpython2.7 libqt4-declarative libqt4-dev-bin libqtassistantclient4 libqtwebkit-dev
  libqtwebkit4 libquantlib-1.2 libquvi-scripts libquvi7 libqzeitgeist0 libraptor2-0 librasqal3 libraw5 libreoffice libreoffice-base libreoffice-base-core libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-emailmerge libreoffice-evolution libreoffice-filter-binfilter libreoffice-filter-mobiledev libreoffice-gnome
  libreoffice-gtk libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-math libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-tango libreoffice-writer librest-0.7-0 librest-extras-0.7-0 librhythmbox-core5 libroar-compat2 libroar2 librpm2 librpmbuild2 librpmio2 librpmsign0
  librtmp-dev libsane-common libsane-extras-common libseed-gtk3-0 libsemanage-common libsemanage1 libsigsegv2 libsocialweb-client2 libsocialweb0 libsolidcontrol4abi2 libsonic0
  libsoundtouch0 libsox2 libspandsp2 libspeechd2 libssh2-1-dev libstdc++6-4.7-dev libswitch-perl libswscale2 libswt-cairo-gtk-3-jni libswt-glx-gtk-3-jni libswt-gnome-gtk-3-jni
  libswt-gtk-3-java libswt-gtk-3-jni libswt-webkit-gtk-3-jni libsystemd-daemon0 libsystemd-login0 libtagc0 libtbb2 libtelepathy-farstream2 libtelepathy-logger2
  libthunar-vfs-1-common libtinfo-dev libtinfo5 libtinyxml2.6.2 libtokyocabinet9 libtotem0 libtracker-extract-0.14-0 libtracker-miner-0.14-0 libtracker-sparql-0.14-0
  libunique-3.0-0 libustr-1.0-1 libv4lconvert0 libvisio-0.0-0 libvncserver0 libvo-aacenc0 libvo-amrwbenc0 libvte-2.90-9 libvte-2.90-common libwebkitgtk-1.0-0
  libwebkitgtk-1.0-common libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libwebrtc-audio-processing-0 libwildmidi-config libwine-bin libwine-openal libwnck-3-0 libwnck-3-common
  libwpd-0.9-9 libwpg-0.2-2 libwps-0.2-2 libwv-1.2-4 libwww-robotrules-perl libx264-123 libxalan2-java libxcb-glx0 libxcb-util0 libxfce4ui-1-0 libxml-commons-external-java
  libxml-commons-resolver1.1-java libxmlrpc-core-c3 libxnvctrl0 libxom-java libxpp2-java libyajl2 libyelp0 libzephyr4 libzthread-2.3-2 libzvbi-common libzvbi0 liferea
  liferea-data lightsoff link-grammar-dictionaries-en linux-headers-3.2.0-2-amd64 linux-headers-3.2.0-2-common linux-headers-amd64 linux-image-3.2.0-2-amd64 linux-image-amd64
  linux-kbuild-3.2 lsb-security mahjongg media-player-info memtest86+ minissdpd mono-4.0-gac mscompress mutter-common mythes-en-us network-manager-openconnect-gnome nmap
  ntrack-module-libnl-0 nvidia-alternative nvidia-installer-cleanup nvidia-kernel-dkms nvidia-support otf-freefont packagekit packagekit-backend-aptcc packagekit-tools
  phonon-backend-null pidgin-data poppler-data printer-driver-all printer-driver-c2050 printer-driver-c2esp printer-driver-cjet printer-driver-escpr printer-driver-foo2zjs
  printer-driver-gutenprint printer-driver-hpcups printer-driver-hpijs printer-driver-m2300w printer-driver-min12xxw printer-driver-pnm2ppa printer-driver-postscript-hp
  printer-driver-ptouch printer-driver-pxljr printer-driver-sag-gdi printer-driver-splix python-aptdaemon python-aptdaemon.gtk3widgets python-dbus-dev python-debianbts
  python-decorator python-defer python-fpconst python-gi python-gi-cairo python-gobject-2 python-mako python-markupsafe python-packagekit python-pycurl python-renderpm
  python-reportlab python-reportlab-accel python-simplegeneric python-soappy python-speechd python-zeitgeist python2.7 python2.7-dev python2.7-minimal qdbus qt4-linguist-tools
  quadrapassel r-cran-gam r-cran-stabledist remmina-common rhythmbox rhythmbox-data rhythmbox-plugin-cdrecorder rhythmbox-plugins rtkit samba-common samba-common-bin shotwell
  simple-scan smbclient software-properties-common sound-theme-freedesktop speech-dispatcher swell-foop syslinux-themes-debian syslinux-themes-debian-squeeze telepathy-haze
  telepathy-idle telepathy-logger texlive-doc-ar texlive-doc-rs texlive-lang-cjk texlive-lang-english texmaker-data tomboy tracker tracker-extract tracker-gui
  tracker-miner-evolution tracker-miner-fs tracker-utils ttf-marvosym unoconv vinagre wireless-regdb wwwconfig-common xbrlapi xorg-sgml-doctools xserver-xorg-video-nvidia
  xz-lzma yelp-xsl zeitgeist-core zenity-common
The following packages have been kept back:
  gnuplot-nox gnuplot-x11 libmysqlclient16 mysql-common r-base-dev
The following packages will be upgraded:
  akonadi-server alsa-base alsa-utils apache2 apache2-mpm-prefork apache2.2-bin apache2.2-common apt apt-utils aptitude aspell asymptote at-spi audacious audacious-plugins
  automoc backintime-common backintime-gnome banshee baobab bash bind9-host binfmt-support binutils binutils-dev bluez bogofilter-bdb brasero brasero-common bsdmainutils
  cdrdao cheese cheese-common clisp cm-super cm-super-minimal cmake cmake-data cpp cpp-4.4 cryptkeeper cups cups-bsd cups-client cups-driver-gutenprint cups-pk-helper
  cutter-testing-framework-bin dasher dblatex dbus debhelper dialog disk-manager dnsmasq-base dnsutils doxygen-gui dpkg-dev dvd+rw-tools dvipng dvipsk-ja easytag eclipse
  eclipse-cdt eclipse-jdt eclipse-pde eclipse-platform eclipse-platform-data eclipse-rcp ekiga emacs23 emacs23-bin-common emacs23-common empathy empathy-common enblend encfs
  enfuse eog epiphany-browser epiphany-browser-data esound-common espeak espeak-data evince evince-common evolution evolution-common evolution-data-server
  evolution-data-server-common evolution-plugins evolution-webcal exim4 exim4-base exim4-daemon-light exiv2 exo-utils ffmpeg file-roller filezilla filezilla-common foo2zjs
  foomatic-db foomatic-db-engine freedesktop-sound-theme furiusisomount fuse-utils g++ g++-4.4 gawk gcalctool gcc gcc-4.4 gcc-4.4-base gcc-4.4-multilib gcc-multilib
  gcj-4.4-base gcj-4.4-jre gcj-4.4-jre-headless gcj-4.4-jre-lib gcj-jre gcj-jre-headless gconf-defaults-service gconf-editor gconf2 gconf2-common gdb gdm3 geany
  gecko-mediaplayer gedit gedit-common gedit-latex-plugin geoclue geoclue-hostip geoclue-localnet geoclue-manual geoclue-yahoo gettext gettext-base gfortran gfortran-4.4
  gfortran-4.4-multilib gfortran-multilib ggobi gimp gimp-data git git-all git-arch git-cvs git-daemon-run git-email git-gui git-svn gitk gitweb gksu gnome-applets
  gnome-applets-data gnome-bluetooth gnome-cards-data gnome-commander gnome-control-center gnome-core gnome-desktop-data gnome-dictionary gnome-disk-utility gnome-doc-utils
  gnome-games gnome-games-data gnome-games-extra-data gnome-icon-theme gnome-keyring gnome-mag gnome-media gnome-menus gnome-mplayer gnome-nettool gnome-panel gnome-panel-data
  gnome-power-manager gnome-screensaver gnome-screenshot gnome-search-tool gnome-session gnome-session-bin gnome-session-canberra gnome-session-common gnome-settings-daemon
  gnome-system-log gnome-system-monitor gnome-system-tools gnome-terminal gnome-terminal-data gnome-user-guide gnome-user-share gnumeric gnumeric-common gparted gpicview
  groovy grub-common grub-pc gstreamer0.10-alsa gstreamer0.10-ffmpeg gstreamer0.10-nice gstreamer0.10-plugins-bad gstreamer0.10-plugins-base gstreamer0.10-plugins-base-apps
  gstreamer0.10-plugins-cutter gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly gstreamer0.10-pulseaudio gstreamer0.10-sdl gstreamer0.10-tools gstreamer0.10-x
  gtk2-engines gtk2-engines-pixbuf gucharmap guile-1.8 guile-1.8-libs gvfs gvfs-backends gvfs-bin gvfs-fuse gvidm hal hamster-applet hardinfo hpijs hplip hplip-cups hplip-data
  htop hugin hugin-data hugin-tools icedove imagemagick info inkscape iproute ipython jabref kdelibs-bin kdelibs5-data kdelibs5-plugins kdepimlibs-kio-plugins kdoctools
  kerneloops lame latex-cjk-all latex-cjk-chinese latex-cjk-chinese-arphic-bkai00mp latex-cjk-chinese-arphic-bsmi00lp latex-cjk-chinese-arphic-gbsn00lp
  latex-cjk-chinese-arphic-gkai00mp latex-cjk-common latex-cjk-japanese latex-cjk-japanese-wadalab latex-cjk-korean latex-cjk-thai latex-cjk-xcjk latex-sanskrit latex2html
  lcdf-typetools less lib32asound2 lib32gfortran3 lib32ncurses5 lib32v4l-0 libaccess-bridge-java-jni libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4
  libalgorithm-diff-xs-perl libapache2-mod-perl2 libapache2-mod-php5 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libapt-pkg-perl libasound2 libasound2-plugins
  libaspell15 libatk1.0-0 libatk1.0-dev libatlas3gf-base libatspi1.0-0 libattica0 libaudclient2 libaudcore1 libavahi-ui0 libboo2.0.9-cil libbsd-resource-perl libbsf-java
  libc-bin libc-dev-bin libc6 libc6-dev libc6-dev-i386 libc6-i386 libcaca0 libcairo-perl libcanberra-gtk-module libcanberra-gtk0 libclutter-1.0-0 libcommons-beanutils-java
  libcommons-lang-java libcommons-logging-java libcups2 libcupsmime1 libcurl3-gnutls libcurl4-gnutls-dev libcutter-dev libcutter0 libcwidget3 libdbd-sqlite3-perl libdbi-perl
  libdbus-glib-1-2 libdbus-glib-1-dev libdpkg-perl libenchant1c2a libepc-common libequinox-osgi-java libesd0 libespeak1 libevolution libexempi3 libexif-dev libexif12 libflite1
  libfluidsynth1 libfont-freetype-perl libfontenc1 libfreerdp-plugins-standard libfuse2 libgail-common libgail18 libgcc1 libgcj-bc libgcj10 libgcj10-awt libgconf2-4
  libgconf2.0-cil libgdict-1.0-6 libgdiplus libgdu-gtk0 libgfortran3 libggi2 libgimp2.0 libgksu2-0 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libgl1-nvidia-alternatives
  libgl1-nvidia-glx libglib-perl libglib2.0-0 libglib2.0-cil libglib2.0-dev libglibmm-2.4-1c2a libglx-nvidia-alternatives libgnome-desktop-2-17 libgnome-keyring0 libgnome2-0
  libgnome2-canvas-perl libgnome2-common libgnome2-perl libgnome2-vfs-perl libgnomecanvas2-0 libgnomekbd-common libgnomeui-0 libgoffice-0.8-8 libgomp1 libgphoto2-2
  libgphoto2-2-dev libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libgtk2-perl libgtk2.0-0 libgtk2.0-bin libgtk2.0-cil libgtk2.0-common libgtk2.0-dev libgtkglext1
  libgtkhtml3.14-19 libgtkmm-2.4-1c2a libhpmud0 libhtml-parser-perl libid3-3.8.3c2a libilmbase6 libisofs6 libjack-jackd2-0 libjdom1-java libjempbox-java libjgoodies-looks-java
  libjson-glib-1.0-0 libkabc4 libkcal4 libkde3support4 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkfile4 libkhtml5 libkimap4 libkimproxy4 libkio5 libkjsapi4
  libkjsembed4 libkldap4 libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpimutils4 libkpty4 libkresources4 libkrosscore4
  libkrossui4 libktexteditor4 libkunitconversion4 libkutils4 liblapack-dev liblapack3gf libldap-2.4-2 libldap2-dev liblist-moreutils-perl liblocale-gettext-perl liblockfile1
  liblucene2-java libmailtransport4 libmcs1 libmicroblog4 libmono-addins-gui0.2-cil libmono-addins0.2-cil libmono-corlib2.0-cil libmono-data-tds2.0-cil
  libmono-messaging2.0-cil libmono-posix2.0-cil libmono-security2.0-cil libmono-sharpzip2.84-cil libmono-sqlite2.0-cil libmono-system-data-linq2.0-cil
  libmono-system-data2.0-cil libmono-system-messaging2.0-cil libmono-system-web2.0-cil libmono-system2.0-cil libmono-wcf3.0-cil libmono-zeroconf1.0-cil libmono2.0-cil libmpfr4
  libmusicbrainz4c2a libncurses5 libncurses5-dev libncursesw5 libndesk-dbus-glib1.0-cil libndesk-dbus1.0-cil libnepomuk4 libnepomukquery4a libnet-dbus-perl libnet-dns-perl
  libnet-libidn-perl libnet-ssleay-perl libnm-glib-vpn1 libnotify-dev libnotify0.4-cil libnspr4-0d libnss3-1d libpam-modules libpango-perl libpango1.0-0 libpango1.0-dev
  libpangomm-1.4-1 libpano13-bin libpdfbox-java libphonon-dev libphonon4 libplasma3 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libpoppler-qt4-3
  libportaudio2 libpstoedit0c2a libpulse-dev libpulse-mainloop-glib0 libpulse0 libpvm3 libqca2 libqjson0 libqt4-assistant libqt4-dbus libqt4-designer libqt4-dev libqt4-help
  libqt4-network libqt4-opengl libqt4-opengl-dev libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test
  libqt4-webkit libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 librdf0 libreadline-dev libreadline5 libreadline6 libreadline6-dev librlog5 librsvg2-2 librsvg2-common
  libruby1.8 libsane libsane-extras libsane-extras-dev libsane-hpaio libsasl2-2 libsasl2-modules libsdl1.2debian libsigc++-2.0-0c2a libslv2-9 libsnmp15 libsolid4
  libsoprano-dev libsoprano4 libsoup-gnome2.4-1 libsoup2.4-1 libsox-fmt-alsa libsox-fmt-base libsprng2 libstartup-notification0 libstdc++6 libstdc++6-4.4-dev
  libstreamanalyzer0 libstreams0 libstrongswan libsvn-perl libtag1-vanilla libtag1c2a libtaglib2.0-cil libtelepathy-glib0 libterm-readkey-perl libtext-charwidth-perl
  libtext-iconv-perl libthreadweaver4 libthunar-vfs-1-2 libtotem-plparser17 libunique-1.0-0 libuuid-perl libv4l-0 libvte-common libvte9 libwebkit1.1-cil libwildmidi1 libwine
  libwine-alsa libwine-cms libwine-gl libwine-gphoto2 libwine-ldap libwine-print libwine-sane libwmf0.2-7 libwnck22 libwww-perl libwxgtk2.8-0 libxapian22 libxerces2-java
  libxerces2-java-gcj libxfcegui4-4 libxi-dev libxi6 libxine1 libxine1-bin libxine1-console libxine1-ffmpeg libxine1-misc-plugins libxine1-plugins libxine1-x
  libxml-parser-perl lilypond lilypond-data linux-headers-2.6-amd64 linux-image-2.6-amd64 littler lmodern locales lsb-core lsb-release luatex lxappearance lxde-core lxinput
  lxmusic lxpanel lxrandr lxsession lxsession-edit lxshortcut lxterminal lynx lynx-cur lyx lyx-common man-db meld mencoder menu mesa-common-dev mesa-utils metacity
  metacity-common min12xxw mkvtoolnix mono-2.0-gac mono-gac mono-runtime mousetweaks mplayer musixtex mutt nautilus nautilus-actions nautilus-data nautilus-image-converter
  nautilus-open-terminal nautilus-scripts-manager nautilus-sendto nautilus-sendto-empathy ncurses-bin network-manager network-manager-dbg network-manager-gnome
  network-manager-openconnect network-manager-openvpn network-manager-openvpn-gnome network-manager-pptp network-manager-pptp-gnome network-manager-strongswan
  network-manager-vpnc network-manager-vpnc-gnome notification-daemon ntfs-3g ntp nvidia-glx nvidia-settings nvidia-vdpau-driver nvidia-xconfig obconf obex-data-server
  obexd-client openbox openconnect openjdk-6-jre openoffice.org-base openoffice.org-common openoffice.org-emailmerge openoffice.org-evolution openoffice.org-filter-binfilter
  openoffice.org-gnome openoffice.org-gtk openoffice.org-help-en-us openoffice.org-java-common openoffice.org-math openoffice.org-style-galaxy openoffice.org-style-tango
  openoffice.org-thesaurus-en-us openoffice.org-writer paprefs passwd pavucontrol pavumeter pcmanfm pdfshuffler perl perl-base perl-doc perl-modules perlmagick php5-cli
  php5-common plasma-scriptengine-javascript pnm2ppa policykit-1 policykit-1-gnome poppler-utils powertop procps psmisc pulseaudio pulseaudio-esound-compat
  pulseaudio-module-bluetooth pulseaudio-module-gconf pulseaudio-module-jack pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils purifyeps pvm pychess python
  python-apt python-axiom python-beautifulsoup python-brlapi python-cairo python-chardet python-coherence python-configobj python-crypto python-cupshelpers python-dbus
  python-debian python-dev python-enchant python-evolution python-foolscap python-gconf python-gdata python-glade2 python-gmenu python-gnome2 python-gnomedesktop
  python-gnomekeyring python-gobject python-gst0.10 python-gtk2 python-gtkglext1 python-gtksourceview2 python-httplib2 python-imaging python-imaging-tk python-libxml2
  python-louis python-lxml python-mechanize python-minimal python-nevow python-notify python-numpy python-opengl python-pexpect python-poppler python-pyatspi python-pyorbit
  python-pysqlite2 python-reportbug python-rsvg python-serial python-software-properties python-tagpy python-twisted-conch python-twisted-core python-twisted-names
  python-twisted-web python-uno python-utidylib python-vte python-wnck python-wxgtk2.8 python-wxversion python-xapian python-zope.interface qt4-designer qt4-dev-tools
  qt4-qmake qt4-qtconfig r-base r-base-core r-cran-abind r-cran-amelia r-cran-bitops r-cran-boot r-cran-cairodevice r-cran-car r-cran-catools r-cran-chron r-cran-class
  r-cran-cluster r-cran-coda r-cran-codetools r-cran-combinat r-cran-date r-cran-dbi r-cran-diagnosismed r-cran-domc r-cran-dosnow r-cran-effects r-cran-epi r-cran-epibasix
  r-cran-epicalc r-cran-epir r-cran-epitools r-cran-erm r-cran-evd r-cran-fasianoptions r-cran-fbasics r-cran-fbonds r-cran-fecofin r-cran-fexoticoptions r-cran-fextremes
  r-cran-fgarch r-cran-fimport r-cran-fmultivar r-cran-fnonlinear r-cran-foptions r-cran-foreach r-cran-foreign r-cran-fportfolio r-cran-fregression r-cran-ftrading
  r-cran-funitroots r-cran-gdata r-cran-genetics r-cran-getopt r-cran-gmodels r-cran-gplots r-cran-gregmisc r-cran-haplo.stats r-cran-hdf5 r-cran-hmisc r-cran-inline
  r-cran-iterators r-cran-kernsmooth r-cran-lattice r-cran-latticeextra r-cran-lme4 r-cran-lmtest r-cran-lpsolve r-cran-mapdata r-cran-mapproj r-cran-maps r-cran-maptools
  r-cran-mass r-cran-matrix r-cran-mcmcpack r-cran-mgcv r-cran-misc3d r-cran-mnormt r-cran-msm r-cran-multcomp r-cran-multicore r-cran-mvtnorm r-cran-nlme r-cran-nnet
  r-cran-plotrix r-cran-polspline r-cran-pscl r-cran-psy r-cran-qtl r-cran-quadprog r-cran-qvalue r-cran-randomforest r-cran-rcmdr r-cran-rcolorbrewer r-cran-rcpp
  r-cran-relimp r-cran-rggobi r-cran-rgl r-cran-rglpk r-cran-rgtk2 r-cran-rmpi r-cran-rmysql r-cran-robustbase r-cran-rocr r-cran-rodbc r-cran-rpart r-cran-rpvm
  r-cran-rquantlib r-cran-rserve r-cran-rsprng r-cran-rsymphony r-cran-sandwich r-cran-slam r-cran-sn r-cran-snow r-cran-sp r-cran-spatial r-cran-spc r-cran-strucchange
  r-cran-surveillance r-cran-survival r-cran-teachingdemos r-cran-timedate r-cran-timeseries r-cran-tkrplot r-cran-tseries r-cran-urca r-cran-vcd r-cran-vgam r-cran-xml
  r-cran-zelig r-cran-zoo r-recommended rdesktop remmina remmina-plugin-rdp remmina-plugin-vnc reportbug rpm rpm-common rpm2cpio ruby ruby1.8 sat4j seahorse
  software-properties-gtk soprano-daemon sound-juicer sox strongswan-ikev2 strongswan-nm synaptic system-config-printer system-config-printer-udev telepathy-gabble
  telepathy-mission-control-5 telepathy-salut testdisk tex-common tex-gyre tex4ht texlive texlive-base texlive-bibtex-extra texlive-binaries texlive-common texlive-doc-base
  texlive-doc-bg texlive-doc-cs+sk texlive-doc-de texlive-doc-en texlive-doc-es texlive-doc-fi texlive-doc-fr texlive-doc-it texlive-doc-ja texlive-doc-ko texlive-doc-mn
  texlive-doc-nl texlive-doc-pl texlive-doc-pt texlive-doc-ru texlive-doc-si texlive-doc-th texlive-doc-tr texlive-doc-uk texlive-doc-vi texlive-doc-zh texlive-extra-utils
  texlive-font-utils texlive-fonts-extra texlive-fonts-extra-doc texlive-fonts-recommended texlive-fonts-recommended-doc texlive-formats-extra texlive-full texlive-games
  texlive-generic-extra texlive-generic-recommended texlive-humanities texlive-humanities-doc texlive-lang-african texlive-lang-arabic texlive-lang-armenian
  texlive-lang-croatian texlive-lang-cyrillic texlive-lang-czechslovak texlive-lang-danish texlive-lang-dutch texlive-lang-finnish texlive-lang-french texlive-lang-german
  texlive-lang-greek texlive-lang-hebrew texlive-lang-hungarian texlive-lang-indic texlive-lang-italian texlive-lang-latin texlive-lang-latvian texlive-lang-lithuanian
  texlive-lang-mongolian texlive-lang-norwegian texlive-lang-other texlive-lang-polish texlive-lang-portuguese texlive-lang-spanish texlive-lang-swedish texlive-lang-tibetan
  texlive-lang-vietnamese texlive-latex-base texlive-latex-base-doc texlive-latex-extra texlive-latex-extra-doc texlive-latex-recommended texlive-latex-recommended-doc
  texlive-luatex texlive-math-extra texlive-metapost texlive-metapost-doc texlive-music texlive-omega texlive-pictures texlive-pictures-doc texlive-plain-extra
  texlive-pstricks texlive-pstricks-doc texlive-publishers texlive-publishers-doc texlive-science texlive-science-doc texlive-xetex texmaker texpower thailatex tipa totem
  totem-common totem-plugins transmission-common transmission-gtk ttf-gfs-artemisia ttf-gfs-baskerville ttf-gfs-bodoni-classic ttf-gfs-didot ttf-gfs-didot-classic
  ttf-gfs-gazis ttf-gfs-neohellenic ttf-gfs-olga ttf-gfs-porson ttf-gfs-solomos ttf-gfs-theokritos ttf-liberation ttf-lyx ttf-opensymbol ttf-sil-gentium udisks ufraw
  ufraw-batch unetbootin unison-gtk unison2.27.57-gtk unixodbc uno-libs3 upower ure usb-modeswitch usb-modeswitch-data util-linux velocity vim-common vim-tiny vino w3m wine
  wine-bin winff wpagui x11proto-core-dev xdg-user-dirs-gtk xfburn xfce4-panel xfce4-screenshooter xmms2-core xmms2-plugin-alsa xmms2-plugin-id3v2 xmms2-plugin-mad
  xmms2-plugin-vorbis xorg xournal xsane xsane-common xscreensaver xscreensaver-data xserver-xorg xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics
  xserver-xorg-input-wacom xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-fbdev
  xserver-xorg-video-i128 xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge
  xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware xserver-xorg-video-voodoo xterm xz-utils yelp zenity zlib1g zlib1g-dev
1128 upgraded, 766 newly installed, 81 to remove and 5 not upgraded.
Need to get 0 B/3,225 MB of archives.
After this operation, 1,782 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
E: Couldn't configure pre-depend ure for libreoffice-core, probably a dependency cycle.
p3tris
 
Posts: 25
Joined: 2012-03-16 10:16

Re: Upgrading squeeze to sid failure

Postby dilberts_left_nut » 2012-05-21 08:25

Well doing a dist upgrade from squeeze to sid with both gnome & kde (and the kitchen sink) installed is asking for trouble really.
If you can fix the libreoffice issue it may "just work", or (more likely) you will hit the next snag, and so on.

Try the aptitude interface. It will give a bit more usable information and the dependency resolution may provide some more helpful options.

FWIW I always remove everything possible before and reinstall after, or just do a bare minimal install then upgrade then install what I want.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4691
Joined: 2009-10-05 07:54
Location: enzed

Re: Upgrading squeeze to sid failure

Postby cynwulf » 2012-05-21 08:51

Yes, you should have removed the desktop environment(s) first. That cuts down on most of the messy dependency resolution. Get rid of gnome, kde, libreoffice, etc and then try again.
cynwulf
 
Posts: 2396
Joined: 2008-09-25 08:49

Next

Return to Installation

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable