gnome-shell depends on gdm3?

News and discussion about development of the Debian OS itself

gnome-shell depends on gdm3?

Postby jilingshu » 2013-11-18 16:17

Hi all,
In today's upgrade in testing(jessie), I found GNOME has been upgraded to 3.8.4. However, gdm3 is automatically installed when I upgrading the system.
By viewing the depends tree, I found gdm3 is now a dependency of gnome-shell. In past few years, gnome-shell and gdm3 are completely independent components. And even I force remove gdm3 today, gnome-shell still works fine until now.
Is this dependency is a mistake, or gnome-shell is really need that dependency?

Thanks in advanced.
jilingshu
 
Posts: 1
Joined: 2013-11-18 16:12

Re: gnome-shell depends on gdm3?

Postby milomak » 2013-11-19 20:27

do you have gnome-core installed?

edit - i was in my stable box when i asked that question. see below for sid
Code: Select all
$ aptitude why gdm3
i   avant-window-navigator Recommends metacity (>= 2.21.5) | xcompmgr | compiz | xfwm4 (>= 4.2) | kde-windo
                                      w-manager (>= 4:4.0.0) | mutter                                     
i A metacity               Recommends gnome-session | x-session-manager                                   
i A gnome-session          Depends    gnome-shell (>= 3.0)                                                 
i A gnome-shell            Depends    gdm3 (>= 3.5.90)


sid and testing run the same versions of gnome-shell and gdm3 so your best course of action is to ask the maintainer if you feel strongly about it - pkg-gnome-maintainers@lists.alioth.debian.org
iMac - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop (64-bit) - Debian Sid, Win10,
Kodi Box - Debian Sid
milomak
 
Posts: 1680
Joined: 2009-06-09 22:20


Return to Debian Development

Who is online

Users browsing this forum: No registered users and 1 guest

fashionable