scsi cd problem FAI installation on Debian squeeze

News and discussion about development of the Debian OS itself

scsi cd problem FAI installation on Debian squeeze

Postby kshankar » 2014-05-28 23:04

I am trying to using Fully Automated installation from a scsi cd-rom drive on Debian Squeeze.
Problem I face is the scsi host-bus-adaptor-Id keeps changing on me during the installation.
This causes the cd-rom to get unmounted and re-mounted. The installation there causes
kernel-panic or just hangs.

For instance initially the scsi Id is 0:0:0:0. After sometime it changes to
1:0:0:0 followed by 2:0:0:0 and so on. My fstab file does not contain entry for
scsi-cd as this is a debootstrap installation wherein I am formatting the disk and installing
OS for the first time.
I am performing a mount of the scsi-cd using
mount -v -t iso9660 `ls /dev/sr?` /live/image, where I am certain initially /dev/sr?=/dev/sr1
for scsi-Id 0:0:0:0, but this increments automatically after some time.

My question(s) are
1) Is there any way to prevent scsi-cd Id changing from 0:0:0:0 to 1:0:0:0 and so on
2) Is there some timer at which this automatically occurs.

My fstab contents during debootstrap are as follows.
/dev/md0 /target/ ext3 rw,errors=remount-ro
/dev/md1 /target/mysqldata ext3 rw
/dev/md2 /target/var/lib/tatara ext3 rw

I don't have an entry for
/dev/sr0 /media/cdrom0 udf,iso9660,ro,user,noauto
since during FAI installation, there is no /target/media directory at all.

In the initial hw-detect I am pre-loading the following kernel modules for scsi devices
kshankar
 
Posts: 1
Joined: 2014-05-28 22:31

Return to Debian Development

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable