libc6:i386 conflicts with libc6-i686 in debian

News and discussion about development of the Debian OS itself

libc6:i386 conflicts with libc6-i686 in debian

Postby Prakash » 2014-12-16 09:52

I am new to debian and need to upgrade libc6-i686:i386 (version 2.13-38+deb7u6) to libc6_2.15. But when I try to install libc6_2.15 it display below message. Please help me to install libc6_2.15-0ubuntu10.9_i386.deb file.

Code: Select all
root@debian:/home/xxxxxx/Downloads# sudo dpkg -i libc6_2.15-0ubuntu10.9_i386.deb
dpkg: regarding libc6_2.15-0ubuntu10.9_i386.deb containing libc6:i386:
 libc6:i386 conflicts with libc6-i686
  libc6-i686:i386 (version 2.13-38+deb7u6) is present and installed.

dpkg: error processing libc6_2.15-0ubuntu10.9_i386.deb (--install):
 conflicting packages - not installing libc6:i386
Errors were encountered while processing:
 libc6_2.15-0ubuntu10.9_i386.deb
User avatar
Prakash
 
Posts: 3
Joined: 2014-12-16 08:31

Re: libc6:i386 conflicts with libc6-i686 in debian

Postby dilberts_left_nut » 2014-12-16 11:14

The package manager is one of the systems that does try to prevent you from sticking forks into sockets.

If you are determined to break it you can override objections by forcing it (see man dpkg).
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4703
Joined: 2009-10-05 07:54
Location: enzed

Re: libc6:i386 conflicts with libc6-i686 in debian

Postby vicshrike » 2014-12-16 11:40

Why do you need to upgrade it?
May the Debian be with you!
User avatar
vicshrike
 
Posts: 36
Joined: 2010-05-07 08:59
Location: /debian/openbox

Re: libc6:i386 conflicts with libc6-i686 in debian

Postby Prakash » 2014-12-16 13:02

Basically I need to install RebbitMQ and its dependency Erlang. and Erlang need its own dependency file libc6( >=2.15 varsion) but presently debian has libc6(2.13).
So I need to upgrade it or install new one.
User avatar
Prakash
 
Posts: 3
Joined: 2014-12-16 08:31

Re: libc6:i386 conflicts with libc6-i686 in debian

Postby Ardouos » 2014-12-16 13:20

This may interest you:
viewtopic.php?f=6&t=118829&p=560308&hilit=+mepis+glibc#p560085
Upgrade at your own risk though.


Another option is to use a distro that has more up to date packages...
User avatar
Ardouos
 
Posts: 955
Joined: 2013-11-03 00:30
Location: Elicoor II

Re: libc6:i386 conflicts with libc6-i686 in debian

Postby stevepusser » 2014-12-16 20:05

I've been keeping track, and so far the experimental libc6 2.17 in the MEPIS repo has not broken anybody's system, so it actually is safe. Since it is just copying what SteamOS did, that is the expected result.

There's also a backported xorg in SteamOS, but there does not seem to be that great a demand for it in Wheezy.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8938
Joined: 2009-10-06 05:53


Return to Debian Development

Who is online

Users browsing this forum: No registered users and 1 guest

fashionable