Page 2 of 2

PostPosted: 2007-04-13 19:28
by hkoster1
It may not be a Debian/kernel problem at all! My guess would be that you should upgrade the firmware in your DSL router/modem... I had a similar problem in my Linksys WAG200G, and a firmware update solved it. :idea:

I would have replied sooner if you had brought this problem up in one of the regular forums, like Hardware or Installation...

PostPosted: 2007-04-13 20:30
by rolandas
No chances that it is hardware issue. I installed Ubuntu kernel 2.6.17 and all works. But this is not Debian kernel issue, it is general kernel issue I beliewe.

PostPosted: 2007-04-17 21:02
by walrus
it loads well to me (2.6.18-4-686, etch fully upgraded)

it maybe the infamous aggressive tcp scaling issue, exposed also in the realease notes for etch

http://www.debian.org/releases/etch/amd ... on.en.html


try to disable tcp window scaling as root
Code: Select all
echo 0 > /proc/sys/net/ipv4/tcp_window_scaling


and try now to load the site

explanation / workaround

PostPosted: 2007-06-29 07:09
by samething22
Recently I found out what is going on with this bug.

The problem has to do with larger default buffer sizes for TCP window scaling in recent Linux kernel versions. If there is an improperly configured router between you and the server you're trying to reach, it will create a bottleneck and you'll get no data from the server. The long and the short of it is that it is not a Linux bug.

Here are some better, more detailed explanations:
http://inodes.org/blog/2006/09/06/tcp-w ... rnel-2617/
http://kerneltrap.org/node/6723

The solution I have used (and I've had to do it again whenever I've updated my kernel) is to change the values in /proc/sys/net/ipv4/tcp_wmem and /proc/sys/net/ipv4/tcp_rmem. The new values should be "4096 16384 131072" and "4096 87380 174760" respectively. This sets the window scaling buffer back to its earlier/smaller size. :)