weekly build 03/17/2007

News and discussion about development of the Debian OS itself

weekly build 03/17/2007

Postby JaDa » 2007-03-18 18:04

http://cdimage.debian.org/cdimage/weekl ... 6/iso-dvd/

i386 DVD

Still there is no automatically Install from ATI Graphic Card! When does your guys change from Mesa Xorg Driver to the ATI fglrx driver? Every Application how needs openGL 2.0 or a aktivated 3d accelerator doesn't work!
It never even work with the download from the ATI Driver from the ATI Website. Don't point it on ATI, this is a seriusly debian issue!

I see no differants between this build and older builds! Still the Kernel security holes are there, graphic doesn't work!
When you guys start updating from 2.6.17 to Kernel 2.6.18 and all is going more worth. This kernel need overwork!

I was testing debian on a Laptop and Desktop!
The Laptop Toshiba Satelitte A135-S2276 see congig here

Errors
1.) Sound Server is not found!
2.) ATI driver will not work with 3D accelerator and openGL 2.0 because of using Mesa GL 1.2
3.) WLan Madwifi Driver doesn't work out of the box! Need reinstalled Installed and configure!
4.) WPA Supplicant doesn't work
5.) Kernel having unbound PCMCIA devices: doing a 'find /sys' after a 'rmmod pcmcia' gives an oops because the pcmcia_device is no unregisterd from the driver core.

I just Installed at the moment debian this build on two desktop boxes! Booth Boxes having ATI Graphic Cards Box 1 Radeon 9550, Box 2 Radeon X300, same problems with openGL 2.0 and 3D accelerator!

Having fun Guy's :wink:
openSuSE 10.2
Debian etch
Arch Linux 0.8 (Voodoo)
you never walk alone :)
User avatar
JaDa
 
Posts: 16
Joined: 2006-10-15 19:47
Location: Sun City, CA

Postby thamarok » 2007-03-18 18:40

I guess they won't add automatic ATI driver installation because it is proprietary and not open-source.. if this is false, please correct me.
thamarok
 

Postby rickh » 2007-03-18 18:54

I have installed Etch on many ATI boxes. It always correctly installs the Xorg ati driver. That "free" driver, of course, does not include hardware rendering, but I have had no problems at all getting the proprietary drivers from non-free installed and working. Ditto for wireless drivers.

Of course proprietary software does not install on the initial installation. This is Debian.
Debian-Lenny/Sid 32/64
Desktop: Generic Core 2 Duo, EVGA 680i, Nvidia
Laptop: Generic Intel SIS/AC97
User avatar
rickh
 
Posts: 3473
Joined: 2006-06-29 02:13
Location: Albuquerque, NM USA

Postby JaDa » 2007-03-18 21:01

rickh wrote:I have installed Etch on many ATI boxes. It always correctly installs the Xorg ati driver. That "free" driver, of course, does not include hardware rendering, but I have had no problems at all getting the proprietary drivers from non-free installed and working. Ditto for wireless drivers.

Of course proprietary software does not install on the initial installation. This is Debian.


Try the game GL-117 or Planet Penguin Racer, start KDE desktop and the the screensaver GL Euphoria, or Install just Google Earth!

I don't mind about Install the driver later from non-free packages, but this packages doesn't work! If you install then, you will get
Code: Select all
fglrxinfo
OpenGL version string: Mesa .....!


Ths is not correct and need to done before the final release!

Example!
This is correct
Code: Select all
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X300/X550/X1050 Series
OpenGL version string: 2.0.6334 (8.34.8)
openSuSE 10.2
Debian etch
Arch Linux 0.8 (Voodoo)
you never walk alone :)
User avatar
JaDa
 
Posts: 16
Joined: 2006-10-15 19:47
Location: Sun City, CA

Postby rickh » 2007-03-18 23:04

I don't mind about Install the driver later from non-free packages, but this packages doesn't work!
I may be missing your point, but as far as I know the packages in Debian non-free work fine. That's where I got mine, and all the GL screensavers, Google Earth and the few GL games I have installed work fine. They have on every computer I've set up.
Code: Select all
debian:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON XPRESS Series Generic
OpenGL version string: 2.0.6174 (8.31.5)
Debian-Lenny/Sid 32/64
Desktop: Generic Core 2 Duo, EVGA 680i, Nvidia
Laptop: Generic Intel SIS/AC97
User avatar
rickh
 
Posts: 3473
Joined: 2006-06-29 02:13
Location: Albuquerque, NM USA

Postby Metalqga » 2007-03-26 15:40

When using the proprietary ati drivers Etch cannot run Opera web browser; Totem mplayer won't run either.. the program crashes instantly. It might have problems with other software but I haven't tested extensively.

here's what opera says:
Code: Select all
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
Floating point exception

When I run opera using the free drivers I get only the first two lines but runs fine.
The problem is that the free driver cannot operate the tv out; and it's much slower when playing 3d games that's why I want to use the proprietary one.
-using ati radeon 9550 The system is fully updated using kernel 2.6.18-k7
I hope this issue gets resolved soon.

edit:
fglrxinfo output:
home:/home/metalqga# fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
My only friend is me!
User avatar
Metalqga
 
Posts: 14
Joined: 2007-02-09 23:51
Location: Varna, Bulgaria

Postby rickh » 2007-03-26 19:55

edit:
fglrxinfo output:
home:/home/metalqga# fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
What that's telling you is that your problem is operator error, not OS bugs. Install fglrx correctly, and your output will look more like this:
Code: Select all
debian64:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON XPRESS Series Generic
OpenGL version string: 2.0.6174 (8.31.5)
Debian-Lenny/Sid 32/64
Desktop: Generic Core 2 Duo, EVGA 680i, Nvidia
Laptop: Generic Intel SIS/AC97
User avatar
rickh
 
Posts: 3473
Joined: 2006-06-29 02:13
Location: Albuquerque, NM USA

Postby Metalqga » 2007-03-27 10:48

Used that howto: http://technowizah.com/2006/10/debian-h ... ivers.html
$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9550/X1050 Series
OpenGL version string: 2.0.6334 (8.34.8)

the problems are still there.

The only workable solution I have come to is when I need to browse the internet: use the free 'ati' drivers, when I need the tv-out/good 3d acceleration: switch to 'fglrx' but this requires at least one logout/restart of x.
My only friend is me!
User avatar
Metalqga
 
Posts: 14
Joined: 2007-02-09 23:51
Location: Varna, Bulgaria

Postby Metalqga » 2007-03-29 11:02

Tried the latest 8.35.5 drivers the same thing.
even the amd catalyst control center refuses to load:

home:/home/metalqga# amdcccle
Floating point exception

Am I the only unfortunate soul using ati 9550 and debian etch here?

Edit:
Code: Select all
Section "Files"
   FontPath   "/usr/share/fonts/X11/misc"
   FontPath   "/usr/X11R6/lib/X11/fonts/misc"
   FontPath   "/usr/share/fonts/X11/cyrillic"
   FontPath   "/usr/X11R6/lib/X11/fonts/cyrillic"
   FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/Type1"
   FontPath   "/usr/X11R6/lib/X11/fonts/Type1"
   FontPath   "/usr/share/fonts/X11/100dpi"
   FontPath   "/usr/X11R6/lib/X11/fonts/100dpi"
   FontPath   "/usr/share/fonts/X11/75dpi"
   FontPath   "/usr/X11R6/lib/X11/fonts/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "i2c"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "vbe"
   Load   "Glcore"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "Device"
   Identifier   "ATI Technologies Inc RV350 AS [Radeon 9550]"
   Driver      "fglrx"
   BusID      "PCI:2:0:0"
   Option       "EnableMonitor" "crt1,tv"
   Option       "TVStandard" "VIDEO"
   Option       "DesktopSetup" "clone"
   Option       "ForceMonitors" "tv"
   Option       "TVFormat" "PAL-B"
EndSection

Section "Monitor"
   Identifier   "SyncMaster"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "ATI Technologies Inc RV350 AS [Radeon 9550]"
   Monitor      "SyncMaster"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480"
   EndSubSection
EndSection


Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
EndSection

Section "DRI"
   Mode   0666
EndSection

Section "Extensions"
        Option  "Composite" "Disable"
   EndSection

My only friend is me!
User avatar
Metalqga
 
Posts: 14
Joined: 2007-02-09 23:51
Location: Varna, Bulgaria

Postby Metalqga » 2007-03-30 19:49

I've solved that one.
One thing I changed was the AGP aperature size (128) in the bios settings and Option "AGPSize" "128" in xorg.conf.
I hope that issue doesn't come up again.

edit
It stopped working again, after a reboot. I have no idea how to make it work again. I'll stop trying.
My only friend is me!
User avatar
Metalqga
 
Posts: 14
Joined: 2007-02-09 23:51
Location: Varna, Bulgaria

Postby pettern » 2007-04-19 15:42

I have the same problem with radeon 9600 pro.
I get the same error with Opera and i get floating point exception when i run kate, krusader, ktorrent, kwrite and lastfm. Also the font is really big in aMSN.

All of those problems goes away when I go back to the xorg ATI driver.

I tried with both the fglrx driver form ATI.com and the one from debian. Was the same problem with both.
pettern
 
Posts: 3
Joined: 2007-04-19 15:28

Postby Spontan » 2007-04-26 14:53

I'm not exactly a genious, but when installed the ati drivers on my etch using --buildpkg Debian/etch is always jacked up. I have had much better success using --buildpkg Debian/testing

Not too sure of the difference, but It worked. Also using the ati 36 drivers now

Running an ATI 9600 pro as well

fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI RADEON 9600 Series
OpenGL version string: 2.0.6458 (8.36.5)

Used http://wiki.cchtml.com/index.php/Debian ... tion_Guide
Following Method #2
Spontan
 
Posts: 14
Joined: 2007-04-16 18:10

ati driver

Postby rabitmoon » 2007-05-11 14:21

If you have already installed the ati drivers and ran ATI --initial and still getting the mesa string your problem is probably still having the radeon module loaded in the kernel.
Exit out of X.
Log into the console as root.
/etc/init.d/gdm stop
modprobe -r radeon
modprobe fglrx
/etc/init.d/gdm start.
this is what worked for me hope you have the same luck
rabitmoon
 
Posts: 1
Joined: 2007-05-11 14:17

A step forward, two backwards?

Postby Metalqga » 2007-07-20 14:16

Linux Proprietary Driver 8.39.4
ISSUES RESOLVED: (1) Fixed kernel module build on kernel version 2.6.22. (2) Fixed floating-point exception when starting AMD CCC-LE in certain configurations. (3) Fixed incorrect colors when playing videos in I420 color format. (4) Fixed a bug when running aticonfig --initial inside X but without the fglrx driver. aticonfig no longer crashes and no longer removes xorg.conf in this scenario.

Unfortunately the very same driver was recalled a few hours after release.
My only friend is me!
User avatar
Metalqga
 
Posts: 14
Joined: 2007-02-09 23:51
Location: Varna, Bulgaria

Postby Metalqga » 2007-07-23 06:24

Installed Linux Proprietary Driver 8.39.4 yesterday using this method:
======================================================
fakeroot sh ati-driver-installer-8.39.4-x86.x86_64.run --buildpkg Debian/etch
sudo dpkg -i fglrx-driver_8.39.4_i386.deb
sudo dpkg -i fglrx-kernel-src_8.39.4_i386.deb
apt-get install linux-headers-$(uname -r)
cd /usr/src
sudo m-a prepare
sudo m-a a-i fglrx
=========================================================
I don't get the famous beta-test logo, and have no problems runnig programs, but at the time I turn TV-OUT on with the options in /etc/X11/xorg.conf
=========================================================
Option "EnableMonitor" "crt1,tv"
Option "TVStandard" "VIDEO"
Option "DesktopSetup" "clone"
Option "ForceMonitors" "tv"
Option "TVFormat" "PAL-B"
==========================================================
I get the same floating point exception error for most of the programs. I hope the fglrx developers check this forum....
My only friend is me!
User avatar
Metalqga
 
Posts: 14
Joined: 2007-02-09 23:51
Location: Varna, Bulgaria

Next

Return to Debian Development

Who is online

Users browsing this forum: No registered users and 1 guest

fashionable