Page 1 of 1

Buster - dhcp init service

PostPosted: 2019-05-03 21:05
by shep
This is a heads up. I'm running Buster amd64 on an HP Steam14 Netbook and was using wicd-gtk. After a recent update, the Stream14 lost it's dhcp connection. My other Buster system has a static NIC connection and continued to work fine.

On the Stream14, I tried connecting manually and received a warning about not getting an IP address. The Stream 14 does not have a NIC, and I don't own a usb NIC, so I set a static IP to get back on my network. I think this had something to do with the recent systemd update. Once I was back on, I fiddled with nw-tray, straight /etc/network/interfaces dhcp connection and swapped out dhclient for dhcpcd. No dhclient/dhcpcd based connection would work. I can't imagine this could go too long without an upstream fix but if you are wifi dependent, you may want to hold off on updates until it is fixed.

Re: Buster - dhcp init service

PostPosted: 2019-05-03 21:39
by Head_on_a_Stick
shep wrote:After a recent update, the Stream14 lost it's dhcp connection

Is there anything in the systemd journal about the failure?

I have no problems with DHCP in my buster system:
Code: Select all
shinken:~$ apt policy systemd
systemd:
  Installed: 241-3
  Candidate: 241-3
  Version table:
 *** 241-3 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
shinken:~$

Perhaps try systemd-networkd, that's what I'm using to connect.

It even offers automatic fallover from wired to wireless, just like trunk(4).

Guide here: https://wiki.archlinux.org/index.php/Systemd-networkd

Re: Buster - dhcp init service

PostPosted: 2019-05-04 13:42
by shep
Thanks for the guidance. Turned out to be an OpenWRT router problem - an extra space in my list of DNS servers. Removed the space, restarted the router and all is good. :oops: