Page 1 of 1

Call me old-fashioned...

PostPosted: 2019-05-27 09:39
by hkoster1
...but I like to decide for myself when to upgrade packages (with Aptitude) and whether or not to put my computer to sleep or hibernation. Disabling the related systemd entries and packages in Buster (with Gnome) takes too much effort in my view, but I've finally managed to do it.
Now, there's one puzzle left when booting Buster: almost immediately there's a boot message saying "Restarting from hibernation", which even appears when I'm just rebooting and when the system clearly has not been hibernating. Not a release-critical bug, but an annoyance nonetheless. How would I get rid of that message? FWIW, I'm running Buster in a VMware Fusion VM.

Re: Call me old-fashioned...

PostPosted: 2019-05-30 10:48
by dotlj
...but I like to decide for myself when to upgrade packages (with Aptitude) and whether or not to put my computer to sleep or hibernation.


+1 me too.
I use
Code: Select all
apt update
apt dist-upgrade

to do the updates, I have removed the unattended-upgrades package.

I use the system settings to change power management not to hibernate or suspend, to do nothing when I close the lid and to power off when I press the power button.
Debian allows users to really make choices and set up their systems the way they want them.
I'm using an SSD, so start up and shut down are fast.