Apparent bug in the installation of lenny

News and discussion about development of the Debian OS itself

Apparent bug in the installation of lenny

Postby the dsc » 2008-04-10 02:01

During the installation process, there's the stage where we set how the partitions are going to be used.

I already had (and still have) another linux installation. Overall, the things were like this during the partition setting

hda - going to be Lenny's root

hdb1 - pre-existing Etch root - not to be used by Lenny
hdb2 - /home for Etch, set to be /home for Lenny too
hdb3 - swap partition for Etch, set to be swap for Lenny too.


hdb1, hdb2, and hdb3 were listed as partitions #1, #2 and #3, respectively. However, when I was to advance to the next stage, there's a part where the system asks for confirmation of these partition settings. Despite of them being set this way I described above, the installation was saying that partition #1 of hdb was going to be Lenny's swap, instead of partition #3.

I checked it many times. At the first time I was at the graphical installation which I decided to take a look, I had never seen it before on Debian. I thought it could be a bug of this mode of installation, then I canceled and went to the text installation, but the same thing happened.

I don't know if it would really install the swap over the root partition of the other installation, I decided to not take the risk, then I just solved that by creating a small swap partition on hda.


It hapenned with a netinst version of the installation for amd64, if that matters.

I'm glad if it helps :)
the dsc
 
Posts: 100
Joined: 2007-08-18 22:14

Postby Japser » 2008-04-10 12:48

That sounds quite serious, you might post this on

http://lists.debian.org/debian-boot/

--Japser.
Japser
 
Posts: 173
Joined: 2008-02-13 13:21

Re: Apparent bug in the installation of lenny

Postby stream304 » 2008-04-17 18:32

the dsc wrote:I already had (and still have) another linux installation. Overall, the things were like this during the partition setting


You aren't the only one. It was happening with Ubuntu Hardy-Beta as well, although it seems to be fixed on my latest Hardy install. (Whether it is a bug-fix or a regression, I do not know) I also have a dual-install, one internally, and one on an external firewire drive.

See this for more:
viewtopic.php?t=24900

In Lenny, I had to find the UUID of the root partition, and specify it at boot time during the second-stage boot: prompt like this: (your UUID will be different obviously)

Code: Select all
Linux root=UUID=ebad84c1-72e1-448a-abc7-4610f19f7000


Specifying the UUID in my /etc/fstab didn't work - although I am using yaboot instead of grub, but the effects were similar.

What did work, was to specify that both of my drives were /dev/sda, which in the case of the firewire was definitely /dev/sdb, but that is the ugly workaround. In ppc, I am able to select the drive to actually boot from in OpenFirmware - even though both are listed as the first drive, ie /dev/sda.

This problem doesn't get seen by single-drive install apparently.
Apple G5 iMac - Lenny
stream304
 
Posts: 109
Joined: 2008-03-14 10:47

Similar problems with Ubuntu 8.04 install.

Postby djchandler » 2008-05-06 01:30

I ran into a great deal of trouble with the Hardy install. Since I initially had no problem with an update from Gutsy I decided to start from scratch with this system after a motherboard swap (bad DIMM slot) and wiped my hard disk for a fresh install. It's fortunate that this occurred on my test system first. As an aside, I don't dual boot thanks to the luxury of having 3 computers in the house for only 2 people.

Using the alternate install CD was not doable. I could not get the hard drives to be recognized. Using the Live CD got me to a desktop, but unable to install because there was no hard drive detected.

For the time being I'm staying clear of Ubuntu. Goodbye Gutsy even. Etch installed to the same hardware set with no problems. Hardware is as follows:

Athlon64 2800+
1 gb generic CAS 3 RAM (2x512mb)
NForce 3-250 chipset
WD 160 gb eIDE HD (SATA disabled in BIOS)
Chaintech Nvidia FX 5500 256 mb graphics card (AGP 8x)

Not the greatest hardware in the world, but it works just fine with Etch. The motherboard is an Asrock K8Upgrade-NF3. It uses an AMI BIOS. I'm very suspicious of the BIOS. This board does take a really long time to boot. But the previous motherboard took a long time to boot also. So it could be the hard drive. An Ubuntu Forum user had a similar problem with a 320 gb Western Digital hard drive.

Both the installer and partition editor (gparted on the Live CD) couldn't find any hard drive. A failed boot attempt in recovery mode after a fresh Gutsy install and subsequent Hardy upgrade yielded an error message that indicated IDE port 0 was too slow, and then promptly halted booting, i.e., the system hung. So I wiped the hard drive and started over with Etch

BTW, this problem came up with both the AMD64 and the i386 versions of the Ubuntu 8.04 distribution.
User avatar
djchandler
 
Posts: 1
Joined: 2008-05-05 00:44
Location: Kansas City Metro


Return to Debian Development

Who is online

Users browsing this forum: No registered users and 1 guest

fashionable