kde4 from experimental - dependicies

News and discussion about development of the Debian OS itself

kde4 from experimental - dependicies

Postby daris » 2008-07-27 10:11

Code: Select all
apt-get install -t experimental kdebase-workspace-dev                                                           
Reading package lists... Done                                                                                           
Building dependency tree                                                                                                 
Reading state information... Done                                                                                       
The following packages were automatically installed and are no longer required:                                         
  libboost-regex1.34.1 libicu38 liblockdev1 libboost-program-options1.34.1 mesa-common-dev libttf2 schroot-common       
  libgl1-mesa-dev libboost-filesystem1.34.1
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  akonadi-server bsd-mailx exim4 exim4-base exim4-config exim4-daemon-light kdepimlibs-data kdepimlibs5 kdepimlibs5-dev
  libakonadiprivate0 libakonadiprivate1 libbluetooth-dev libbluetooth2 libcapseo-dev libcaptury-dev libdbd-mysql-perl
  libdbi-perl libglib2.0-dev libgpg-error-dev libgpgme11 libgpgme11-dev libhtml-template-perl libldap2-dev
  libmysqlclient16 libnet-daemon-perl libnm-util-dev libnm-util0 libpam0g-dev libplasma-dev libplrpc-perl libpth-dev
  libpth20 libqimageblitz-dev libraw1394-dev libsasl2-dev libsasl2-modules libsensors-dev libstrigiqtdbusclient-dev
  libusb-dev libxcomposite-dev libxdamage-dev libxext-dev libxfixes-dev libxkbfile-dev libxklavier12-dev libxml2-dev
  libxrandr-dev libxrender-dev libxxf86misc-dev mailx mysql-client-5.1 mysql-server mysql-server-5.1
  network-manager-dev x11proto-composite-dev x11proto-damage-dev x11proto-fixes-dev x11proto-randr-dev
  x11proto-render-dev x11proto-xext-dev x11proto-xf86misc-dev
Suggested packages:
  mail-reader eximon4 exim4-doc-html exim4-doc-info libmail-spf-query-perl swaks dbishell libglib2.0-doc gpgsm
  libipc-sharedcache-perl libcompress-zlib-perl libraw1394-doc libsasl2-modules-otp libsasl2-modules-ldap
  libsasl2-modules-sql libsasl2-modules-gssapi-mit libsasl2-modules-gssapi-heimdal tinyca
The following NEW packages will be installed:
  akonadi-server bsd-mailx exim4 exim4-base exim4-config exim4-daemon-light kdebase-workspace-dev kdepimlibs-data
  kdepimlibs5 kdepimlibs5-dev libakonadiprivate0 libakonadiprivate1 libbluetooth-dev libbluetooth2 libcapseo-dev
  libcaptury-dev libdbd-mysql-perl libdbi-perl libglib2.0-dev libgpg-error-dev libgpgme11 libgpgme11-dev
  libhtml-template-perl libldap2-dev libmysqlclient16 libnet-daemon-perl libnm-util-dev libnm-util0 libpam0g-dev
  libplasma-dev libplrpc-perl libpth-dev libpth20 libqimageblitz-dev libraw1394-dev libsasl2-dev libsasl2-modules
  libsensors-dev libstrigiqtdbusclient-dev libusb-dev libxcomposite-dev libxdamage-dev libxext-dev libxfixes-dev
  libxkbfile-dev libxklavier12-dev libxml2-dev libxrandr-dev libxrender-dev libxxf86misc-dev mailx mysql-client-5.1
  mysql-server mysql-server-5.1 network-manager-dev x11proto-composite-dev x11proto-damage-dev x11proto-fixes-dev
  x11proto-randr-dev x11proto-render-dev x11proto-xext-dev x11proto-xf86misc-dev
0 upgraded, 62 newly installed, 0 to remove and 41 not upgraded.
Need to get 1194kB/48,1MB of archives.
After this operation, 123MB of additional disk space will be used.
Do you want to continue [Y/n]?

Why kdebase-workspace-dev needs exim4, mysql-server and lots of other dependicies?

Same for kdeplasma-addons:
Code: Select all
root:~# apt-get install kdeplasma-addons
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libboost-regex1.34.1 x11proto-kb-dev libicu38 liblockdev1 libboost-program-options1.34.1 mesa-common-dev libxdmcp-dev
  xtrans-dev libttf2 x11proto-core-dev schroot-common x11proto-input-dev libpthread-stubs0-dev libxau-dev
  libpthread-stubs0 libgl1-mesa-dev libboost-filesystem1.34.1 libx11-dev libxcb-xlib0-dev libxcb1-dev
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  akonadi-server bsd-mailx exim4 exim4-base exim4-config exim4-daemon-light kdepimlibs-data kdepimlibs5
  kdeplasma-addons-data kdeplasma-addons-libs4 libakonadiprivate0 libakonadiprivate1 libdbd-mysql-perl libdbi-perl
  libgpgme11 libhtml-template-perl libnet-daemon-perl libplrpc-perl libpth20 libsasl2-modules libterm-readkey-perl
  mailx mysql-client-5.0 mysql-server mysql-server-5.0
Suggested packages:
  mail-reader eximon4 exim4-doc-html exim4-doc-info libmail-spf-query-perl swaks dbishell gpgsm libipc-sharedcache-perl
  libcompress-zlib-perl libsasl2-modules-otp libsasl2-modules-ldap libsasl2-modules-sql libsasl2-modules-gssapi-mit
  libsasl2-modules-gssapi-heimdal tinyca
The following NEW packages will be installed:
  akonadi-server bsd-mailx exim4 exim4-base exim4-config exim4-daemon-light kdepimlibs-data kdepimlibs5
  kdeplasma-addons kdeplasma-addons-data kdeplasma-addons-libs4 libakonadiprivate0 libakonadiprivate1 libdbd-mysql-perl
  libdbi-perl libgpgme11 libhtml-template-perl libnet-daemon-perl libplrpc-perl libpth20 libsasl2-modules
  libterm-readkey-perl mailx mysql-client-5.0 mysql-server mysql-server-5.0
0 upgraded, 26 newly installed, 0 to remove and 0 not upgraded.
Need to get 38,6MB/45,7MB of archives.
After this operation, 130MB of additional disk space will be used.
Do you want to continue [Y/n]?


Does plasma-addons really need those dependicies?

I installed debian lenny (netinstall, only base system) using unetbootin, upgraded to sid and installed kde 4.0.98 from experimental.


edit: i ran apt-get update and now everything is ok
daris
 
Posts: 11
Joined: 2007-07-12 08:05
Location: Poland

Postby Jackiebrown » 2008-11-23 04:55

It doesn't. It's trying to install the recommends
User avatar
Jackiebrown
 
Posts: 1276
Joined: 2007-01-02 04:46
Location: San Antonio, TX

Postby allywide » 2008-12-05 09:24

i tried it . but it semms it dosen't work :cry: can some body tell me what is going on
bags are my favorite~
allywide
 
Posts: 3
Joined: 2008-12-03 13:19
Location: vdc

Re: kde4 from experimental - dependicies

Postby L_V » 2009-01-30 09:40

daris wrote:Why kdebase-workspace-dev needs exim4, mysql-server and lots of other dependicies?
You should try
aptitude install -t experimental kdebase-workspace-dev -R

or add this line to /etc/apt/apt.conf
APT::Install-Recommends "false";
L_V
 
Posts: 1047
Joined: 2007-03-19 09:04

Postby infinitycircuit » 2009-01-30 22:24

Always use aptitude when grabbing stuff from experimental it's about 10x smarter.
I am currently a Debian Maintainer. I am also in the New Maintainers' Queue.
infinitycircuit
 
Posts: 1137
Joined: 2007-07-24 03:31
Location: California


Return to Debian Development

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable