Page 1 of 1

Removing bloat from Debian?

PostPosted: 2004-10-03 13:42
by Frank Bauer
As we are nearing Sarge release and discussing if it will fit on one double-sided DVD, I made a look at Sarge archive.

Why do we have to have gcc272, gcc295, gcc3.2, gcc3.3, gcc3.4? I understand gcc272 and gcc295 are 'good old reliable buddies', but three verions og gcc3?

Another example: automake 1.4, 1.6, 1.7, 1.8, 1.9???

gstreamer and its pile of plugins: 0.6, 0.8.

Isn't there time to reconciliate these versions to just one, sometimes two working versions?

Best Regards
Frank Bauer

PostPosted: 2004-10-03 15:39
by peschmae
Maybe, but for gcc, some apps only can be compiled with one version (e.g. openoffice afaik only works with gcc 3.2).
I don't know about gcc 2.7.2 and who needs that though.

Same for automake - some apps require 1.4, others 1.9 yet others don't mind the version...

Peschmä

PostPosted: 2004-10-03 21:31
by startx
well, as far as i see, you need an older gcc to compile a newer version of gcc. for example, to compile any gcc-3.x you will need some former gcc-3.x.
same to the 2.9 serias. i admit i am just guessing, but this could be a reason for keeping several versions ....

@peschmae: hi, know you, eh?

PostPosted: 2004-10-03 23:42
by Jeroen
startx wrote:well, as far as i see, you need an older gcc to compile a newer version of gcc. for example, to compile any gcc-3.x you will need some former gcc-3.x.
same to the 2.9 serias. i admit i am just guessing, but this could be a reason for keeping several versions ....


No, the only requirement is that packages need to be rebuildable. It's allowed to have gcc that can only be rebuilded with itself. For example, ghc6 itself is also only buildable if you have a working ghc first.

The rationale is that buildable is to satisfy DFSG, one needs to be able to make changes to a package. That you cannot bootstrap it easily, is another point, and not required.