The update on Feb 10 2009 made my system extremely unstable

News and discussion about development of the Debian OS itself

The update on Feb 10 2009 made my system extremely unstable

Postby Fede.Campana » 2009-02-11 22:10

I installed the update on Feb 10 and since most of times Debian crashes (freezes, nothing moves) after 5 to 15 minutes of normal use. Sometimes while on Iceweasel, sometimes when modelling in Blender 3D.

Is there any way I can go back to the version before Feb 10 2009?

Please Help! :o)
Fede.Campana
 
Posts: 3
Joined: 2009-02-11 22:03

Postby mike102282 » 2009-02-11 22:18

I don't think there is, however I seriously doubt that the updated did this since it was mostly just security fixes.
Debian Linux Geek
User avatar
mike102282
 
Posts: 196
Joined: 2007-08-05 17:13
Location: Springfield, OH

Postby pcalvert » 2009-02-12 01:13

I am running Etch.

Code: Select all
# aptitude upgrade -s
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
Building tag database... Done
The following packages will be upgraded:
  gnumeric gnumeric-common libc6 libc6-dev libc6-i686 libgnutls13
  linux-image-2.6.18-6-686 locales
8 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 36.6MB of archives. After unpacking 1524kB will be freed.
Do you want to continue? [Y/n/?]


It looks like a fairly major upgrade. That's why I haven't upgraded yet. I hesitate to upgrade if aptitude wants to upgrade a bunch of things and I don't know why.

I am subscribed to the debian-security-announce mailing list. Of the above packages, I have only received a notice about one of them-- libgnutls13.

Phil
“Property is the fruit of labor; property is desirable; it is a positive good
in the world. That some should be rich shows that others may become
rich, and hence is just encouragement to industry and enterprise.”
— Abraham Lincoln
pcalvert
 
Posts: 1845
Joined: 2006-04-21 11:19
Location: Sol Sector

Postby pcalvert » 2009-02-12 01:58

I just had some thoughts about your problem. Are you using a standard Debian kernel, or did you compile the kernel yourself? What kind of video card is in your computer, and did you have to do anything special to get it working?

Phil
“Property is the fruit of labor; property is desirable; it is a positive good
in the world. That some should be rich shows that others may become
rich, and hence is just encouragement to industry and enterprise.”
— Abraham Lincoln
pcalvert
 
Posts: 1845
Joined: 2006-04-21 11:19
Location: Sol Sector

Postby Fede.Campana » 2009-02-12 10:10

pcalvert wrote:I just had some thoughts about your problem. Are you using a standard Debian kernel, or did you compile the kernel yourself? What kind of video card is in your computer, and did you have to do anything special to get it working?

Phil


Hi Phil,

Thanks for the kind reply. I am using a standard Debian Kernel (I am beginner, so no self-compiling yet ;o).

The video card has always been somewhat of a problem in my PC, so maybe you are asking the right question. It is a "Radeon 9500 120M DDR VO DVI-I" (written on barcode sticker) and says "powered by ATI" on its fan. I didn't do anything special to get working, it was recognised automatically when I installed Debian.

My PC is 2005, so perhaps it is simply too old for the latest OSs? Coming from WinXP, in January I wanted to switch to Linux so I first tried Ubuntu, which froze always in 5-15 minutes of installation from live CD. Then I tried OpenSUSE, which worked reasonably OK but when opening too many windows (say a OpenOffice Writer, Firefox and something else) it froze. Then I moved to Debian Etch which worked perfectly, never froze, until the update I installed on Feb 10. Now it always freezes (I am writing from Puppy Linux booted from CD).

I have two ports for the monitor plug, one from the video card and one directly from the mother board. I will now try removing the video card and plugging directly on mother to see what happens.
Fede.Campana
 
Posts: 3
Joined: 2009-02-11 22:03

Postby emariz » 2009-02-12 16:18

If the kernel was updated you can boot the previous ones by pressing ESC when loading GRUB. Use an older kernel till you know what causes the constant freezes.
Search for related problems in the Debian Bug list. As your machine is not new, there's a high chance that other users have the same issues.
emariz
 
Posts: 2916
Joined: 2008-10-17 07:59

Postby Fede.Campana » 2009-02-12 19:51

Thanks for the ESC-tip and the Debian Bug list.

What I did right is simply remove the video card. Now Debian -with the new update- runs perfectly. I don't seem to need the video card for the moment, since Blender 3D (the most graphic-demanding program I use) works perfectly and shows very smooth movements. Also, my only son is 3 so by the time he starts playing flashy games we will probably have a new computer. :o)

Fede
Fede.Campana
 
Posts: 3
Joined: 2009-02-11 22:03

Postby jheaton5 » 2009-02-12 21:21

Tell us what your video card is. Perhaps someone here has experience with that card.
User avatar
jheaton5
 
Posts: 1489
Joined: 2008-08-20 01:40
Location: Newnan, GA, USA

Postby bugsbunny » 2009-02-12 21:23

jheaton5 wrote:Tell us what your video card is. Perhaps someone here has experience with that card.


He answered that a few posts up;
It is a "Radeon 9500 120M DDR VO DVI-I"
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04


Return to Debian Development

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable