debian wacom tablet not being recognized

Here you can discuss every aspect of Debian. Note: not for support requests!

debian wacom tablet not being recognized

Postby blubee » 2016-02-16 05:16

I think I borked my wacom xorg configuration. I recently updated to nvidia drivers so that it would disable flipping which causes screen tearing if recording the screen and it overwrote my default xorg configuration to this:

Code: Select all
 
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 340.46  (buildd@brahms)  Tue Oct  7 08:00:32 UTC 2014
   
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
   
    Section "Files"
    EndSection
   
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
   
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
   
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
   
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
   
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "NoLogo" "True"
        Option         "NoFlip" "True"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection



lsusb

Code: Select all
    blubee@hn:~$ lsusb | grep Wacom
    Bus 001 Device 006: ID 056a:0315 Wacom Co., Ltd

    xsetwacom --list
    Wacom Intuos Pro M Pen stylus      id: 10   type: STYLUS   
    Wacom Intuos Pro M Pad pad         id: 11   type: PAD       
    Wacom Intuos Pro M Finger touch    id: 12   type: TOUCH     
    Wacom Intuos Pro M Pen eraser      id: 15   type: ERASER   
    Wacom Intuos Pro M Pen cursor      id: 16   type: CURSOR 


here's an image when I open up the gnome wacom settings utility.
http://i.stack.imgur.com/GIqT8.png

How can I update my xorg to enable my wacom to what is shown in the xsetwacom --list.

Anyone can help me figure out what's going on?
blubee
 
Posts: 10
Joined: 2015-12-25 14:12

Re: debian wacom tablet not being recognized

Postby blubee » 2016-02-16 21:57

there's no one around who has any experience with wacom tablets on debian?
blubee
 
Posts: 10
Joined: 2015-12-25 14:12

Re: debian wacom tablet not being recognized

Postby GarryRicketson » 2016-02-17 03:39

Sorry, I honestly do not know, my graphics tablet is a different kind and I have never had any problems, also "nvidia drivers" is not a factor on my computer.
How ever I did do this, I put the question into startpage, that is a search engine,..
How can I update my xorg to enable my wacom to what is shown in the xsetwacom --list
I have not looked thru all of the many results, so I do not know if any will help you.
But that is something you can do, in the meantime while waiting for a answer, you
might even find something, there seem to be a lot of results.
There are some topics on the forum invloving Wacom tablets:
http://forums.debian.net/search.php?st=0&sk=t&sd=d&sr=posts&keywords=wacom+tablet
I do not know if any are similar to your problem, again that is something you can do, browse through them, there might be something.
User avatar
GarryRicketson
 
Posts: 4964
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: debian wacom tablet not being recognized

Postby blubee » 2016-02-29 16:37

After a whole lot of testing I found out that it's the kernel versions.

Originally i had the stock kernel installed but my mouse, logitech mx master constantly disconnects after any inactivity. Updating to kernel
linux-image-4.3.0-0.bpo.1-amd64 linux-headers-4.3.0-0.bpo.1-amd64

the mouse works but now the wacom tablet settings are gone. The tablet still works as a basic mouse but none of the controls are there.

Is there any info on these kernels causing issues with wacom tablets?
blubee
 
Posts: 10
Joined: 2015-12-25 14:12


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable