Problem connecting to TightVNCserver

Here you can discuss every aspect of Debian. Note: not for support requests!

Problem connecting to TightVNCserver

Postby rovernut » 2016-05-30 13:10

I'm getting an error message when connecting to my Acer laptop running Debian 8 from my Thinkpad running Debian 8.
Here's a screen shot I get as soon as I connect:
Image

On the target machine I've tried starting the VNC server three ways
vncserver :1 -geometry 1920x1080 -depth 24
vncserver :1
tightvncserver:1

The vnc log file shows:
**********************************************************************
228/05/16 07:16:06 Xvnc version TightVNC-1.3.9
28/05/16 07:16:06 Copyright (C) 2000-2007 TightVNC Group
28/05/16 07:16:06 Copyright (C) 1999 AT&T Laboratories Cambridge
28/05/16 07:16:06 All Rights Reserved.
28/05/16 07:16:06 See http://www.tightvnc.com/ for information on TightVNC
28/05/16 07:16:06 Desktop name 'X' (hostname:1)
28/05/16 07:16:06 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
28/05/16 07:16:06 Listening for VNC connections on TCP port 5901
xrdb: No such file or directory
xrdb: can't open file '/home/user/.Xresources'

28/05/16 07:16:16 Got connection from client 10.80.5.1
28/05/16 07:16:16 Using protocol version 3.8
28/05/16 07:16:16 Enabling TightVNC protocol extensions
28/05/16 07:16:21 Full-control authentication passed by 10.80.5.1
28/05/16 07:16:21 Pixel format for client 10.80.5.1
28/05/16 07:16:21 32 bpp, depth 24, little endian
28/05/16 07:16:21 true colour: max r 255 g 255 b 255, shift r 16 g 8 b 0
28/05/16 07:16:21 no translation needed
28/05/16 07:16:21 Using tight encoding for client 10.80.5.1
28/05/16 07:16:21 Using compression level 1 for client 10.80.5.1
28/05/16 07:16:21 Using image quality level 6 for client 10.80.5.1
28/05/16 07:16:21 Enabling X-style cursor updates for client 10.80.5.1
28/05/16 07:16:21 Enabling cursor position updates for client 10.80.5.1
28/05/16 07:16:21 Enabling LastRect protocol extension for client 10.80.5.1
28/05/16 07:16:27 Client 10.80.5.1 gone
28/05/16 07:16:27 Statistics:
28/05/16 07:16:27 key events received 1, pointer events 103
28/05/16 07:16:27 framebuffer updates 6, rectangles 79, bytes 12940
28/05/16 07:16:27 LastRect markers 4, bytes 48
28/05/16 07:16:27 cursor shape updates 1, bytes 82
28/05/16 07:16:27 cursor position updates 1, bytes 12
28/05/16 07:16:27 tight rectangles 73, bytes 12798
28/05/16 07:16:27 raw bytes equivalent 6291528, compression ratio 491.602438
***************************************************************************
I created /home/user/.Xresources but the log file is the same other than no longer that file not found.

I have a raspberry that I have no issues connecting to from my Thinkpad.
Here're the details on the Acer:
**********************************************************************
Code: Select all
System:    Host: hostname Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4) Console: tty 1 dm: kdm
           Distro: Debian GNU/Linux 8
Machine:   Mobo: Acer model: Aspire 5534 v: V1.12 serial: LXPXXXXXXXXXXXXXXXXXXX
           Bios: Acer v: V1.12 date: 09/03/2009
CPU:       Dual core AMD Athlon X2 L310 (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 svm) bmips: 4787
           Clock Speeds: 1: 1196 MHz 2: 1196 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS780M [Mobility Radeon HD 3200]
           bus-ID: 01:05.0 chip-ID: 1002:9612
           Display Server: X.org 1.16.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           tty size: 109x33 Advanced Data: N/A for root out of X
Audio:     Card Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2 chip-ID: 1002:4383
           Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 08:00.0 chip-ID: 10ec:8168
           IF: eth0 state: down mac: 00:00:00:00:00:00
           Card-2: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express)
           driver: ath9k bus-ID: 02:00.0 chip-ID: 168c:002a
           IF: wlan0 state: up mac: 00:00:00:00:00:00
Info:      Processes: 192 Uptime: 1:11 Memory: 550.1/3708.7MB
           Init: systemd v: 215 runlevel: 5 default: 2 Gcc sys: 4.9.2
           Client: Shell (bash 4.3.301 running in tty 1) inxi: 2.1.28

********************************************************************************************

Anyone have any idea what to check next or what the issue is?
Tom Rowe

Four wheel drive allows you to get stuck
in places even more inaccessible.
rovernut
 
Posts: 90
Joined: 2013-11-20 10:50

Re: Problem connecting to TightVNCserver

Postby pylkko » 2016-06-05 22:02

wait, are you using GNOME? because it has it's own package (forget what it is called) that can handle vnc straight out of the box without needing to install tight or anything.
User avatar
pylkko
 
Posts: 1277
Joined: 2014-11-06 19:02

Re: Problem connecting to TightVNCserver

Postby ralph.ronnquist » 2016-06-05 22:58

Listening for VNC connections on TCP port 5901

It doesn't say, but ordinarily that's only on the lo interface, which is good practice security-wise.

Assuming you have ssh service on your Acer, you can use ssh port forwarding, e.g., using the via option for xvnc4viewer, or (perhaps) similar on other viewers. A manual port forwarding also works.
User avatar
ralph.ronnquist
 
Posts: 314
Joined: 2015-12-19 01:07
Location: Melbourne, Australia

Re: Problem connecting to TightVNCserver

Postby rovernut » 2016-09-13 09:25

Sorry about not getting back.
I'm using KDE on both.
But shortly after posting this I sent the laptop to by brother so I can't test anything.
I'll be getting it back from him in Oct so will follow-up then.
Tom Rowe

Four wheel drive allows you to get stuck
in places even more inaccessible.
rovernut
 
Posts: 90
Joined: 2013-11-20 10:50

Re: Problem connecting to TightVNCserver

Postby steve_v » 2016-09-13 11:13

IIRC you simply can't run GNOME3 on Xvnc - it provides no acceleration, which modern GNOME requires for some perverse reason. You might try tigervnc (the interwebs suggests this may work, but YMMV) X11VNC or GNOMEs built-in VNC server (if you only want to connect to the local desktop, not a managed session) or use a different DE.
rovernut wrote:I'm using KDE on both.
Er, really? KDE doesn't say "Oh no, something has gone wrong". As far as I am aware that message is from gnome-session (or possibly GDM, I don't actually use GNOME) KDE4 works fine with Xvnc IME.
steve_v
 
Posts: 681
Joined: 2012-10-06 05:31
Location: New Zealand

Re: Problem connecting to TightVNCserver

Postby rovernut » 2016-09-16 23:12

steve_v wrote:IIRC you simply can't run GNOME3 on Xvnc - it provides no acceleration, which modern GNOME requires for some perverse reason. You might try tigervnc (the interwebs suggests this may work, but YMMV) X11VNC or GNOMEs built-in VNC server (if you only want to connect to the local desktop, not a managed session) or use a different DE.
rovernut wrote:I'm using KDE on both.
Er, really? KDE doesn't say "Oh no, something has gone wrong". As far as I am aware that message is from gnome-session (or possibly GDM, I don't actually use GNOME) KDE4 works fine with Xvnc IME.
Yeah, My Thinkpad it KDE as is the Acer.
Tom Rowe

Four wheel drive allows you to get stuck
in places even more inaccessible.
rovernut
 
Posts: 90
Joined: 2013-11-20 10:50


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable